locked
Duplicated registered plugin registration steps after installing the solution RRS feed

  • Question

  • Hi,

    We are experiencing a weird behavior and was wondering if anyone has any idea why this is happening.

    After installing the updated solution from Dev environment to Test environment (the solution has already been installed in test and its being reinstalled to apply updates), many of the plugin registered steps get duplicated. This can be seen in plugin registration tool after the solution is installed.

    Any idea?

    Thanks.


    captainsina

    Thursday, March 28, 2013 2:58 PM

Answers

  • Hi,

    I've seen this many times - it's because the plugin steps in your dev environment have been deleted and re-created. This causes them to get a new GUID and so on import they are added as new steps rather than updating the previous ones.

    hth


    Scott Durow
    Read my blog: www.develop1.net/public     Follow Me on Twitter
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Friday, March 29, 2013 2:15 PM
    Answerer

All replies

  • Hi,

    I've seen this many times - it's because the plugin steps in your dev environment have been deleted and re-created. This causes them to get a new GUID and so on import they are added as new steps rather than updating the previous ones.

    hth


    Scott Durow
    Read my blog: www.develop1.net/public     Follow Me on Twitter
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Friday, March 29, 2013 2:15 PM
    Answerer
  • Hi

    I have also faced this problem earlier. This is because I have not updated the step in Dev, infact deleted the step and added a fresh step.

    Guid of the step changed and there, added a new step in test env. 

    What I did was, Uninstalled the solution from Test and imported a fresh solution having all the resources again.

    I took a notice of not to delete the step from dev rather to update the step and export it to Test.

    My problem was solved then.


    Regards, Karan Mittal If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".

    Saturday, March 30, 2013 9:05 AM