locked
Validation of viewstate MAC failed RRS feed

  • Question

  •  There is a small problem with a big faliure.. in the <form action ="default2.aspx">tag when i click the buuton 

    it shows the error has

    Server Error in '/' Application.

    Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that <machineKey> configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster.

    http://go.microsoft.com/fwlink/?LinkID=314055

    in this page  i have already done local system in the inetmgr.

    also i just switch to add two no from visual studio.

    pls its very kiiling.

    i have generated a machine key decrytion keys and all added to web.config in <system.web> but same problem.and also see

    ?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>

    in this link also in the iis i configured now localsystem but this is not going from web.config i dont think even re install will 

    solve out the problem.

    • Moved by Carl Cai Wednesday, June 25, 2014 9:33 AM (from vb) asp.net forum is more dedicated for these issues
    Tuesday, June 24, 2014 4:05 PM

Answers

  •  There is a small problem with a big faliure.. in the <form action ="default2.aspx">tag when i click the buuton 

    it shows the error has

    Server Error in '/' Application.

    Validation of viewstate MAC failed. If this application is hosted by a Web Farm or cluster, ensure that <machineKey> configuration specifies the same validationKey and validation algorithm. AutoGenerate cannot be used in a cluster.

    http://go.microsoft.com/fwlink/?LinkID=314055

    in this page  i have already done local system in the inetmgr.

    also i just switch to add two no from visual studio.

    pls its very kiiling.

    i have generated a machine key decrytion keys and all added to web.config in <system.web> but same problem.and also see

    ?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>

    in this link also in the iis i configured now localsystem but this is not going from web.config i dont think even re install will 

    solve out the problem.

    Hi,

    I am afraid that for web development issues, I would recommend you post them in https://forums.asp.net forum to get dedicated supports.

    In addition, you could have a check whether the following blog helps.

    http://blogs.msdn.com/b/tom/archive/2008/03/14/validation-of-viewstate-mac-failed-error.aspx

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Just Karl Wednesday, June 25, 2014 5:51 PM
    • Marked as answer by Just Karl Thursday, July 10, 2014 10:39 PM
    Wednesday, June 25, 2014 9:33 AM