locked
Solution!!! winss.exe resource problem RRS feed

  • General discussion

  • I've found the solution to the resource hogging problem I think.

     

    The solution is to disable/stop theses services under Services in Administrator Tools:

     

    "Peer Name Resolution Procotol" and "Peer Networking Identity Manger"

     

    I was having this problem and was writing this message which I was going to post to a support technician but now I've solved it, so this italic bit below is just for reference...

     

    I am having a problem with OneCare v2.0. Whenever the OneCare service is started (winss.exe), the process causes the computer to slow down by taking computer resources. I find that my CPU is at 100% all the time since installing OneCare v2.0.

     

    I previously had installed OneCare v1.6.

     

    I have formatted my hard drive and reinstall Windows XP in order to try and solve this problem but the problem still remains. If I end the winss.exe service through Services or through Task Manager, my computer's resources return to normal.

     

    I have 1.5GB of RAM, and recently installed 1GB of RAM to try and combat the problem, but this does not solve it.

    My hard drive has 70GB of total space and 30GB free space. I have an external hard drive attached via USB which I have excluded from scanning as it holds many installer files, which, according to the forums, may cause OneCare to slow down scanning.

     

    My interpretation of what is causing this problem has been highlighted on the forums, which is that OneCare is performing a mini-scan or 'one time' scan since first installation. Since there is no option to disable this I am not able to work through the problem with this information.

     

    I have tried running the Tune-up scan which I hoped would cause the mini-scan to cancel out, however, as my CPU is already slow, the Tune-up is taking longer than 24 hours to scan, which mostly slows down when it comes to the stage at scanning system files. To try and combat this, I have tried ending OneCare's processes using Services in Administrator Tools, but if I end the winss.exe service, the tune-up scan is cancelled as well.

    Something I have noticed is that alongside the winss.exe service soaking up CPU is that some of the instances in Task Manager called "svchost.exe" also seem to have high CPU percentages. If I end the svchost.exe instances (usually of which two are over 20% for all the time) then this does not solve the problem - the instances of svchost.exe then respawn.

     

    However I have noticed that if I end the two svchost.exe's, the windows, themes and start bar return to the classic style and after a few seconds, return to my predefined style. Also, I notice that the Volume control in the system tray refuses to open ("no mixer available"), and sounds cannot be played through Windows Media Player 11. However, I can still hear the computer's sounds such as Logon/Logoff/Startup/Shutdown/Recycle etc.

     

    Up to this point at writing this message I realised I could solve the problem myself instead of contacting support - all I had to do way trial-and-error on the Services in Adminsitrator Tools - maybe even trying to get the scan to work in Safe Mode / Diagnostic Mode.

     

    I kept stopping certain services under a manually configured diagnostic mode and just simply waited until the CPU hogging went down - and noticed that when I ended the "Peer..." services, this is exactly what happened.

     

    Whether this will solve other people's problems I don't know but I hope this will help some people in troubleshooting their own computers. Good luck!


    P.S.: I had exactly the same problem on my laptop as well, which is connected via my network router as part of my circle. The CPU was constantly down so I just disabled these two services and it returned to normal. I'm really glad it's solved so I hope that other people can use this method as a possible solution.

    Wednesday, August 15, 2007 1:01 PM

All replies

  • I moved your post here last night, but thanks for reporting your experience.

    -steve

    Thursday, August 16, 2007 6:15 PM
    Moderator
  • I had the same problem.  winss.exe and svchost.exe were consuming 100% of the CPU.  Disabling both "Peer Name Resolution Procotol" and "Peer Networking Identity Manager" stops the problem.  Starting those services again did not cause high CPU utilization, but I worry that restarting the onecare service or rebooting will cause the problem again.  I have not tested that theory yet though.

     

    Jason

    Thursday, October 25, 2007 1:23 AM
  •  

    I've tested this further, and the high CPU utilization problem will happen again following a reboot.  You must disable the services listed in the previous posts to prevent the problem.  I will try to report this problem to OneCare support.
    Tuesday, November 6, 2007 4:09 AM
  • I'm running into the same problem, with winss.exe growing to over 1.5 GB of virtual memory per Task Manager, since the auto-upgrade to OneCare 2.0! So I was excited to see this fix, only when I open the Administrative Tools/Services console I don't see "Peer Name Resolution Procotol" or "Peer Networking Identity Manger"! (I'm running a fully up-to-date WinXP Media Center). Any ideas as to other solutions, or where to find these services if I'm looking in the worng place?

     

    Thanks in advance ...

    Thursday, November 22, 2007 9:34 AM
  • I'm also having the same problem again on the desktop computer. It was extremely annoying because the tool support sent me is useless. I have uninstalled / reinstalled the net framework and all sorts and nothing has changed. OneCare on that machine keeps "Breaking" for no good reason. Ive had to put another AV on there temporary because im fed up of it keep doing it and i thought when onecare 2 is released i was hopeing it would be fixed. If not then i definately won't be re-newing my subscription early next summer and i'll go elsewhere for AV software which i don't want to do but it is becoming a joke.

    This has not happened with my laptop once yet, i also do not have the "Peer name resolution protocol" or "Peer networking identity manager" so im stuck as well.

    Also, whenever i try to load onecare when it starts doing it it just says it has stopped and to contact support. I can't be bothered contacting support again. It is apparent to me a fair number of users have this problem and i wish the developers would look into it already, something is causing onecare to break.
    Thursday, November 22, 2007 4:51 PM
  • Stephen - I have had the same problem and stopped it by ending the process winss.exe - but obviously I am now at risk!

    My Tablet laptop seems to have received an update to One Care this morning which reduced the problem ther, but my main PC remains clogged and the system idel is down to 60% on average.

    Are Microsoft aware this ais a majo problem and when will they resolve it?

    Thanks

    Roy

    Saturday, November 24, 2007 5:22 PM
  • I've checked on my XP Professional computer, and it doesn't have these services either.  However, on my Vista Ultimate computer, they are there and in Manual.  The only one that was actually running was the service which broadcast my information out (Peer Networking Identity Manager).  I stopped this service, even though I'm not experiencing the high CPU usage (or at least I wasn't attributing it to OneCare). 

    Also, I checked on my laptop (Toshiba Satellite with XP Media Center) and it doesn't have this either.  One question for everyone who doesn't have this service...  Are you running Vista in your network?  If (or even if not) have you applied the update to your XP computers that allows them to use the new network location that's included in Vista (Link-Layer Topology Discovery Responder).  I wonder if that doesn't replace those two services with something else.

    The question above can be posted to the people who have successfully found and disabled the Peer Networking services as well.

    Have a great weekend everyone:-)
    Patrick.
    Saturday, November 24, 2007 9:00 PM
  • I seem to have had some success following this suggestion, and found the peer networking services as follows:

    control panel/administrative tools/services. I disabled Peer Network Identity Manager, and immediately the CPU stopped maxxing out. I turned the service on again out of curiosity, and the CPU still seems to be running normally but I haven't re-started the computer either, so I suspect that the problem will come back again. A temporary and not very satisfying solution, which I REALLY hope will be dealt with soon by Microsoft.

     

    Big problems still remain: LOC shows a red logo, but I get the "not responding" message if I try to open it. I'm still unprotected from viruses and basically can't use the service at all.

     

    Tech Support has been unresponsive, after sending me a first e-mail with advice that was unhelpful.

     

    How much time do we have to lose for this ridiculous program?

     

    Patrick

    Monday, December 17, 2007 10:19 AM
  • Patrick, since you've apparently resolved part of the problem, I suggest that you reinstall OneCare at this point or continue to work with support. If you have not heard back from support in several days, please either post the case ID for follow-up or open a new case and reference the old one.

    -steve

     

    Monday, December 17, 2007 6:46 PM
    Moderator
  • hey, i was experiencing the same problem after installing 2.0 onto my laptop, altho the processor running at 100% CPU ONLY slowed down One Care itself, taking over 7 DAYS to actually complete one tune up, and over 24 hrs to complete a 10 min scan

    I've used your

    The solution is to disable/stop theses services under Services in Administrator Tools:

     

    "Peer Name Resolution Procotol" and "Peer Networking Identity Manger"

    solution, and it dropped my CPU right down, and improved the performance of my One Care, altho the CPU still fluxtuates a lot, however when i restarted my laptop the CPU problem return as the both
    "Peer Name Resolution Procotol" and "Peer Networking Identity Manger" had turned themselves back on.

    i turned them both off again, but i was wondering if there's a way to turn them perminantly off so i'm not having to turn them off every time i restart
    Monday, December 17, 2007 7:13 PM
  • I removed the Peer-to-Peer windows component under the Add/Remove Programs on my wife's system and hers is running fine now even after rebooting several times just to make sure it doesn't come back some way or another.

     

    It doesn't so I guess hers is fine now. She is on a Dell Dimension 4600 (older single core processor - Intel P4 3Ghz).

     

    Anyway, seems the Peer-To-Peer was loading hers down but not now.

     

    I haven't tried connecting her to the HUB tho (mainly cause she's on it now) to see if that would bring it back thru Onecare or not.

     

    Monday, December 17, 2007 8:31 PM
  • I'm not sure why it affects some and not others, perhaps it is hardware related - the NIC, for example. I haven't encountered the issue on a number of systems - some pretty slow and aging.

    -steve

     

    Tuesday, December 18, 2007 2:34 AM
    Moderator
  • You're right.  I'm sure that in some cases it may end up being older hardware being a factor in the problems.  But I should have been more clearer above.  By HUB I meant Onecare's PC Circle.  I was using my system (the HP with Vista) as the HUB of the circle.  I guess somehow on the installation of Onecare it enables or installs P2P.  So when I checked more into what specifically it was that was loading the CPU and memory down, it came down to the P2P settings like it had on so many others I've read here in the forum.  Once I removed that, everything went back to normal.  Since mine & her system are in the same room and the 3rd system is in the family room, I figured it was just as easy to do without the Circle.

     

    30+ years ago when I went to work on computers (in the USN), I had a chance to go into program writing (FORTRAN & COBALT).  Kept getting headaches.  So I stuck with the hardware side. Of course being in it that long it's hard not to learn, & in a lot of cases had to, how to get around in the programs & OS software that were being run on the systems.  You really have to understand a lot on both sides to be proficient in computer repair and building.  But the hardware, to me, was less of a headache.

     

    Don't know what in all Microsoft is going to have to do to get WLOC v2 worked out, but with all the different problems everyones having on different systems (new & old) they got a hard job ahead of them.

     

    Appreciate all the help and research here that others have done.  And this may be the best, if not the hardest way, for us at this end to get thru this.  So good luck to all.  And while some I've read on here are getting a bad taste for Microsoft, there's not a piece of software put out on the market that's not going to have a problem running in some system somewhere. So it's not only Microsoft.  They're all just trying to make a better product for consumers.  So you might want to just try and hang in there and eventually get thru this.

     

    By the way, as we get more proficient in resolving these issues we should start hinting to Microsoft about being given our Microsoft Certified Tech license  lol.
    Tuesday, December 18, 2007 10:07 AM
  • Oh yeah, and thanks RJC, good work!!

     

    Tuesday, December 18, 2007 10:08 AM
  • Thanks much.  Your description of the problem and solution were right on the money.  Coincidentally, the problem started occuring after I installed MS Office 2007.  Prior to that, One Care was performing relatively well.

    Thursday, December 20, 2007 1:48 PM
  • I had the same problem when I switched from Norton to OneCare. The virus scan was extremely slow and my apps were like stuck in syrup. Thanks to "What's Running", I was able to find that the Peer Networking Identity Manager service was the culprit. Removing the Peer to Peer Windows component solved the problem. I'm not sure what problems I will have with apps that use this component, if any.

    I just installed Office 2007 and my wife's and my laptops. Her laptop works fine and does not have the Peer to Peer component installed.

    It seems to me that this problem has been around long enough that the OneCare developers would have come up with a fix.
    Sunday, December 23, 2007 12:06 PM
  •  Old Geek wrote:
    I had the same problem when I switched from Norton to OneCare. The virus scan was extremely slow and my apps were like stuck in syrup. Thanks to "What's Running", I was able to find that the Peer Networking Identity Manager service was the culprit. Removing the Peer to Peer Windows component solved the problem. I'm not sure what problems I will have with apps that use this component, if any.

    I just installed Office 2007 and my wife's and my laptops. Her laptop works fine and does not have the Peer to Peer component installed.

    It seems to me that this problem has been around long enough that the OneCare developers would have come up with a fix.

    I believe that we will see a fix for this and a few other issues in a program update early in 2008. The solution is a little more than can be handled with the minor build updates - .10 to .12 to .14, and will need to be addressed in a more major update, but not as major as a 1.6 to 2.0 upgrade.

    -steve

    Sunday, December 23, 2007 5:56 PM
    Moderator
  • After lots of frustration and seemingly getting nowhere, I seem to have emerged from the darkness... I was having many problems, with CPU hogging, OneCare not starting, not allowing me to upgrade, etc. Had some contact with Tech Support, but what ended up taking care of the CPU problem was disabling peer-to-peer (I still don't know what consequences that may have, and would be glad to hear from someone who knows). The other problems, strangely, either worked themselves out or were somehow taken care by further OneCare updates. Anyway, the system is now working fine. So there does seem to be hope... Wish I could understand why.

     

    Thanks to all the people who have shared their hints and ideas here. Have a nice Christmas, everyone.  

     

    Patrick

    Monday, December 24, 2007 9:43 AM
  •  

    I don't have the peer services running or the networking components installed.  However, I did notice that this started happening right about the time when OneCare began wanting to "bond" with my daughters computer as a hub.  So, I'm giong back to my settings to see if I can go ahead and make my PC the hub and ensure that she's running the latest version too.  That's where I suspect this issue is coming from...
    Friday, December 28, 2007 4:36 PM
  • Have Win-XP-Pro w/SP2 and WLOC Upgrade to v.2. Have encountered QuickScan running for over 24hrs when said would take 10min., Also noticed that after update on first tune-up did NOT complete and manualy terminated. As am User and Admin., At this time, have not try'd to Dissable PEER setting as disscribed by others. Altho, I would think that this Problem would already have been fix'd. IF there is a Fix other than turning Off PEER Setting everytime you startup(when not inuse system is shutdown) it would seem that it is something that was missed in BETA Testing Before Release!?

        Will Post New Message after Restart,PEER Setting Disable, and Restart of AV/Spyware Scan.

     Posted 1205hrs 12-30-2007

    Sunday, December 30, 2007 8:07 PM
  • Unfortunately, the problem with the Peer service didn't appear until after release and a fix is forthcoming, but not yet implemented.

    -steve

     

    Monday, December 31, 2007 4:23 AM
    Moderator
  • Lots of good info from everyone... I feel at least a little closer to ridding myself of this headache.

     

    Downloading the 'Windows Live OneCare Ant Malware Cleanup Tool' , and running this program when 'OneCare cannot start' is a another temp fix solution.  However I have to do this everytime I reboot. . 

    I attempted to disable P2P process in Admin Tools/System from starting up again after reboot, but have not tested yet...

    I am running Windows XP home. 

     

    Wish me luck!  Hang in there, Everybody..

    Wednesday, January 2, 2008 3:18 PM
  • Dissabled ALL PEER settings after Pausing  AV_Scan. Restarted scan and ZOOM! Went on thru and did a Tune-Up

     on its own.(Evidently it completed the one I Stop'd after it ran for over 24hrs w/out completing.)

    Tho I Still do not like having to Undo PEER Settings inorder to have Scan run in its Suggest'd Time Frame?!

     21:15hrs 1-2-2008

    OH, I did get an Update Slash Reset of DATABASE .? May have Help'd with speeding things up ? I Hope!

    Thursday, January 3, 2008 5:18 AM