locked
New Router - Failed to setup Remote Web Access RRS feed

  • Question

  • I replaced my faulty Linksys router WRVS4400N with a new Linksys E4200 router. I am trying to setup Remote Web Access again but WHS 2011 could not configure my router via UPnP so I forwarded the ports (80 and 443) manualy. I verified with Shields Up whether the ports were open and they were.

    Everytime I try to access the Remote Web Access configuration page it indicates my router is not working and when I try to setup the domain name it comes up with the following error message: "An unexpected or unknown problem occured. Please wait a few minutes and try again" . I have tried this now a dozen times but I keep getting the same messages.

    Any help is appreciated because I do not want to re-install WHS 2011 if I can avoid it.

    Sander

    Monday, November 21, 2011 4:16 AM

All replies

  • Don't reinstall it, cause I did it, thinking that it would solve the same problem that I had, but again it didn't work.

    So don't bother.

    Perhaps the OS doesn't like some routers.

    I asked the same question a couple of times, and was advised to open port 443, which I did, but it simply refuses to setup.

    Apart from that, I guess there's no big deal, at least for me, to access my homeserver from far away, an ability I had with WHS v1,

    but vary rarely used. Anyway, it would have been a nice feature to have, since it is there.

    Monday, November 21, 2011 6:22 AM
  • I'm having the same issue.  I went from a Linksys WRT310N to the E4200.  I'm not sure what changed besides the hardware.  I setup up the router manually and that error still shows up.  Anyone else experiencing this?  I'm able to access my server on the road but that error showing up for 6 months now is driving me nuts.
    GIGABYTE EP43-UD3L, Q8400 2.66Ghz, 4GB RAM, 300GB SATA HD, ATI Radeon X1300 Graphics Card
    Saturday, January 28, 2012 10:18 PM
  • Same problem here with the Linksys E4200. VERY FRUSTRATING. :-/ I do (or did) use the remote access a LOT with my old D-Link router. Looks like I'll be going back to that one unless someone finds a workaround. Gawd knows it won't come from Microturd. :-/
    • Proposed as answer by John Hallows 2 Saturday, July 14, 2012 8:25 PM
    Saturday, July 14, 2012 8:09 PM
  • Same problem here. It seems to be a problem with the authentication when trying to setup UPnP on the router. It worked the first time I tried then broke its self and right now I can't get anything working. I made the mistake of turning off the web access to try and start over, so now I have nothing even though the ports are forwarded.
    Wednesday, December 12, 2012 10:31 PM
  • I have the 4200 v1, don't know if the version makes a difference. I did some digging around on the Cisco page and found someone recommending doing a 30/30/30 reset. You hold the reset button for 30 sec, continue to hold reset and unplug the router for 30 sec, plug it back in and continue to hold reset for another 30 sec. This will clear the NVRAM and put the router back to factory settings. I was then able to let the server set up remote access and eveyrthing is working.
    • Proposed as answer by Mouseskowitz Thursday, December 13, 2012 3:03 AM
    Thursday, December 13, 2012 3:03 AM
  • Okay, I believe that I've solved the problem. At least this worked for me on my Linksys E4200, and it might work for you too. Double check two things in your router Administration settings. I included screen captures on my settings at the end in case that helps.

    Step 1: Click the the Administration tab, click Management, and then, in the UPnP area, ensure that UPnP is set to Enabled.

    Step 2: Click the Applications and Gaming tab, click Single Port Forwarding, and then ensure that you have the following port exceptions (if not, create them) and also ensure that each of them is Enabled.

    • HTTP-External Port: 80, Internal Port: 80, Protocol: TCP, To IPv4 Address: (this is really important!) 192.168.1.xxx [where xxx is the IP address of your Windows Home Server]
      Note: For the first exception, use the drop down menu under Application Name to select HTTP, and then type the IP address. For the next two exceptions, you type an Application Name of your choosing, plus the ports and the IP address. 
    • Name1-External Port: 4126, Internal Port: 4126, Protocol: TCP, To IPv4 Address: (this is really important!) 192.168.1.xxx [where xxx is the IP address of your Windows Home Server]
    • Name2-External Port: 443, Internal Port: 443, Protocol: TCP, To IPv4 Address: (this is really important!) 192.168.1.xxx [where xxx is the IP address of your Windows Home Server]

    After doing this, open the WHS Dashboard, click Server Settings, click Remote Web Access, and then run the Automatically Configure Your Router step again. Should work. 

    So what happened to break my remote access? Well, in my case, the router assigned a different IP address to my WHS than the IP address that I previously used to create the 3 port exceptions above. And, it did so even though I had RESERVED that specific IP for the WHS client on the Setup tab/Basic Setup/DHCP Reservation table!! :-/ I removed the old, incorrect IP reservation for my WHS, and then reserved the new IP. We'll see if the router overrides my "reservation" again. If it does, it gets bricked, and I go back to D-Link, never to return to Linksys again.

    I hope this helps someone resolve this annoying issue!

    Here are screen captures for the two steps above:

    Step 1

    Step 2

    • Proposed as answer by John Hallows 2 Wednesday, March 20, 2013 2:35 AM
    Wednesday, March 20, 2013 2:35 AM
  • I ended up upgrading to the 4500 thinking the 4200 was bad. Turns out that the real problem was with the server. I did a reinstall on the server and everything is working great now. I haven't gone to the trouble of hooking up the 4200 again to see if that fixed it with that as well.
    Wednesday, March 20, 2013 3:35 PM