locked
CRM Page Default Customization RRS feed

  • Question

  • Hello all, CRM beginner here.

    Is there a way to set the default page for the CRM?

    An example, everytime I open my CRM, I want it to automatically open to my Leads, let's say, with Elizabeth's Leads as the view. I know we can do this from the 'Personalize Workplace' at the bottom of CRM left pane. However, for some reason, when I open my 'Personalize Workplace', I don't see that option to set my default CRM page. Under the 'General' tab of my 'Personalize Workplace', I only have the 'Set Records per Page', 'Advanced-Find Mode' and the CRM email tracking options. On the other side, when I login as an administrator, I can set the CRM default page (which unfortunately only applied to that administrator only). Is there a way so that a user like me can set my own default page and tab?

    Another question, I also want to set a specific view to be the default view in that entity everytime I open CRM. For example,
    everytime I open my CRM, I want it to automatically open to my Leads, let's say, with Elizabeth's Leads as the view. When I login as administrator, from the 'Setting' and 'Customize Entities', I can actually customize a view to be the default one for that entity. However if I set a particular view as the default (when login as admin), it is going to be applied to every user. Is there a way to set a default view on an entity for one specific user only?

    I really appreciate your help! Thanks in advanced!


    -Elizabeth K.

    Wednesday, February 13, 2008 7:55 PM

Answers

  •  

    Hi.

     

    Goto:

    [CRM Install dir ] \ CRMWEB \ tools \ personalsettings \ dialogs \ personalsettings.aspx .

     

    1. Open the file with Visual Studio, make sure no one (from your company) added unsupported code to it.

         If so, remove the additions and see if it helps.

     

    OR

     

    2. The file also exists in the installation disk try replacing the current file and see if it helps.

     

    OR

     

    3. Insert a script tag that alerts the personalsettings.aspx so you could open it as a standalone browser.

     

    //personalsettings.aspx page

       <html>

       <head>

       <script>

            alert( location.href );

       </script>

     

    4. Do a Ctrl A + Ctrl C on the alert and copy it to a notepad.

    5. Copy the URL in a new browser window and try locating the missing section using iedevtoolbar.

     

    If the missing section is not there this would definitely be a bug.

     

    Good luck

    Adi

     

    Friday, February 15, 2008 2:34 PM

All replies

  • Hi Elizabeth,

     

    1. As far as I know, you should be able to set your default page like you are able to do with Administrator role. I dont think there is any right for changing my default page.

     

    2. You are right, one default view is set for all the users and there is no feature to do it for only one user. There is a work around discussed by David. : http://mscrmuk.blogspot.com/2007/12/providing-different-default-views-for.html

     

    Wednesday, February 13, 2008 10:50 PM
    Moderator
  •  

    Hi.

     

    Login as admin and navigate to Elizabeth role under settings à business unit settings à user roles à choose Elizabeth role.

    Under business management tab you have user settings, check that you have at least user create writes.

     

    In any case, even if you don’t have sufficient writes the default tab and page should be grayed out, but you can still see them.

    Check that no one entered code into the file under  CRMWEB/tools/personalsettings/dialogs/personalsettings.aspx page, just to be on the safe side.

     

    Cheers,

    Adi

    Thursday, February 14, 2008 4:39 AM
  • Thanks alot for the reply Ady and Umar. Regarding Ady's post above:

     Adi Katz wrote:

     

    In any case, even if you don’t have sufficient writes the default tab and page should be grayed out, but you can still see them.

    Check that no one entered code into the file under  CRMWEB/tools/personalsettings/dialogs/personalsettings.aspx page, just to be on the safe side.

     



    However, even though I copy paste the Administrator role to Elizabeth's current role, then login as Elizabeth on her own machine, I still cannot see the page default option (not even grayed out; it's not there at all). In fact, no user (except the Administrator) can set their own default page.

    Could this possibly be a bug? If yes, could anyone please help me fixing this bug?

    Also Adi, about the file CRMWEB/tools/personalsettings/dialogs/personalsettings.aspx, is there a specific address where I can find this file? I did a search but still cannot find this file.

    Thank you in advanced!


    -Elizabeth K.

    Thursday, February 14, 2008 10:02 PM
  •  

    Hi.

     

    Goto:

    [CRM Install dir ] \ CRMWEB \ tools \ personalsettings \ dialogs \ personalsettings.aspx .

     

    1. Open the file with Visual Studio, make sure no one (from your company) added unsupported code to it.

         If so, remove the additions and see if it helps.

     

    OR

     

    2. The file also exists in the installation disk try replacing the current file and see if it helps.

     

    OR

     

    3. Insert a script tag that alerts the personalsettings.aspx so you could open it as a standalone browser.

     

    //personalsettings.aspx page

       <html>

       <head>

       <script>

            alert( location.href );

       </script>

     

    4. Do a Ctrl A + Ctrl C on the alert and copy it to a notepad.

    5. Copy the URL in a new browser window and try locating the missing section using iedevtoolbar.

     

    If the missing section is not there this would definitely be a bug.

     

    Good luck

    Adi

     

    Friday, February 15, 2008 2:34 PM