locked
Error "Outlook Integration Errors" RRS feed

  • Question

  • I have a testing environment with OCS2007b3 running on a single server and two workstations running vista/office2007/OC2007b3.  All components appear to be functioning with the exception of the following.

     

    On both test workstations, OC reports an error condition with a red "!" in the systray.  When reviewing the error, it reads as follows:

     

    "There was a problem connecting to Microsoft Outlook.  Communicator could not get calendar or Out of Office information from the Exchange Server.  Communicator will automatically continue to retry.  If this problem persists, contact your system administrator."

     

    The test environment is running Exchange 2007 with all roles but UM on a single server.  Outlook<->Exchange connectivity appears to be functioning correctly on both workstations.

     

    Any idea where to look to determine why the communicator client is unable to integrate successfully with outlook?

     

     

    _Randy

    Monday, April 9, 2007 8:18 PM

Answers

  • This is a known issue that has been fixed in the Release Candidate build of Office Communicator.
    Monday, May 7, 2007 4:07 PM

All replies

  • I am having the same issue. I have read the documentation but cannot find any help.
    Friday, April 13, 2007 8:03 PM
  • I have the same error on the following components:

    - Windows Vista Ent.

    - Office 2007 Ent.

    - OCS2007 Public Beta

    - Exchange 2007

     

    I suspect its a misconfiguration between exchange 2007 & OCS, but where?

     

    Could anybody help us out?

    Wednesday, April 18, 2007 9:56 AM
  • I have same error:

     

    - Windows XP.

    - Office 2007 PRO.

    - OCS2007 Public Beta

    - Exchange 2007

     

    Sad(

    Monday, April 23, 2007 7:28 AM
  • Randy,

     

    In Office Communicator, under Tools>Options, the bottom part of the Personl tab is for the Personal information manager. Please verify that the 'Automatically retrieve Out of Office settings from Outlook' and 'Update my status based on calendar data' options have been selected. Also, can you verify the build of Office Communicator you are running? You'll find this information under Help>About Microsoft Office Communicator.

     

    Thanks,

     

    Chad A. Lacy

    OCS 2007 Beta Support

    Monday, April 23, 2007 12:41 PM
  •  

    Chad,

     

    Having the same problem so also posting my information:

    I have also verifyd the options, and they have been selected!

     

    Version: 2.0.6090.0 (Microsoft Office Communicator 2007 Public Beta)

     

    Thanks,

     

    Maarten

    Monday, April 23, 2007 12:53 PM
  • Same problem here:

     

    I have two machines:

    - 1 Windows XP with office 2003 : Integration works fine

    - 1 Vista machine with office 2007 : Integration with outlook does not work

     

    Version: 2.0.6090.0 (Microsoft Office Communicator 2007 Public Beta)

     

    Johan

    Monday, April 23, 2007 3:57 PM
  • My entire office is having this problem. Our environment is the same at C@T's. Does OCS 2007 have problems with Outlook 2007?
    Monday, April 23, 2007 6:20 PM
  • Yes.. Those options are selected.  The build of OC is:

    2.0.6090.0

     

     

    Monday, April 23, 2007 9:35 PM
  • My problems are solved!

     

    If you have multiple profiles in outlook you have to set the profile to integrated with Office Communicator to the default profile.

     

    Configure your profiles via Control Pannel.

    Click mail

    Click Prompt for a profile to be used

    Start outlook and select your profile to integrate with Office Communicator Client

    And select this profile to be the default.

     

    Integration problems should be resolved now

     

    Greetz,

    Johan

    Tuesday, April 24, 2007 9:48 AM
  • What if you only have one profile?
    Tuesday, April 24, 2007 1:00 PM
  • This isnt my issue either.  I have only one profile on the machine.
    • Proposed as answer by sergio3d Thursday, October 8, 2009 1:21 PM
    Tuesday, April 24, 2007 1:39 PM
  • This is a known issue that has been fixed in the Release Candidate build of Office Communicator.
    Monday, May 7, 2007 4:07 PM
  • Is the release candidate build of the client available to us now?

     

    Monday, June 25, 2007 5:16 PM
  • I have installed the official released software, but I have the same issue with the Outlook integration error. Has anyone found a solution to this?

     

     

     

    Tuesday, October 23, 2007 12:48 PM
  • You need to make your Exchange profile that you want to connect to MOC as the default profile

     

    Deli

     

    Tuesday, October 23, 2007 1:24 PM
  • I found the solution to this. I had to request and install a certificate on the Default Website on the Exchange Server. The certificate I was using was from the internal PKI service.

    Thursday, November 1, 2007 10:02 AM
  • This isnt my issue either.  I have only one profile on the machine.

    I find solution few min. ago, maybe this can help you to.
    start->settings->control panel->mail->under "profiles" click "show profiles"..
    now, in my case there was "default outlook profile" and "Backup of default outlook profile", first I thought this "backup" is normal system configuration but when i deleted that "backup" profile and checked "default outlook profile" problem with Office communicator was gone!

    regards,
    sergio
    Thursday, October 8, 2009 1:27 PM
  • I found another possible solution to this issue.  I tried everything listed above without success.
    I thought I would post this information since I spent so much time trying to find a solution to this without success.


    I fixed the problem by creating a reverse DNS entry for my OCS server in the email domain of the clients email address.
    For example,
      My AD domain is Company.int
      My Email users use ExternalCompanyName.com

    I removed the PTR record for OCS.Company.com and created a PTR for the OCS server's IP address pointing to OCS.ExternalCompanyName.com
    That solved my particular problem.

    Hope this helps someone else out a little.
    Monday, December 28, 2009 1:39 AM