locked
Cannot install the Connector updates / Manual way to Uninstall Connector? / KB2705129 RRS feed

  • Question

  • It seems I have a Windows Home Server 2011 Connector installation in limbo. It was working until the Windows Updates today.

    It doesn't show up in Programs and Features in the Control Panel so I can't uninstall it.

    It seems to be working (Launchpad/Dashboard), but the Server doesn't see my computer being connected so I can't backup.

    After running Windows Update on my WHS 2011 today, I get the error on my Windows 7 Pro 64-bit client laptop:

    Cannot install the Connector updates

    Windows Home Server 2011 Connector updates were not installed. Restart the computer to resolve the issue. If the problem persists, uninstall the connector software and install it again.

    No matter how many times I restart, it doesn't update, and again, I cannot uninstall it.

    Another clue from Reliablity Monitor:

    Windows Home Server 2011 Connector Unsuccessful application update

    Windows Installer installed an update. Product Name: Windows Home Server 2011 Connector. Product Version: 6.1.8800.16399. Product Language: 1033. Manufacturer: Microsoft Corporation. Update Name: Update Rollup for Microsoft Windows (KB2705129). Installation success or error status: 1603.

    Wednesday, August 15, 2012 5:04 AM

Answers

  • I'm happy to say that Update Rollup 4 has allowed me to install over my corrupt connector installation.
    Wednesday, December 26, 2012 4:16 PM

All replies

  • Try a reboot or two and patience and see what happens or you can try the brute force way.

    The brute force way is to uninstall the connector from your client computer, reboot, and then click on your server in the OTHER DEVICES section of the network tab.  This will reinstall the connector software on your client to the version stored on your server.  Sometimes this method results in a second copy of your client on the server.  You you should then create a new backup and then delete the old copy of your client on the server unless you want something in its backup history.


    ...JJC...

    Thursday, August 16, 2012 2:35 AM
  • You may have missed parts of my post. I have tried many restarts.

    The Connector Uninstaller is not present in the control panel -- I can't uninstall it. I don't follow your suggestion about OTHER DEVICES and network tab. Can you clarify?

    Thanks.

    Thursday, August 16, 2012 6:26 AM
  • if you open the network tab your server should show up both in the computers and the other deveices section.  selecting the server in the other devices section starts a dialog to install the connector.

    The connector uninstall is in the programs and features section of the control panel and is named windows home server 2011 connector.


    ...JJC...

    Thursday, August 16, 2012 6:50 AM
  • Hi,

    Please check if you can uninstall and reinstall connector in Clean Boot to avoid software conflicts. For the detailed steps, please refer to the following Microsoft KB article:

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/929135

    What’s the result in Clean Boot?

    Regards,


    Arthur Li

    TechNet Community Support

    Thursday, August 16, 2012 8:51 AM
  • Hi Carlo,

    You can go to Microsoft Connect Site to file a bug and upload your log. Their product manager will help you to resolve your problem.

    https://connect.microsoft.com/SBS

    Thursday, August 16, 2012 9:46 AM
  • Again,

    "Windows Home Server 2011 Connector" is NOT in the Programs and Features in the Control Panel. It's as if the Connector installed and was working and for some reason the uninstaller didn't get included in the Program Features control panel.

    I will try to see if it somehow shows up in Clean Boot.

    I have filed a bug in Microsoft Connect, too.

    Update:

    I just tried Clean Boot to see if the uninstaller shows up. No, it doesn't.

    I also tried installing the Connector in Clean Boot. It still fails at the very last step.

    Thursday, August 16, 2012 6:26 PM
  • Are you running by any chance Visual Studio 2012 and hence .net 4.5?  I also have the same issue the past few weeks. I am considering uninstalling some of the updates if upgrading from RC to RTM on VS2012 doesn't do the trick.

    -- Free AV for WHS : http://whsclamav.sourceforge.net/

    Friday, August 17, 2012 9:39 PM
  • Hi.  I have had the exact same problem since the roll up. Still searching the web for clues.... Since day one I have had all sorts of issues with this Connector!  I have had to play all sorts of tricks to actually get it to work from the beginning (i.e. the FilePending regedit thing, etc., etc.) and just when I had it all running this bl00dy update killed every computer connected...
    Saturday, August 18, 2012 12:49 PM
  • Oh and I don't have any option to un-install via control panel either. I'm going to call microsoft about this in the morning.
    Saturday, August 18, 2012 12:52 PM
  • No, I have not installed Visual Studio 2012, but installed .NET Framework 4.5 AFTER all this Connector problem.

    I think it's a problem with the Connector or at least the latest update.

    I've filed a bug report in the Microsoft Connect Website regarding this. Please help me escalate it: https://connect.microsoft.com/SBS/feedback/details/758165/august-14-2012-windows-7-updates-fail-to-update-whs2011-connector-kb2705129#details

    Sunday, August 19, 2012 12:33 AM
  • I have .NET 4 only, which was what it was before when it all worked (prior updates).. I will uninstall anyway and see what happens

    Sunday, August 19, 2012 6:12 AM
  • Are you using WSUS by any chance on your server? 
    Sunday, August 19, 2012 6:47 AM
  • So I uninstalled Net 4 - tried running the connector again, and FindMyServer - no joy.  As Carlo says above, there is no Launchpad program installed in the control panel (to un-install), but she is definately still there. Anyway I ran for the hills by uninstalling KB2705118 from my server and guess what - my clients can connect again!

    Thanks for the "update" Microsoft! That made my weekend just that little bit more fun.... Yeah.  Oh the only other thing I did which did not work anyway was disable the intranet updates for the client (from WSUS). Don't think this had anything to do with it.  As I said, just remove the roll up and all is well.  Until next time....

    Sunday, August 19, 2012 9:15 AM
  • I just have been exposed to the very same issue and tried many things unsuccessfully. This is clearly a bug that needs to be addressed ASAP.

    hj

    Sunday, August 19, 2012 9:56 PM
  • When you say worked, I still assume that the backup, etc is now back to normal, but the uninstaller is still not present in Programs and Features in the control panel?
    Sunday, August 19, 2012 11:15 PM
  • I'm having the same issue, and have reverted the server but only 2 of the computers have reconnected to the server, the others are still getting the above message.
    Tuesday, August 21, 2012 10:48 PM
  • When I say worked, I mean that the PC clients are able to connect after un-installing any connector that's present and re-running the connector software - after removing the roll-up.

    The dam roll-up re-installed again the other day on my server (I didn't deny it properly) so I had the same issue again.  Just removed the roll-up and restarted the clients and was able to re-connect.  I have not take things any further, at the moment I just need it to work!

    Sunday, August 26, 2012 10:42 AM
  • Hi

    it appears I have run into the same issue.  The error message I get is ""Windows Home Server 2011 Connector updates were not
    installed. Restart the computer to resolve this issue. If the problem still persists, uninstall the connector software and install it again."  This is on a Windows 8 Pro machine (although I doubt the client OS is of relevance).

    It did show up today after some updates where [automatically] applied to the server.

    Have added my logs to the existing entry on connect (https://connect.microsoft.com/SBS/feedback/details/758165/august-14-2012-windows-7-updates-fail-to-update-whs2011-connector-kb2705129). However, it appears that the bug was closed already with seemingly no meaningful response.

    Would, however, be seriously interested in a fix to get my home server back into production - it does not feel good with no functional backup.

    Thanks for any hints

    Hubert


    -- Thx & Best Regards Hubert Daubmeier

    Wednesday, December 12, 2012 9:43 PM
  • I wonder if it would work to uninstall and reapply the rollup that caused the Connector to not update correctly? It is KB2757011.

    Thursday, December 13, 2012 3:11 AM
  • I have uninstalled that Rollup on the server (so far it is not yet automatically reinstalled). Then rebooted the client. Some automatic client update seems to have occured, with the error message remaining unchanged.

    -- Thx & Best Regards Hubert Daubmeier

    Friday, December 14, 2012 12:30 PM
  • Try reinstalling the rollup on the server. Then log into dashboard from the computer you're having problems with while signed in under the offline mode, I'm guessing you can't sign in with lauchpad. For me this is what helped my computers that weren't updating the client finally work, although this wasn't the problem I was having. Hope it works for you.
    Friday, December 14, 2012 7:53 PM
  • Unfortunately no luck; the error messages remain unchanged.

    -- Thx & Best Regards Hubert Daubmeier

    Saturday, December 15, 2012 2:58 PM
  • I'm happy to say that Update Rollup 4 has allowed me to install over my corrupt connector installation.
    Wednesday, December 26, 2012 4:16 PM