locked
No restore possible due to missing network adapter RRS feed

  • Question

  • I`m running 5 Computers on the homeserver one with Vista64 has beeen backed up regulary but when my primary disk failed i was not able to restore it due to the missing network connection. I changed the nic from internal asus realtek  to D-Link DGE-528 no result same problem :no network connection.
    The other computers hooked to  the same network no problems, when I startet a short test for trying out the procedure with the recovery disk and the drivers from the windows home server driver directory. Even though I startet up in extended mode for loading up drivers ,which did not pass the Windows certification.
    By the way the adapters (the built ind as well as the DGE 528) worked with no problems in that configuration

    I really would appreciate some help and my proposal for future releases  would be to implement some more possibilities for loading up network drivers.

    Or giving out a list of nic boards which are already ready to go with the microsoft home server.
    Because I dont want  to guess around for some more days in trying out nic`s which may work .

    Thanks a lot Klaus

     
      
    Monday, October 19, 2009 9:57 AM

Answers

All replies

  • For restore you will need 32 bit network drivers, please read How to update Realtek NIC drivers during Bare Metal Restore. Hope this helps, and I agree there's room for improvement there.

    Monday, October 19, 2009 11:08 AM
    Moderator
  • Or attach the disk to another running client PC as secondary drive and follow the FAQ How to restore a client PC, if the network connection does not work in the CD based restore environment.
    Best greetings from Germany
    Olaf
    Monday, October 19, 2009 6:58 PM
    Moderator
  • I am having a similar problem with Vista Ulltimate, 32 bit.  I needed to restore my system which has multiple hard drives.  This is a Dell xps420, with and  Intel 82566CD-2 gigabit NIC built in.  I can get the  driver installed and the restore started, but at the end of restoring drive C: the Restore process stops with and error message that the network connection is lost.

    This leaves my system in a non-bootable state, and I have to use the Vista CD/DVD to do a repair of the boot sector.  Once this is done it appears that Drive C: has been restored and the system runs fine.

    Fortunately, I didn't need to restore the other drives anyway, but it was many hours wasted.

    This is a repeatable problem.  My guess is that the Restore process overwrites the NIC driver and then tries to access it again for the next drive.  Seems sort of a dumb way to do things.

    Scott
    Monday, December 7, 2009 5:09 PM
  • I have read that this behavior can happen, if the DHCP address lease time (configured somewhere in the router) was to short and due for renewal.
    Best greetings from Germany
    Olaf
    Tuesday, December 8, 2009 3:21 PM
    Moderator

  • WHY does Microsft not update the information /
    The LAURA JONES Post  is wrong and should be removed.

    Here is the correct information.





    Lara Jones [MSFT] | Program Manager
    Community Support and Beta | Windows Home Server Team
    Windows Home Server Team Blog
    Connect Windows Home Server
    Windows Home Server

    Thank you for the information. Your procedure does not work but it allowed me to develop a way to allow the restore disk to work.

    The procedure you outlined does not work for the following Realtek NIC
     
    RTL8111B/RTL8168B/RTL8111/RTL8168
    RTL8111C/RTL8111CP/RTL8111D(L)
    RTL8168C/RTL8111DP


    Here is what you must do.

    Download the Vista (WinServer 2008) Driver
    instead of the WinXP (WinServer 2003) Driver


    Here is how I modified your procedure so that it WORKS for any of the above Realtek NIC

    Using the Windows Home Server Dual Boot Computer Restore Disk (Release Date 7/16/2008), the NIC drivers for the Realtek  family of network cards will need to be manually updated using the Vista (WinServer 2008) Driver.
         
         The Windows Home Server restore CD will indicate the "NIC driver for the restore CD is present"; 
         however, this driver WILL not work and there will be no network connectivity.
         The solution is to download the drivers from the  Realtek site and install them during the restore using
          a USB key as outlined in the  process below.

     

    Note: Just passively placing the drivers in a folder on the USB key including the drivers from a previous backup as instructed in the Restore Disk User guide will not work as the existing drivers are already loaded.

      You must follow the steps below.

     

    1.       Download the network drivers from the Realtek Website:

     

    http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false


    a.
          
    Download the Vista (WinServer 2008) Driver.

         Note: I actually downloaded all the Windows XP and Vista drivers (4 different sets) and deleted all the
         drivers marked 64 bit
    (64 bit drivers WILL not work)


    2.
          
    Extract all the zip files onto the ROOT of a USB flash without a folder and plug the USB flash into the client PC.

     

    3.      Then apply the downloaded NIC driver(s) with the Windows Home Server Restore CD

     

    a.       On the detect hardware screen, select the appropriate time/currency format and keyboard/input method

     

    b.      Detect hardware dialog will detect the Realtek network device RTL8168C/8111C Family PCI-E Gigibit ethernet NIC
    (NDIS 6.0 but it will not be usable because of hardware and driver incompatibility.

                   

    c.       Manually update the driver from the USB flash

                                                                                     i.           Select the “Show Details…” button

                                                                                   ii.           Press the “Install Drivers…”

                                                                                  iii.          Push “Scan” button to scan for new/updated d rives

                                                                                   iv.        A dialogue box will pop up:

    "Drivers were found for your hardware.

    Click OK to see all detected hardware."

                                                                                 vi.            Select OK

     

    d.      Verify that you have updated the Network driver.

    You should now see your specific NIC hardware listed in the “Detect Hardware” dialog screen as
    Realtek PCIe GBE family Controller.

    Continue following the restore disk prompts

    Stew Gordon
    Thestewman@msn.com

    • Proposed as answer by thestewman Tuesday, December 8, 2009 10:47 PM
    Tuesday, December 8, 2009 10:47 PM
  • Mainboard drivers are often a bit difficult to handle in the Windows PE 2.0 environment. You may find, that 32 Bit Vista drivers must be extracted on the USB stick to be recognized.
    A downloaded .exe file would not be enough. (Although I would see Windows 7 32 Bit drivers work as well.)
    Since you have Windows 7, you could also try the method described in this thread to create a Windows 7 based bootable USB stick with the necessary components for a bare metal restore.

    Bare metal restores - as well as the Restore Wizard from within a running operating system - are targetting volumes (which you can create with integrated Disk Management in the restore wizard), which must have at least the same size as the volume had, which you want to restore. You can also restore directly to the old volumes given they have no file system issues, so at least formatting is recommended. Also within a running operating system you cannot overwrite the volume, which runs on that OS or represents the volume, on which it's boot files are located (often, if you had run XP on the first drive and Win7 on the second, both drives will be protected while Windows 7 is running).

    Best greetings from Germany
    Olaf
    Monday, February 8, 2010 6:52 PM
    Moderator
  • I suggest trying the x-files version of the Restore CD.  It has many additional NIC drivers and has allowed me others to restore using the "as advertised" simple methodology when all others failed.  Just create a new bootable Restore CD from the ISO image and give it a try:
    The download link for Version 1.2 is in this blog:
    http://xfiles.breakinghomeserver.com/2009/11/30/whs-client-restore-v1-2/ 

    Tuesday, February 9, 2010 7:04 PM
  • I reinstalled the new drive as Boot drive in my wife's PC, but it will not boot from drive. I'm guessing that there is no boot sector??
    i also tried using the Windows 7 disc, and selecting repair, but no OS shows up (folders and files are definitely there)

    I need help!



    did you try to set the boot partition active?
    Did the original machine have the 100 MB partition or a hidden volume from the PC maker, which had not been backed up and therefore not restored?
    If you boot from the Windows 7 DVD, you say the startup repair fails, if I understood correctly. (Some screenshots of this process are also found here.)
    So you can try to open a cmd prompt and enter a few commands there:
    diskpart
    list disk
    select disk X
    (X represents the number under which your disk is shown)
    list part
    select part 1
    (if 1 is the partition with your operating system)
    active (this marks the selected partition as active)
    exit

    Try to reboot.

    Best greetings from Germany
    Olaf
    Tuesday, February 9, 2010 7:28 PM
    Moderator
  • If you did "list part" - did you see a partition 1?
    Select which ever partition shows up with "select part #" then doing active
    Wednesday, February 10, 2010 12:40 AM