locked
Sending C3P request failed

    Question

  • Hi there,

     

    we have a OCS Enterprise deployment going on at a customer. The setup currently contains two OCS Front-End servers behind a F5 BigIP HLB. The HLB is acting in a routing configuration. All traffic to and from the Frond-Ends travels through the F5. On ONE of the FE we keep getting the messages below:

     

    Event Type: Error
    Event Source: OCS User Services
    Event Category: (1006)
    Event ID: 30989
    Date:  20-5-2008
    Time:  10:42:33
    User:  N/A
    Computer: SERVER1
    Description:
    Sending C3P request timed out. Conferencing functionality will be affected if C3P messages are failing consistently.

    Sending the message to https://server2.domain.com:444/LiveServer/IMMCU/ timed out. Error code is 2EE2.
    Resolution:
    This can happen if the destination server above is overloaded and cannot process messages.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

     

    Event Type: Error
    Event Source: OCS User Services
    Event Category: (1006)
    Event ID: 30988
    Date:  20-5-2008
    Time:  10:46:54
    User:  N/A
    Computer: SERVER1
    Description:
    Sending C3P request failed. Conferencing functionality will be affected if C3P messages are failing consistently.

    Sending the message to https://server2.domain.com:444/LiveServer/IMMCU/ failed. Error code is 2EFD.
    Resolution:
    Check the destination server to see that it is listening on the same URI and it has certificate configured for MTLS. Other reasons might be network connectivity issues between the two servers.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    To be clear, we see these events on SERVER1. In the event it states that wants to connect to the second server in the Pool.

     

    I also posted an issue on the Server2 machine. On that machine we get:

     

    Event Type: Error
    Event Source: OCS MCU Infrastructure
    Event Category: (1022)
    Event ID: 61009
    Date:  20-5-2008
    Time:  10:52:50
    User:  N/A
    Computer: SERVER2
    Description:
    The process AVMCUSvc(892) failed to send notifications to the focus at https://<HLB FQDN>:444/LiveServer/Focus.
    Failure occurrences: 2053, since 20-5-2008 2:19:50.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    and

     

    Event Type: Error
    Event Source: OCS MCU Infrastructure
    Event Category: (1022)
    Event ID: 61009
    Date:  20-5-2008
    Time:  10:33:57
    User:  N/A
    Computer: SERVER2
    Description:
    The process IMMcuSvc(2452) failed to send notifications to the focus at https://<HLB FQDN>:444/LiveServer/Focus.
    Failure occurrences: 129, since 20-5-2008 10:01:57.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

     

    Any help would be appreciated.

     

    Wim

     

    Tuesday, May 20, 2008 9:26 AM

All replies

  •  

    Hello!

     

    Your Computer may has too many trusted root certification authorities.

     

    Maybe this can help you:

     

    To resolve this issue if the January 2007 update for Microsoft root certificate program members is installed, remove unnecessary trusted root certification authorities. To do this, follow these steps:

    1. Click Start, click Run, type MMC in the Open box, and then press ENTER.
    2. On the File menu, click Add/Remove Snap-in.
    3. In the Add/Remove Snap-in dialog box, click Add.
    4. In the Add Standalone Snap-in dialog box, select Certificates, and then click Add.
    5. In the Certificates snap-in dialog box, select Computer account, and then click Next.
    6. In the Select Computer dialog box, select Local computer, and then click Finish.
    7. In the Add Standalone Snap-in dialog box, click Close.
    8. In the Add/Remove Snap-in dialog box, click OK.
    9. Under Console Root, expand Certificates (Local Computer), expand Trusted Root Certification Authorities, and then click Certificates.
    10.

    Delete the certification authorities that are unnecessary.

     

    Good luck!-)

     

    Greetings Maxwell

     

    Wednesday, June 18, 2008 11:27 AM
  • Sounds like you have your SNAT/DNAT setting wrong.  If your F5 is running in DNAT mode you have to update the pool to let it know.  Check the command line doc on how to do that.

     

    Thursday, June 19, 2008 3:04 AM
  • I had a similar issue and did not solve any of the solutions available on the internet. Since I have got 2 front end servers in enterprise pool with F5 load balancer and one of the front-end server and virtual pool was in same subnet, I just added a entry in the host file as xx.xx.xx.xx (front-end server ip address) virtual pool name to fix the issue.

    All sorted!

    Cheers

    Thursday, October 22, 2009 3:07 PM