locked
WHS won't backup computers RRS feed

  • Question

  • I can't get my WHS to backup my computers. It appears to be something wrong in WHS. I says it can't access some sort of global cluster.dat file with a big long name. I tried manually backing up and it tries but fails with always the same error message. I logged into the server OS  directly from the computer and tried to do a scan of the drive and this did not fix it either. Is there a way to repair these database files so I can get my server working again? I am using the first version of WHS with the XP type interface.

     

    Perry

    Monday, May 23, 2011 1:08 PM

Answers

All replies

  • So it did work but now it has stopped? If so, did you do anything to it in the intervening period?
    Monday, May 23, 2011 1:27 PM
  • It worked but it was running out of storage about a month ago. We also had several power outtages about the same time. I added another drive to the pool about a week ago and it installed correctly and read as healthy. Since running out of space, no backups have been succesful since April 20, 2011 or so. I suspect one of the database files is currupt but I have not idea how to repair it. I can access my shared folders and even access old backups but it won't complete new backups. I have 1.4T of free space. Also the date was off on the server. It was one day ahead. I fixed that and no changes.

    Here are some screen captures that may help. The new storage was added about a week ago. The problem seems to predate the new drive which is understandable since I ran out of disk space about then.

    http://www.motorcycleproducts.org/WHS-Issues/

    Perry


    Monday, May 23, 2011 1:49 PM
  • I don't suppose you back up your server?
    Monday, May 23, 2011 2:21 PM
  • No I have not been backing it up. That is one thing I have not gotten around to. I guess I could use Acronis to do it but I need to get it working first.

    Perry

    Monday, May 23, 2011 2:41 PM
  • I wouldn't use Acronis, rather the built in backup which I believe came with PP3. Agree you need to get it working first - let me have some more thoughts.
    Monday, May 23, 2011 3:24 PM
  • I guess I need to do a command line chkdsk instead of the utility that comes with windows. I really have not had many issues with WHS. It has been doing its thing until now. I would think that it is trying to append a file that is not there or corrupt. If I can get past this one error the server seems to be working fine otherwise. How do I find out what PP I am running. I have autoupdates on so I assume it has loaded all the current updates and I checked and it did not find and new updates. All of the computers that are being backed up have logs similar to the screen shots I posted a link for. What does the toolkit buy me? How do I access the backup utility in PP3? I assume I would store this backup on a networked drive on another computer?

    Perry

    Monday, May 23, 2011 3:59 PM
  • Yes, Power packs were delivered by autoupdates. My memory is clearly failing me as server backup was introduced with PP1 - here is an extract from the PP1 release documentation:

     

    Home Server Backup

    ·      You can can now back up and restore your home server shared folders to an external hard drive.

    ·      When you add a hard drive to your home server, you are given an option to use the hard drive to back up your home server shared folders. When you select this option, your home server appears in the Computers & Backup tab. You can then use Backup Now to back up your shared folders to the hard drive.

    ·      You can view and restore your home server shared folder backups on the Computers & Backup tab.

    The full document can be found here:

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=f219dd13-3d9a-4506-8be2-fbcc4e195415&displaylang=en

     

    So actually my statement above was wrong as this backs up the server shared folders only.

    Phil


    Monday, May 23, 2011 4:45 PM
  • Looks like I am running service pack 2 from what I can tell. I did the chkdsk on D: last night and it found no errors so why does it have trouble accessing that .dat file on D:?

    Perry


    Perry
    Tuesday, May 24, 2011 5:19 PM
  • Ok it looks like it gets to about 25% through the backup and then dies. I also get an error message that says that backup service is not running on the server.

    To follow up I did a repair on the database and tried to do a backup and it still stalled at 25%.

    I next tried to do a backup cleanup and it said it could not because there was an error in the backup service.

    Perry



    Tuesday, May 24, 2011 6:33 PM
  • Service Pack 2 is different to PP2. If you look at System Properties, General it will show Service Pack level (mine is 2) but to find out which Power Pack you have you need to open the Console, Home Server Settings, Resources and at the top right it will show Windows Home Server with Power Pack X (mine is 3).
    Wednesday, May 25, 2011 12:29 AM
  • I ended up having to delete the whole database of backed up computers.

    Here is how I did it.

    http://www.clarkezone.net/default.aspx?id=532d3d54-b935-40e7-b020-beb0ca1d653a

    I logged into my server directly and erased the files using file explorer on the server. The files were 1.18T all combined. I am backing up complete disks again. I think something got messed up when I ran out of storage space.

    Perry


    Perry
    • Marked as answer by Perry114 Tuesday, May 31, 2011 3:58 PM
    Tuesday, May 31, 2011 3:58 PM