locked
WHS2011 Disk Management RAID-5 failed redundancy every startup RRS feed

  • Question

  • Ok, so I finally got my server up and running, but I am having problems with my RAID.

    I have 6x 2TB hdds attached to the system in non-raid (AHCI) mode. I would RAID them on the motherboard, but it does not support RAID-5. So I have gone into Windows Disk Management and setup the 6 drives as dynamic disks and put them in a RAID-5. It took nearly 24 hours to "resync" but then shows healthy.

    But here's the problem: Any time the computer restarts, whether it be from a power failure, manual restart, or even a scheduled restart for updates, the volume goes to a "failed redundancy" mode, and I must manually go into disk management and bring the volume back online (which takes another 24 hours), but returns to healthy everytime.

    Now, I was previously using Windows RAID 1 with these disks on Windows 7 before upgrading to WHS2011. The only time it when to a failed redundancy mode was if there was a power failure. And if it happened, it would automatically begin resync as soon as Windows 7 started again.

    So my question is, is the software RAID in WHS2011 supposed to fail redundancy everytime the computer restarts? It doesn't sound like normal behavior to me. It wouldn't be a big deal if it would at least automatically start a resync when booted up.

    Any input in this issue would be appreciated. Thanks.

    Tuesday, September 13, 2011 5:18 PM

All replies

  • No, this isn't normal behavior for Windows software RAID in general, or in Windows Home Server 2011 (unsupported though it may be). I would look to BIOS settings (are drives set for staggered spin-up to reduce power supply load at boot, for example?) and hardware issues such as failing HBA, cable issues, or even a weak power supply.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, September 13, 2011 5:31 PM
  • The drives are not set to staggered spin-up, they all start at once. The power supply is a 650W power supply and far exceeds the power requirements of the computer. The Host adapters are functioning properly and I tested all the hard drives as well.

    The strange part is when the drives so to failed redundancy, they are all still online, but I have to click reactivate to make them resync.

    Tuesday, September 13, 2011 5:58 PM
  • Well, all I can really tell you is that Windows RAID 5 is less "safe" than hardware RAID 5 for a variety of reasons, and it doesn't offer very good performance. I would really recommend you consider buying a good quality RAID HBA (preferably one with hardware acceleration, OCE, and ORLM, though you'll spend in the hundreds for it) and using that instead of Windows software RAID.

    Or you can research causes of software RAID issues in Windows Server 2008 R2 (the base OS for Windows Home Server 2011). For that, you might start with the Windows Server setup and deployment forum, here:

    http://social.technet.microsoft.com/Forums/en-us/winserversetup/threads


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 14, 2011 2:18 PM
  • Thanks for the reply. I always search online for answers before I go post.

    About the hardware RAID... The reason I am using the software RAID is because my motherboard has 6 SATA ports, but they only support RAID 0,1, and 10. Due to the amount of hard drives, anything other that a RAID-5 is rediculously inefficient. I am not looking for blazing peformance, just lots of storage that won't be obliterated with a single HDD failure (as happened recently with my desktop workstation). As a matter of fact, I expect it to be quite slow; with an Atom D510 (1.66 GHz Dual Core) managing WHS2011 and 6 hard drives in RAID-5, I know that is a lot of calculations on the fly. The reason for choosing WHS2011 and using this existing comuter I have is because of my financial constraints. I cannot afford to buy an expensive RAID card, and if I could, I hardly believe they make one that will fit in a PCIe x1 slot in a MiniDTX computer.

    On another note, my motherboard just completely crapped out me last night while attempting a reinstall of WHS2011 (bought a permanant 160 GB HDD for it). So it will be a week or two before I get a warranty replacement, but I am hoping that there was something wrong with the motherboard that may have been causing this issue.

    I will post again when I get the replacement board with the result from the new board.

    Wednesday, September 14, 2011 4:37 PM
  • Motherboard issue sounds like a definite possibility. Good luck with that. :)

    As for RAID in general, you do know it's a "high availability" solution, not a "data protection" solution, right? For data protection, you want to back up your data and take the backup off site.


    I'm not on the WHS team, I just post a lot. :)
    Wednesday, September 14, 2011 5:40 PM
  • Yes, the motherboard is what I'm hoping to be the problem as well.

    I have to agree with you, on terms of mission-critical data, RAID is no substitute for a good backup. However, I'm not looking for a backup solution. I don't expect the computer to burst into flames or get stolen or anything like that. It isn't going to be setup with data that is irreplaceable. The server is basically going to be the backup location for my main desktop, laptop, and serve as storage for my HTPCs. It will mostly be storing all of my recorded TV shows from my various PCs, as well as my ripped Blu-Rays and DVDs. I own all of the Blu-Rays and DVDs, and all the data for the PC backups will still be located on the origin PC if there's any problem, so all the data will either be replaceable or also located elsewhere, it would just be shame to lose everything from a single drive failing. It takes a very, VERY long time to rip Blu-Rays and encode them in a format playable by WMC (in the ballpark of a DAY per Blu-Ray).

    I originally had the computer setup with Windows 7 and the drives in RAID-10, but at just under 6 TB, I ran out storage space. I am disappointed Microsoft doesn't do RAID-5 with Windows 7, (even though the option is there but greyed-out). I was originally looking at getting Windows Server 2008 R2, but the cost of it was so high I couldn't justify. When WHS2011 came out for just $50 and I read it was based on the WS 2008 R2 kernel, I figured it would support RAID-5, which I am glad to see it does. I'm hoping the problem will be resolved with a new MB and everything will work as I expect after that.

    Wednesday, September 14, 2011 6:10 PM
  • OK, so I finally got my replacement motherboard. It turns out the old motherboard was not causing my issue. My RAID-5 still goes into failed redundancy after every startup.

    I tried installing a fresh instance of WHS2011 and it did not change the issue.

    Wednesday, October 19, 2011 11:04 PM
  • Hi, I install WHS 2011 on a board with ICH9R chipset, and my RAID 5 configuration work until it start a process who use almost all the ressources of de CPU, so I decide to spanned de drive instead of use RAID 5 configuration and the performance are awesome. I had a configuration of 2 500GB in RAID 1, 4 drives (1TB, 1TB, 500GB and 500GB) in RAID 5 for a total of approx. 1.5TB and the rest of the space spanned (1TB) and I think the RAID Array software have a hard time to manage that. I am not sure if I had put the bios into RAID instead of AHCI will change something.
    Tuesday, December 20, 2011 3:16 AM
  • I am having the same problem with the ichr10 chipset :(
    Saturday, June 16, 2012 4:35 PM
  • A reliable RAID 5 solution is not only a matter of having a decent ($$$) hardware RAID controller card, it is also a matter of getting the appropriate hard drives. Typical desktop hard drives are not built for RAID 5 setups as explained in this FAQ by Western Digital.
    Monday, July 16, 2012 10:05 AM
  • I was running a pair of raid 1 arrays on an X58/ICH10 chipset motherboard but both with desktop drives. I won't name the manufacturers here but the ones I would have thought of as being good needed 3 replacement drives in as many years yet the other lesser make drives gave no issues at all. What makes this odd is mirrored drives are accessed exactly the same as single drives so should have had no problems directly attributable to the configuration

    I did have 2 separate 4 disk raid 5 hardware level raids in my WSS box one again on the motherboard and the other on a SiL3114 controller and also made with desktop spec drives but these gave no problems.

    Having archived many of the files and switched back to WHS2011 the motherboard I have used is an H61 chipset which does not support raid on the integrated SATA controller so have implemented a Server 2008 R2 software raid. This has been fine with music and picture libraries and is also a Time Machine destination for my iMac. Its performance is not great, noticeably slowing when uploading the file store en mass but now loaded works fairly well but only time will tell how reliable it will be. 


    25 years of loving (and too often hating) everything Microsoft.

    Monday, July 16, 2012 1:07 PM