locked
Cannot Import Excel Data into Tabular Cube; Microsoft.ACE.OLEDB.12.0 provider is not registered RRS feed

  • Question

  • We've tried numerous suggestions over the past few days but have been unable to import data. I created a spreadsheet in Excel and even though I can successfully test my connection and even preview the data, when I attempt to import it I get the following error: The Microsoft.ACE.OLEDB.12.0 provider is not registered on the local machine. We see that this error has been addressed several times on this site and others however, none of those suggestions work for us. Here are my specs and some of what we have tried so far:

    Windows 7 64-bit
    MS Office 2010 64-bit
    MS SQL Server 2012 (using SQL Server Data Tools for cube construction)

    Failed Solutions:
    Downloaded and installed AccessDatabaseEngine_x64.exe
    Downloaded and installed 2007 AccessDatabaseEngine
    Downloaded and installed 2007 Office Driver Connectivity Components
    Downloaded and installed IIS 7 and attempted to adjust parameters
    Modified Connection string and Extended Property of Excel
    No Build option under Project > Properties (Only Deployment and screen completely different then screenshots shown online)
    Top ten most common answers given for this problem

    BTW: We're following along with McGraw-Hill Delivering BI with MS SQL Server 2012  chap13, pg 524

    Wednesday, August 8, 2012 12:44 PM

All replies

  • Hi. I am also having the same problem and have tried most of the 'solutions' you mention. Have you had any luck solving this?
    Wednesday, August 29, 2012 3:10 AM
  • We have moved on from this book because we couldn't find an answer. However, I do believe we figured out the problem though it has been a couple of weeks now so the solution that follows may not be correct. What I vaguely recall us doing was discovering we had the wrong instance of Analysis Services installed. We had to do a complete reinstall of SQL Server. Trying to do the install by only adding needed features did not work. Instead we had to go through the entire process as if SQL Server was never installed. Doing that we were able to add the correct Analysis Service (I apologize but which Analysis Service goes with which cube [MDX or Tabular] completely slips my mind at the moment). I believe we discovered this because we had two different bit systems that prevented us from accomplishing the task.

    I'm still new to this but if my memory serves me correct (and it has been known to be faulty), you need two different instances of Analysis Services installed if you want to use both MDX and Tabular cubes. I hope that this information is correct. Please advise me to rather it works for you or not so that I can modify this thread properly. Good luck!

    Wednesday, August 29, 2012 1:34 PM