locked
Cannot add Windows Home Server share subfolder to Windows 7 Library - "Not Indexed" RRS feed

  • Question

  • I am trying to add a *subfolder* of my user share to my Win7 Documents library, i.e.
    \\HOMESERVER\USERS\Dan\Subfolder

    When I do this, I receive a message that it cannot be added because it is not indexed.

    However, I *can* add the parent folder (DAN) or the grandparent folder (USERS).  This makes no sense.  When I check the Indexing Settings of the WHS, it is set to index "SHARES" (great-grandparent folder) and all is well with Indexing status. 

    What is going on?  Help :-)

    BTW: This is WHS PP3 (RTM of PP3) and Win7 x64 fwiw.

    Dan Holme
    MVP SharePoint Server


    Dan Holme, Intelliem
    Wednesday, November 25, 2009 8:56 PM

All replies

  • Hi Dan,
    since the self made subfolders of the shares in D:\shares on the Home Server are more or less tombstones pointing in reality to folders on different disks on the WHS, I could imagine, that these cannot be indexed directly. This may cause the issue you see.
    Best greetings from Germany
    Olaf
    Wednesday, November 25, 2009 9:47 PM
    Moderator
  • I just double-checked:
    I'm running the same configuartion and have no problem adding a user share (I have full access) to the Library.
    So it should work for you.

    Not really helpfull. Currently I have no idea what might be wrong but I have the feeling Olaf might be pointing in the right direction?

    - Theo.

    No home server like Home Server
    Wednesday, November 25, 2009 9:54 PM
    Moderator
  • Do you currently have any files in that subfolder? I get this message if I'm trying to add an empty share/folder to the library. Even though the folder is being indexed it looks like the folder appears unindexed unless there's at least one file in there. After dropping a file in there it may not work immediatly. Give it some time to index.
    • Proposed as answer by kariya21Moderator Thursday, November 26, 2009 9:48 PM
    • Unproposed as answer by Dan Holme Sunday, November 29, 2009 2:39 AM
    Thursday, November 26, 2009 1:38 AM
  • I just had the chance to test here adding an exisiting folder with files, and it worked.
    Created a new folder, and it did not work.
    I think, the indexing will have to be done by the server itself, so it allows adding new locations to the client only with an delay and only, if these folders are part of an indexed structure.
    Best greetings from Germany
    Olaf
    • Proposed as answer by kariya21Moderator Thursday, November 26, 2009 9:48 PM
    • Unproposed as answer by Dan Holme Sunday, November 29, 2009 2:39 AM
    Thursday, November 26, 2009 11:02 AM
    Moderator
  • I tested each of these proposed answers and none of them work.  I also tested this in ANOTHER share (software) and determined that the (poorly designed) behavior of the features is this:

    1) The SHARE can be included in a library (e.g. Software or Users)
    2) A SUBFOLDER of the share can be included in a library
    3) A SECOND LEVEL subfolder CAN NOT BE INCLUDED in library...

    Test results
    - \\HOMESERVER\USERS\Dan\Subfolder can not be added (even after it was indexed, etc.)
    - \\HOMESERVER\USERS\Dan can be added
    - \\HOMESERVER\Software\Subfolder\Subfolder can not be added
    - \\HOMESERVER\Software\Subfolder can be added
    - \\HOMESERVER\Software can be added

    Sadly, I cannot even add a NEW shared folder to a library, even though the shared folder lives under D:\Shares (which is indexed).  I'll give it a day to see if indexing "catches up" but it's not looking good.

    Dan Holme, Intelliem
    Sunday, November 29, 2009 3:38 AM
  • I was running into this same problem, and I think I have found a possible (partial) solution... If you make a network share "Always available offline", Windows 7 will allow you to add the share to a Library.

    So, I made the share I wanted to add "Always available offline" (right click on the folder in Explorer to enable this).  Then, I added the share to my Library.  Finally, I went back to the share and changed it so it is no longer "Always available offline".  My share is now in the Library, as desired.  I have a warning that says "Some library features are unavailable due to unsupported library locations. Click here to learn more..."  I haven't yet figured out what features are unavailable, but so far it does not seem to be a big problem...

    Hope that helps.

    Damon

    Monday, December 7, 2009 4:56 AM
  • Good catch Dan.  Been running into this issue.  Offline files are not an option when talking about hundreds of gb's in my software folder.

     

    Thanks for posting your find.

    Thursday, January 13, 2011 6:55 PM