locked
synctoy seems to mis some files RRS feed

  • Question

  •  

    I just started using synctoy and run it on my mp3 folder. I tried to copy that to an external harddisk. The first time it only seemed to copy about half of my files. I tried it again with echo and now most of the files copied. But if I check the file count in explorer there is still a difference. I tried the other actions as well with preview and that does not change anything. My options are set for all files.
    Friday, November 14, 2008 10:38 PM

Answers

  • Hi _Riemen_

     

    SyncToy ignores these files:

    • Desktop.ini
    • Thumbs.db
    • and SyncToy metadata from other folder pairs that are store in your Left folder.

    If the difference in files you see is not huge, I am sure that is because SyncToy excluded these files I just listed.  There is usually about one Desktop.ini file per subfolder.   

     

    Let me know if this answered your question,

     

    Maria del Mar Alvarez Rohena - MSFT

    Monday, November 17, 2008 9:58 PM

All replies

  • Hi Appie01

     

    The ECHO Sync Action is meant to be used for one-way sync's from Left Folder to Right Folder.  If you added files to your external hard disk folder (rigth folder), you will not see them in your left folder.  In addition, with ECHO, any other modification (update, add, delete) perform on your right directory will not be propagated to the left folder.  If you want both of your MP3 stores to be identical, you should change your sync action from ECHO to Synchronize.

     

    Tell me a bit more about your setup:

    • Are you doing any modifications in your right folder?
    • Did you create a synchronization task for yor MP3 folder to run in the background, or did you just click on Run on the sync toy UI?  It could be the case that you used the UI and did not wait for the echo to copy all files to yoru external hard disk.  If you cancel the sync session, it will not finish copying all files.
    • What options did you set for this Folder Pair?

     

    Maria del Mar Alvarez Rohena - MSFT

    Monday, November 17, 2008 7:01 PM
  •  

    Exactly the same Problem for me:

     

    Tried to copy my musik-files to an external disk.

    Its a large folder with over 5000 MP3, some WMA, desktop.ini, and JPGs for album covers.

     

    first copied some of them manually, but aborted this. then tried to use SyncToy to copy the rest using echo.

    When i show properties of the 2 folders in explorer, I see that there are some files less in the new folder.

     

    Any Ideas?

    Monday, November 17, 2008 8:06 PM
  • Hi _Riemen_

     

    SyncToy ignores these files:

    • Desktop.ini
    • Thumbs.db
    • and SyncToy metadata from other folder pairs that are store in your Left folder.

    If the difference in files you see is not huge, I am sure that is because SyncToy excluded these files I just listed.  There is usually about one Desktop.ini file per subfolder.   

     

    Let me know if this answered your question,

     

    Maria del Mar Alvarez Rohena - MSFT

    Monday, November 17, 2008 9:58 PM
  • Hello

    I further investigated about this issue and found the following:

     

    Synctoy (x64 on Vista) seems to have some problems with german umlauts in file-names.

     

    What I did was as follows:
    First I copied the files to my Western Digital World Edition from my external USB-HD, which was connected to the USB-extension-port of the NAS-drive.

    For some reason (maybe because of the embedded-linux-system), the drive had some problems with files with umlauts, like ä, ö, ü,... in filenames, although these filed are copied correctly from Vista to the NAS-drive. These characters were chamged to some strange symbols during this.

    So I stopped this, attached the USB-drive to my Notebook and tried to copy the folder to the NAS via Sync-toy and echo-mode.

     

    Sync-toy seemed to copy all the files, but did not delete the wrong files with strange symbols instead of umlauts. So some files were duplicated. That was why I thought Synctoy would miss these files.

     

    Besides that, Synctoy changed all the umlauts to _ while copying, although copying these files manually via Vista works correct.

     

    Could you please investigate about Synctoys behavior with special characters?

     

    Greetings

    Tuesday, November 18, 2008 7:16 PM
  • Could you please clarify something about this statement - "Besides that, Synctoy changed all the umlauts to _ while copying, although copying these files manually via Vista works correct"?

     

    What is the exact setup when SyncToy did this?

    - What is the source drive? How were you connected to it?

    - What is the destination drive? How were you connected to it?

    - What were the settings of the folder pair? Echo/Synchronize, etc.?

    - Give us an example of a file that had special characters on the source and ended up with _ on the destination - which you're sure was done by SyncToy?

     

     

    Friday, November 21, 2008 7:17 AM
    Answerer
  • Thanks for your help Maria. I was just going from left to right and it was the desktop.ini files that made up the difference.

     

    Albert

    Friday, November 21, 2008 8:22 PM
  • Hi Albert

     

    Thanks for letting us know.

     

    Maria del Mar Alvarez - MSFT

    Friday, November 21, 2008 8:26 PM