locked
Unable to restore client - USB Recovery key not working "Invalid partition table" prior to loading setup [no hardware problems] RRS feed

  • General discussion

  • Hello all,

    I've been completely unable to make a functioning USB recovery key/flash drive. I create one through the Dashboard...->other tools->Create recovery USB, but each time it is used, it generates the error message "Invalid partition table", then halts the boot process before it even enters the restore utility.

    I've tried just about every combination of USB->HDD, USB->CDROM, etc in the bios to ensure that it gets selected, as well as F12, etc and it certainly tries to load the drive. I noticed that there a few other methods to create a restore USB device by a manual distpart/bootsect, but they have also failed. As a result, I've tried to load via a 8g NTFS and an 8g FAT32 flash drive with all of the setup files. I even got desperate and burned them onto a cdrom to no avail....

    After I'm done, or if it does not try to load from the USB based on the BIOS drive order, it simply loads Win7 back where it started from....arg...

    I'm just wondering what else I'm missing

    • Custombuilt hardware - 1Tb SATA x3 on Gigabyte mobo
    • WHS 2011, 64bit [No problems] - Retail version from Newegg
    • Windows 7 Pro 32bit [No problems; restoring to an earlier backup prior to installing Windows 8]
    • PNY 8g flashdrive
    • Kingston 8g flashdrive

    Thanks!!!!

    • Changed type Andy Qi Tuesday, April 30, 2013 9:46 AM
    Saturday, April 20, 2013 12:20 PM

All replies

  • Have you tried creating a bootable flash drive from e.g. Windows 8 installation media to see if your PC will boot from that?

    I'm not on the WHS team, I just post a lot. :)

    Saturday, April 20, 2013 3:15 PM
  • Hello Ken,

    Thanks for the input. Still not able to load WHS recovery - I've been able to boot into the Windows 7 backup restore program with a USB drive. 

    So, that puts me at:

    2g USB: Automated WHS -> Hangs at boot

    16g USB: Win7 recovery (boots no problem - its a FAT32 formatted drive), Hangs at boot for WHS. No difference with bootsect /nt52 

    8g USB: Win7 recovery (Boots no problem); Automated WHS (a FAT32 filesystem)-> "invalid partiion table'

    8g USB: Manually copy setup files (NTFS filesystem) -> ignores the drive

    USB CDROM for Win7: Boots no problem

    Still loosing this fight...Any other ideas? 

    Thanks


    • Edited by Nevin Leiby Wednesday, April 24, 2013 4:58 AM
    Tuesday, April 23, 2013 6:28 PM
  • Just for reference and to help anyone else having the same problem, here is what I had to do:

    Thanks Ken and Drashna from WGS, your tips helped tremendously.

    Discussion on WGS here 

    ------------------

     

    1) I used both an 8g and 16g USB flash drive

    2) Use the Windows 7 USB/DVD tool (downloaded online) to create the USB recovery key on my Win7 x86 machine. Using the manual bootsect method was not successful on my machine. Use the Win7 32bit ISO image as the source ISO to create the USB key. Using the Win7 64bit ISO as the source ISO resulted in an error message saying that bootsect would not run properly. (? I'm guessing that it's an improper method or the fact the recovery itself is done as a 32bit process even though WHS is a 64bit OS). At no point was the WHS USB Recovery Key tool used.

    3) Insert the newly created USB recovery key into the WHS. Copied the contents of the

    "C:\Program Files\Windows Server\Bin\ClientRestore" from WHS over top of the existing files created by the Windows 7 USB/DVD tool. Note this was NOT the "C:\Program Files (x86)\..." on the WHS even though I was restoring a Win7 x86 machine

    4) Reboot with flash in drive. Front panel USB slot worked.

    5) [DEL] Enter Bios-> Advanced config->Boot order

    6) If the flash drive is bootable, it will appear LAST on a list of ~4 items. For each reboot, it would have to be moved FIRST. Setting the boot order to USB-HDD by itself or through the [F12] boot sequence is NOT sufficent. This step must be done for the USB key to work. If the USB key is NOT bootable, it would NOT be listed and it would be ignored despite all efforts done elsewhere. This step had to be done each reboot.

    7) Save bios config -> reboot

    8) [F12] Change the boot order to the USB-HDD. Note that step #5 was necessary even if the boot order was changed with F12.

    9) WHS Recovery tool begins

    ------------------

    (...And now WHS recover hung up restoring the OS partition on a large disk. But I can get it from here!)


    Step #6 was very frustrating because even if a properly prepared USB recovery key was made, it would not be used. At no point was the WHS USB Recovery Key creation tool helpful - it always produced the 'invalid partition table' error message

    ---------------

    Drashna's suggestions:

    Do you have a copy of the original disk for the client restore (or an ISO of)?  If so, use the Windows 7 USB/DVD Tool to create the disk.

     

    Otherwise ...follow this: http://www.wikihow.c...-a-USB-Bootable

    And then copy the contents of "C:\Program Files\Windows Server\Bin\ClientRestore" to the USB drive, and see if that works.


    The Windows 7 USB/DVD tool... the "7" part is really a misnomer. It works for most ISOs. Even some non-windows one.The big thing is that the tool makes the partition bootable (if the usb drive is capable of it) automatically. Instead of having to pull up diskpart and doing it yourself (and risk wiping a drive).  

     

    Once it's "created", if you had to use a different ISO, you can delete (not format) the contents and put the contents of "C:\Program Files\Windows Server\Bin\ClientRestore" onto the disk (that's what the tool on the dashboard does, albiet automatically).

     

    The link though, is instructions on how to do make the usb flash drive bootable manually (be very careful). 


    Monday, May 13, 2013 6:03 AM