locked
HomeServer 2011 RC1 cannot configure draytek router. RRS feed

  • Question

  • I have Home server 2011 RC1 everything seems to be working as planned except Remote access. I have have tried setting up the router using UPNP and setting the port forwarding manually as specified in and earlier Forum post that showed the settings for my router Draytek Vigor 2820n. I can confirm ports 80 and 443 are open (www.canyouseeme.org) but 4125 remains blocked. The remote setup wizard in Dashboard simply says the router cannot be configured as PNP is turned off....... if I manually configure the router it fails after a lengthy verification.

    I have searched the forums but cannot find a solution, I have noted Draytek and UPNP is flaky but manual port forwarding does seem to work either, any advice would be appreciated

    regards  Bruce Henwood

    Wednesday, February 23, 2011 8:29 AM

Answers

  • For what it is worth, my router is an ISP supplied one incorporated into a wireless unit. It is non UPNP.

    Changing the port forwards from my WHS v1 to the WHS 2011rc simply did not work. Remotely logging in still took me to the older v1 machine. I though I was going crackers as checking the port forwards many times showed that they were definitely pointing at the 2011RC.

    A soft reboot from the router web menu did not fix the issue. The unit required a complete power off for 30 seconds. After this the new port forwards worked as expected and I could get to the 2011rc machine. Obviously the soft reboot was not clearing the routing tables.

    Not sure whether you have tried a total power down of the router but in my case it's what resolved the issues.

    Dave


    The Frog on the Lilypad at Home
    • Marked as answer by awdxs Wednesday, February 23, 2011 8:40 PM
    Wednesday, February 23, 2011 8:29 PM

All replies

  • Hello bruce,

     

    Its no help, But I too have the exact same problem on my Vigor 2820n

     

    Brgds

    Nick

     

    Wednesday, February 23, 2011 3:17 PM
  • This seems to be a problem with many routers.  port 4125 is not necessary.  I've had it working without it.  The best thing to try is to ignore the dashboard warnings, set up your domain, and just try it out.  WHS also tells me that my router is not working, but all the services work.  Also reserve your servers IP.  Let me know if that works for you.  You should be able to skip setting up the router with the wizard, and just be able to set up a domain.
    D.W.
    Wednesday, February 23, 2011 4:00 PM
  • fwiw I have a Draytek 2820Vn. I manually forwarded (port redirection) 80 & 443 to WHS 2011 and remote access works. Router IP and Model are both shown as Unknown.  Automatic UPNP fails for me also. 
    Wednesday, February 23, 2011 8:09 PM
  • For what it is worth, my router is an ISP supplied one incorporated into a wireless unit. It is non UPNP.

    Changing the port forwards from my WHS v1 to the WHS 2011rc simply did not work. Remotely logging in still took me to the older v1 machine. I though I was going crackers as checking the port forwards many times showed that they were definitely pointing at the 2011RC.

    A soft reboot from the router web menu did not fix the issue. The unit required a complete power off for 30 seconds. After this the new port forwards worked as expected and I could get to the 2011rc machine. Obviously the soft reboot was not clearing the routing tables.

    Not sure whether you have tried a total power down of the router but in my case it's what resolved the issues.

    Dave


    The Frog on the Lilypad at Home
    • Marked as answer by awdxs Wednesday, February 23, 2011 8:40 PM
    Wednesday, February 23, 2011 8:29 PM
  • I have the same setup Vigor 2820n and WHS2011rc Vail running on a test rig.

    Draytek routers have never worked UPNP, I have managed to get port forwarding to work but for my test rig I have just added it as a DMZ host on the router and it works fine. I would rather not do this in the long term but it is fine for testing purposes.

    It might be worth noting that the latest firmware for the 2820 routers killed the ability to loopback from your local network to the remote web login of your Windows Home Server using your homeserver.com domain name, you have to use the local IP address to connect to the server login page from within your local network.

    hope this is of some help

    murray_s


    If it isn't broken don't worry I'll soon have it in bits to see why!!!!!!!
    Wednesday, February 23, 2011 9:49 PM