none
MSMPIsetup.exe does not install on a Windows 10 Enterprise VDI / Application Error 1000 RRS feed

  • Question

  • Hello,

    I tried to install msmpisetup.exe to a Windows 10 Enterprise 1903 VDI because another software depends on it.

    Sadly the installation fails to start and I get following Application Error in the event log:

    Log Name:      Application
    Source:        Application Error
    Date:          16.12.2019 15:33:19
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      2v1001.pulspower.com
    Description:
    The description for Event ID 1000 from source Application Error cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    msmpisetup.exe
    10.0.12498.5
    5bcf6108
    unknown
    0.0.0.0
    00000000
    c0000409
    4e4c11a0
    f58
    01d5b41dc3140a41
    C:\temp\msmpisetup.exe
    unknown
    ca8d8024-f517-428c-a966-5c89a94fff24

    The handle is invalid

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2019-12-16T14:33:19.822644500Z" />
        <EventRecordID>2265</EventRecordID>
        <Channel>Application</Channel>
        <Computer>2v1001.pulspower.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>msmpisetup.exe</Data>
        <Data>10.0.12498.5</Data>
        <Data>5bcf6108</Data>
        <Data>unknown</Data>
        <Data>0.0.0.0</Data>
        <Data>00000000</Data>
        <Data>c0000409</Data>
        <Data>4e4c11a0</Data>
        <Data>f58</Data>
        <Data>01d5b41dc3140a41</Data>
        <Data>C:\temp\msmpisetup.exe</Data>
        <Data>unknown</Data>
        <Data>ca8d8024-f517-428c-a966-5c89a94fff24</Data>
        <Data>
        </Data>
        <Data>
        </Data>
      </EventData>
    </Event>

    I already disabled all firewalls and antivirus programs but to no avail. A reinstall of the machine has also not helped with this issue. I did already try the newest msmpi versoion but i got the same error.

    Can anyone point me in the right direction regarding this issue?

    Thanks!

    Monday, December 16, 2019 4:14 PM

All replies

  • You can use the command line to specify a installation log file so that you can know more details about the installation failure.

    Open a cmd console as administrator, and run the following command:

    C:\Temp\MSMpiSetup.exe /unattend /force /log "C:\Temp\MpiSetup.log" /verbose

    Tuesday, December 17, 2019 2:49 AM
    1. Make sure you meet the requirements.
    2. Uninstall the language pack.
    3. Unplug all peripheral devices.
    4. Uninstall third-party antivirus.
    5. Choose to keep only files when asked.
    6. Rebuild BCD.
    7. Upgrade with installation media.
    8. Perform a clean install.

    Tuesday, December 17, 2019 6:24 AM
  • Thank you for your answer!

    I already tried logging the error but the application seems to crash before logging is even started as no logfile is created even with your command

    Tuesday, December 17, 2019 10:51 AM
  • There are some language packs installed, but the install works on another machine with the same software set / languagepacks.

    There are no peripheral devices connected.

    The machine got a fresh reinstall without the antivirus and it still did not work.

    As the machine just got a reinstall rebuilding the BCD seems kind of pointless.

    Upgrade to what? I am already using windows 10 Enterprise.

    Clean reinstall was already tried in troubleshooting.

    Thanks for your suggestions but sadly none of these seem to bring a new angle on this problem.

    Tuesday, December 17, 2019 10:57 AM