locked
WHS as Server Storage (not replication) RRS feed

  • Question

  • I just setup my WHS and my goal in setting it up was LESS for backing up my other machines (i.e. replication) and MORE for having one storage location for ALL commonly used files. For example, I have three computers in my house and we use them all equally to access the same documents (imagine, quicken file, excel spreadsheets, etc.). Here's my question -- every time I boot up a machine connected to the WHS, in order to open up the network drive shortcut that WHS installed on my machine, I have to "log on" to connect to the WHS and enter my password. Is there any way of bypassing the password logon? Or some script that I can run when my computer boots up that automatically tries to connect to the network drive and then inputs the password? Thanks in advance for your help. Hope this all makes sense.
    Friday, April 23, 2010 7:11 PM

Answers

  • So here's how this works with Windows Home Server (and any other workgroup sharing solution, as it happens):

    On your server, you have a user with the login name Ken , the display name Vicki Warren , and the password KensPassword . On a client computer, if the login name and password match, you will have seamless access to the shares on the server that Ken has been given access to. Note that the display name I used doesn't match the login name very well. The display name is a red herring; it's the friendly name that Windows will display on the login screen instead of your login name (which could be something silly like HPUSER9413), but otherwise it's unrelated to your actual login credentials.

    To see this working correctly, on your server, create a new user, give that user a password, and grant access to some shares. Now on a client computer, create a new user with the same login name your gave the user on your server, and the same password. Log off that client computer, and log back in as the new user. See that you have access to the shares on the server per the settings you made.

    The most common issue with share access issues, and the one I think you're facing, is login names that don't match on the server and client. See this FAQ for information on how to correct this issue. Once you follow through on this, you should not be prompted for credentials again. (Note that passwords also have to match.)


    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by portland_matt Sunday, April 25, 2010 2:06 PM
    Saturday, April 24, 2010 2:23 PM
    Moderator

All replies

  • You need to define passwords for the user IDs in use on each client machine.  Then within windows home server you need to add a user that exactly matches in terms of user name and password.  Again within the Windows Home Server Console you need to give read or read/write access to each folder you want that user to have access to.

    If you install the connector software on each machine it makes it easier for you to do this - then you can choose to remove the computers from backup - it's a bit more than replication, if all 3 machines run the same OS then you won't store 3 copies of a system file, only 1.

    Just to be sure, you know about the duplication facility on folders that you can turn on so that copies of files are stored on second disk (if you have one that is)?


    --

    Friday, April 23, 2010 9:22 PM
  • Al, thanks for the response. I believe I set the machines up this way initially. But every time I reboot a connected machine, if I click on the desktop shortcut to the network drive (WHC connector software automatically installs the desktop shortcut), it asks me to log in. It remembers my username but not the password. I even check the box that says "remember my credentials". I'm trying to determine if there is a way of automatically having my connected PC's always connect upon reboot. It's a very minor thing, but would love to figure this out so I don't always have to connect and enter my credentials before opening up any software that accesses files on the network drive. Any suggestions?
    Saturday, April 24, 2010 1:53 PM
  • So here's how this works with Windows Home Server (and any other workgroup sharing solution, as it happens):

    On your server, you have a user with the login name Ken , the display name Vicki Warren , and the password KensPassword . On a client computer, if the login name and password match, you will have seamless access to the shares on the server that Ken has been given access to. Note that the display name I used doesn't match the login name very well. The display name is a red herring; it's the friendly name that Windows will display on the login screen instead of your login name (which could be something silly like HPUSER9413), but otherwise it's unrelated to your actual login credentials.

    To see this working correctly, on your server, create a new user, give that user a password, and grant access to some shares. Now on a client computer, create a new user with the same login name your gave the user on your server, and the same password. Log off that client computer, and log back in as the new user. See that you have access to the shares on the server per the settings you made.

    The most common issue with share access issues, and the one I think you're facing, is login names that don't match on the server and client. See this FAQ for information on how to correct this issue. Once you follow through on this, you should not be prompted for credentials again. (Note that passwords also have to match.)


    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by portland_matt Sunday, April 25, 2010 2:06 PM
    Saturday, April 24, 2010 2:23 PM
    Moderator
  • Ken, thanks for the information. I followed the instructions and detail above and everything worked. The FAQ that you linked to was helpful as well. Problem solved!

     

    Sunday, April 25, 2010 2:06 PM
  • Problem solved, thanks Ken! The FAQ you linked to was extremely helpful as well. Thanks again and my family also thanks you since they were always trying to connect!
    Sunday, April 25, 2010 2:12 PM