locked
Issue With PRM Solution CTP Partner Contact Permissions in Dynamics CRM Online 2011 RRS feed

  • Question

  • Hi,

    I have assigned Full Permissions to a partner contact for an Account in the PRM for the following:

    • Channel Access Pemissions.
    • Account Access Permissions.
    • Case Access Permissions.
    • Contact Access Permissions
    • Opportunity Access Permission

    Partner Contact Permisssions

    However, when I log into the Partner Portal site with the user credentials I cannot access "Manage Contacts and Manage Accounts" in the "Pipeline" sections of the site.

    I get a message that says "You do not have sufficient permissions to view this page."

    Any ideas on how to resolve this issue?

    Cheers - Abby

     

    Monday, February 21, 2011 8:35 PM

Answers

  • One thing you can do is add the invalidate cache js code as a favorite to your browser. I did that in IE by going to "Favorites" -> "Add to favorites...", set the name(e.g. "Invalidate Cache"), go to the properties of that link and change the URL in the Web Document tab to this value:

    javascript:var sURL=document.location.protocol + '//' +document.location.host;var oHttp=new ActiveXObject("Msxml2.XMLHTTP.6.0"); oHttp.Open('GET',sURL+'/Cache.axd?Message=InvalidateAll&d=' + (new Date()).valueOf(),false);oHttp.Send();window.location.reload(true);

    Then you can go ahead and click on the favorite/bookmark. This will invalidate your cache and reload the page. Try again after that. 

    There is more information on this in the Portal Functionality and Administration Guide included in the portal package that was installed.

    -Maria

    • Marked as answer by Abby_Doc Thursday, April 19, 2012 3:10 AM
    Wednesday, February 23, 2011 4:42 PM
  • Just to make sure - does the Channel Access set to the account have the right account (partner) and contact?  Does the access also have all the needed permissions set? After making any permission changes, make sure to invalidate your cache again.

    -Maria

    • Marked as answer by Abby_Doc Thursday, April 19, 2012 3:10 AM
    Saturday, February 26, 2011 5:45 PM

All replies

  • Hi Abby,

    There are several reasons why you might not be able to access the above-mentioned links.

    1. The Parent Customer of the Contact (customer accessing the portal) has not been set to a partner
    2. The Account Relationship Type has not been set to "Partner"
    3. The cache needs to be invalidated
    4. The channel access permissions need to be set (which you already did)

    Hope this helps,

    Maria

    Wednesday, February 23, 2011 2:43 AM
  • Hi Abby,

    There are several reasons why you might not be able to access the above-mentioned links.

    1. The Parent Customer of the Contact (customer accessing the portal) has not been set to a partner
    2. The Account Relationship Type has not been set to "Partner"
    3. The cache needs to be invalidated
    4. The channel access permissions need to be set (which you already did)

    Hope this helps,

    Maria

    Hi Maria,

    1. Yes I have.

    2. Yes I have.

    3. How do I do this? I have never been able to access the links I mentioned.

    4. Yes, Did this.

    Thanks,

    Abby

    Wednesday, February 23, 2011 1:54 PM
  • One thing you can do is add the invalidate cache js code as a favorite to your browser. I did that in IE by going to "Favorites" -> "Add to favorites...", set the name(e.g. "Invalidate Cache"), go to the properties of that link and change the URL in the Web Document tab to this value:

    javascript:var sURL=document.location.protocol + '//' +document.location.host;var oHttp=new ActiveXObject("Msxml2.XMLHTTP.6.0"); oHttp.Open('GET',sURL+'/Cache.axd?Message=InvalidateAll&d=' + (new Date()).valueOf(),false);oHttp.Send();window.location.reload(true);

    Then you can go ahead and click on the favorite/bookmark. This will invalidate your cache and reload the page. Try again after that. 

    There is more information on this in the Portal Functionality and Administration Guide included in the portal package that was installed.

    -Maria

    • Marked as answer by Abby_Doc Thursday, April 19, 2012 3:10 AM
    Wednesday, February 23, 2011 4:42 PM
  • Hi Maria,

    I tried your suggestion but no luck and the issue still remains.

    Thanks

    Abby

     

    Wednesday, February 23, 2011 9:00 PM
  • Just to make sure - does the Channel Access set to the account have the right account (partner) and contact?  Does the access also have all the needed permissions set? After making any permission changes, make sure to invalidate your cache again.

    -Maria

    • Marked as answer by Abby_Doc Thursday, April 19, 2012 3:10 AM
    Saturday, February 26, 2011 5:45 PM