locked
Pls Help! OCS2007 client, some options are greyed out..policy??? perhaps? RRS feed

  • Question

  •  

    on the client if you goto Tools, options, advanced, and all the advance connection settings are greyed out. why is that?? i cannot set any settings so therefore it cannot connect to the OCS server.

     

    please help!!

     

    Thanks

    Wednesday, June 25, 2008 12:06 PM

Answers

  • If it's greyed out it's getting the settings from in-band provisioning or group policy.

    if you want to 'prove' this try closing down the communicator client (right-click & exit) then deleting these reg keys - back them up if you want:

    HKCU\Software\Policies\microsoft\communicator
    HKLM\Software\Policies\microsoft\communicator

    ..then fire up your client. You should have your options back. Bear in mind once the machine gets group policy you'll lose them again - at least you'll be able to prove it's group policy/in-band provisioning blocking the settings for you.
    Tuesday, July 8, 2008 1:49 PM

All replies

  • Pardon me for asking the obvious, but are you clicking on the the Manual Configuration radio button first?  When set to the default Automatic Configuration all of the fields below are disabled.

     

    Wednesday, June 25, 2008 1:59 PM
    Moderator
  •  

    no problems i like stupid questions because it can find the answer, no you cannot select anything it is all greyed out Surprise( please help
    Wednesday, June 25, 2008 2:19 PM
  • You probably have Group Policies controlling these settings

    Please check GPOs

     

    Wednesday, June 25, 2008 4:36 PM
  • There where some for the old communicator 2005 but i have set them to all not configured. where abouts the setting be, or registry perhaps?

     

    our clients have only user rights on the PC's and not admin rights. If logon locally (with admin rights) i can configure the settings. But when i log back on with user rights the settings the options are disabled.

     

    please advise...

     

    Thanks 

    Thursday, June 26, 2008 10:21 AM
  • You may have registry settings outside of the policies sections that have been configured via a custom GPO which tattooed the registry, or via some other deployment solution.

     

    Take a look at this thread for some more info: http://forums.microsoft.com/unifiedcommunications/ShowPost.aspx?PostID=2479877&SiteID=57 as well as this article http://www.gpoguy.com/FAQs/tattoo.htm.

     

    The affected users may have unwanted settings under HKCU\Software\Microsoft\Communicator and not under the standard 'Policies' key.

     

     

    Thursday, June 26, 2008 4:04 PM
    Moderator
  • Thanks jeff,

     

    right after lots of reading i have finally got it to put the server in OCS2007 client via policy, i had the wrong adm file!!, but now it is not letting me change from TCP to TLS even though i have specified it via the policy template...it is greyed out.

     

    any ideas?

     

    note:the communicater adm file is from the microsoft site.

    Monday, June 30, 2008 4:27 PM
  • Do you have any certificates deployed to the servers and trusted by the clients?  TLS will not function without certificates, so it might be an underlying requirement and not a GPO-controlled setting that is doing it.

    Monday, June 30, 2008 4:50 PM
    Moderator
  • If it's greyed out it's getting the settings from in-band provisioning or group policy.

    if you want to 'prove' this try closing down the communicator client (right-click & exit) then deleting these reg keys - back them up if you want:

    HKCU\Software\Policies\microsoft\communicator
    HKLM\Software\Policies\microsoft\communicator

    ..then fire up your client. You should have your options back. Bear in mind once the machine gets group policy you'll lose them again - at least you'll be able to prove it's group policy/in-band provisioning blocking the settings for you.
    Tuesday, July 8, 2008 1:49 PM
  • I'm experiencing the same problem and have isolated it to policy settings.  I was able to prove it by removing theHKCU\Software\Policies\microsoft\communicator reg key.

     

    The problem I have know is determining which setting actually "grays" out these these options

     

    Any thoughts?

    Thursday, August 28, 2008 5:08 PM