locked
crm 4.0 Queue not receiving emails RRS feed

  • Question

  • Hey everyone,

    i have a queue in crm set to grab all e-mail that come to that e-mail box but everytime i send a e-mail to that e-mail box nothing happens.

    the queue is configured to convert All e-mail messages, the incoming and outgoing is set to E-mail router

    i have re-entered the creds for it and i can confirm that using test access in the e-mail router both incoming and outgoing passed,

    thanks in advance

     


    Moon
    Monday, October 25, 2010 2:25 AM

Answers

  • I did not even think of that, Thanks Madam Ma, i have changed my port to 443 but that did not fix it, i think i might need to open a micorsoft ticket
    Moon
    Tuesday, October 26, 2010 10:54 PM

All replies

  • Hi,

    What are you using Exchange Server or POP3 mail account like gmail?

    Regards

    TGB


    Microsoft Certified Business Management Solutions Specialist
    Monday, October 25, 2010 4:24 AM
  • Exchange Server 2007 and using the Exchange Web Service Protocol
    Moon
    Monday, October 25, 2010 4:33 AM
  • Hi Moon,

    What Access Credentials you are using? The user must have access rights on the Exchange side. You can setup the Access Credentials via E-Mail Router Configuration Manager. And what are you using http or https to connect to your Exchange?

    Please check these settings as well:

    1. The protocol, url, port are right
    2. The url is the mailbox server, it may not the OWA address
    3. You don't need the /exchange or /owa on the end of the Url, because the router service will find it
    4. Sometimes you have to publish and settings and restart the email router service then do the load/test

    Can you also check this video http://video.mikelu.org/emailrouterexchange/emailrouterexchange.html

    Regards

    TGB


    Microsoft Certified Business Management Solutions Specialist
    Monday, October 25, 2010 4:43 AM
  • Hey TGB,

    i have loged into to the mailbox as the creds i am using for the e-mail router and i can see the 3 e-mails i sent,

    the protocol i think is correct because when i do a "Test Access" i get Incoming Status: Succeeded

    i have also restarted the router many times.

    thanks

     


    Moon
    Monday, October 25, 2010 4:52 AM
  • Moon,

    Can you tell me about your environment. The deployment of AD, CRM and Exchange are they on single server or distributed accross multiple boxes? And on which box you have deployed your email router?

    Regards

    TGB


    Microsoft Certified Business Management Solutions Specialist
    Monday, October 25, 2010 5:00 AM
  • Hi,

    Can you also do some diagnostics and post the last few lines of your error log here. http://blogs.msdn.com/b/benlec/archive/2008/03/04/crmdiagtool4-for-microsoft-crm-4-0-has-been-released.aspx

    Regards

    TGB


    Microsoft Certified Business Management Solutions Specialist
    Monday, October 25, 2010 5:02 AM
  • Hey TGB,

    the crm server is a server 2003 R2 SP2 x64,

    crm/sql/e-mail router is all on the above box and all are installed as x64 bit version,

    and our exchange server/AD is a sbs server 2007,

    is the anything else you need?


    Moon
    Monday, October 25, 2010 5:05 AM
  • Hi,

    Can you check this link as well http://rc.crm.dynamics.com/rc/regcont/en_us/op/articles/configrouter.aspx#o30952 what I presume is there is something wrong with your access credentials accorss different boxes. Please also check this link as well http://blogs.msdn.com/b/crm/archive/2009/01/08/troubleshooting-the-microsoft-dynamics-crm-e-mail-router.aspx

    Regards

    TGB


    Microsoft Certified Business Management Solutions Specialist
    Monday, October 25, 2010 5:28 AM
  • Hey TGB,

     i checked the above links and could not find anything wrong with my setup compared to the links.


    Moon
    Monday, October 25, 2010 6:13 AM
  • I had this problem few days ago with exchange server 2010 though.

    This solve my problem (I hope it will help you):

    The e-mail address of the queue had to be the primary address of the mailbox.   

    also, do you have SSL?

     

    Monday, October 25, 2010 2:15 PM
  • I checked the primary address of the mailbox and it was not the one i was using, i have now switched to the primary one but i am still not getting anything in the queue, i don't have not option to use ssl when using the exchange web services Protocol but in the web address i am using https.

    Thanks for you idea Madam Ma!


    Moon
    Monday, October 25, 2010 10:48 PM
  • One more thing I forgot to mention, since you are using https, go to advanced tab in your Incoming profile and change the Network port to 443.

    Hope this helps. :)

    Tuesday, October 26, 2010 9:15 AM
  • I did not even think of that, Thanks Madam Ma, i have changed my port to 443 but that did not fix it, i think i might need to open a micorsoft ticket
    Moon
    Tuesday, October 26, 2010 10:54 PM
  • Why don't you try with another queue or user (for testing purposes), maybe it's the queue (or the mailbox itself) that is not set right. Also, have you checked the MSCRMEmailLog on your server?
    Wednesday, October 27, 2010 11:31 AM
  • Sorry to ask but where is the MSCRMEmailLog?

     


    Moon
    Thursday, October 28, 2010 5:37 AM
  • On the CRM server (I suppose that your Microsoft CRM E-mail Router is installed there also). Go to server manager - > Event Viewer and see if you have some event (error/warning) from MSCREmailLog.

    Also make sure that you have enabled the CRM Email Router Event Log. Here is a link on how to enabled if it is not.

    http://crmjunkie.blogspot.com/2008/07/crm-email-router-event-log.html

     

    Thursday, October 28, 2010 7:28 AM
  • Hey Madam Ma,

    thanks for the link,i have followed the above link and i still get no errors or useful information.


    Moon
    Monday, November 1, 2010 3:21 AM
  • Have you tried to test the router with other queue or user that have other email address? Cause as I said before, the problem might be the mailbox itself (we had case like that few months ago). Try that... And if that doesn't provide you with some solution, I'm affraid I have no other ideas. :)
    Monday, November 1, 2010 11:11 AM
  • He Madam Ma,  thanks for all your help, i have used my mail box as a queue and that also did not work, so i think it must be the router, i will try and reinstall it, P.S. i wont replay for some time because i am on holidays!
    Moon
    Tuesday, November 2, 2010 6:16 AM
  • Could anyone fix this issue? I am having the same problem, i create an email activity to a queue, the email is sent to the queue mailbox but it does not appear in the queue! Cheers.
    Tuesday, November 23, 2010 2:34 PM