"The router is not working." non-uPNP router RRS feed

  • Question

  • I have a non-uPNP router and have forwarded ports 80 and 443 to the Vail V2 server (I am using a static IPv4 address for the server and referencing that IP address in the router port forwarding, and yes running ipconfig on the server verifies the server is using that IP address).  No matter what I try the "router is not working" error appears in the remote web access setup.

    IE8 on the server cannot access any outside web sites (I don't have a local web server to test local access).  PCs on the network have no trouble accessing the internet.

    I can ping the Vail server from a local PC and it responds fine.  The Vail server can ping local PCs and the router with no errors.

    Why can't the server access the internet?

    Thanks in advance.

    Friday, August 27, 2010 7:00 PM

All replies

  • Can you confirm that your broadband modem is either operating in bridge mode, or has those ports forwarded to your router?
    I'm not on the WHS team, I just post a lot. :)
    Friday, August 27, 2010 7:51 PM
  • The server indicates it is using IP

    The router shows that it is forwarding the following ports:

    Local Port         Forwarded to                Remote Port              Remote IPs

    80                         80                            Any

    443                       443                          Any


    The router supports DMZ mode but that is disabled for security reasons.

    Friday, August 27, 2010 8:52 PM
  • I forgot to mention the ports are being forwarded for TCP only.
    Friday, August 27, 2010 8:56 PM
  • You didn't answer my question. Is your broadband modem configured correctly? Or are you saying that your router is your broadband modem?
    I'm not on the WHS team, I just post a lot. :)
    Saturday, August 28, 2010 12:36 AM
  • I had a non-uPNP router, couldn't turn both on at the same tme Had to get a new router worked fine.

    I use road runer. Use a Cisco E1000 router

    The router is the second device in my network. The broadband modem is the first.


    Monday, August 30, 2010 6:45 PM
  • If I am reading your initial post correctly there are two separate issue's.

    1: The Vail remote access is not working.

    Nothing to add from the previous replies may or may not be related to the second problem.

    2: The Vail server does not have internet access.

    Is the ip address to the server allocated from a static entry in the router DHCP server or did you enter it manually?. I suspect that the ip stack in VAil does not like the DNS entry for the network interface. I can reproduce a similar issue with both Vail and Win 7 if the DNS is incorrect. 

    My router is capable of statically allocating ip addresses to various machines that enables them to pickup the same ip address each time as well the correct dns information from my ISP. I have had mixed results with manually adding the ip address and DNS entries to the machines, but allocating from the router has never caused an issue.


    • Edited by frogz1 Wednesday, September 1, 2010 4:58 AM missing word
    Wednesday, September 1, 2010 4:55 AM
  • Sorry Ken.  My router is the DSL modem.
    Friday, September 10, 2010 3:44 AM
  • Frogz1, thanks for the reply.  Unfortunately my router/modem allows me to reserve IPs for static machines but does not allow assigning a static IP to a specific machine.  So I entered a static address directly in the server.
    Friday, September 10, 2010 4:08 AM
  • Just thinking about the problem its has pretty much got to be related to the IP address settings. When manually configuring the ip parameters maybe worth re-entering the address, subnet mask and default gateway. Also check the DNS entries.

    Not able to confirm at present, but on the server desktop I think there is an option, when you right click on the network icon, to repair the interface. This should tell you what the system thinks is wrong. This is the system tray icon.

    Running out of idea's.


    Friday, September 10, 2010 5:05 AM
  • the static reservation SHOULD work. in fact if you un-do the static on the
    computer and let it get a DHCP IP, it will probably request the previous static,
    and if available and in the correct range, the router should serve it up. then
    you can "reserve" it. I've tried this with several routers and have been
    On Fri, 10 Sep 2010 04:08:12 +0000, stevehendri wrote:
    >Frogz1, thanks for the reply.  Unfortunately my router/modem allows me to reserve IPs for static machines but does not allow assigning a static IP to a specific machine.  So I entered a static address directly in the server.

    Barb Bowman


    Friday, September 10, 2010 10:57 AM
  • Static IP addressing and DHCP reservation are not the same thing; this Microsoft Knowledgebase article gives a good explanation of why DHCP reservation is preferred where possible. It sounds to me, Steve, like you're saying that your router doesn't support DHCP reservations, but does allow you to designate a range of addresses which are within the DHCP pool it uses, but will not be assigned as DHCP addresses?

    Also, when you configure Remote Access, are you checking off the box which says "I will configure my router manually"? If not, your server will attempt to use UPnP to configure your router, and if your router doesn't respond as expected, your server will raise an alert.

    I'm not on the WHS team, I just post a lot. :)
    Friday, September 10, 2010 12:15 PM
  • Frogz1, Barb and Ken,

    Switching from static addressing to allowing the router to assign an address made it possible for the server to access the internet.  Now if only I could set up a domain name (every time I try it comes back telling me my user name or password are wrong even though I can remote desktop into the server and use its IE8 and log in successfully at login.live.com)

    I need to apply my time and efforts elsewhere for a while. So I will not be watching this thread.

    Thanks for the help.

    Monday, September 13, 2010 4:02 AM
  • Possible keyboard layout issue here? Your server is probably in US English, how about your client? Can you complete the domain registration wizard by opening the dashboard directly on your server via Remote Desktop, since you can log in to Live that way?
    I'm not on the WHS team, I just post a lot. :)
    Monday, September 13, 2010 3:14 PM