locked
Exception of type 'System.Web.HttpUnhandledException' was thrown and lost access to workplace area RRS feed

  • Question

  • Hi

    Our server administrator was doing some maintenance works on crm server and he tried to solve CRM problem with out look integration, which leaded to a failure. after that, cause of some changes to server name, I had to manually rename connection string of CRM  both in database and registery, now system runs in IE but only, but in workplace area, the following error appears:

    Error Description:
    An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Error Details:
    Exception of type 'System.Web.HttpUnhandledException' was thrown.

    Full Stack:

    [SocketException: The requested name is valid, but no data of the requested type was found] at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6) at System.Net.Dns.GetHostAddresses(String hostNameOrAddress) at Microsoft.Crm.Application.Utility.Util.IsLocalUrl(String url) at Microsoft.Crm.Utility.HelpUtility.UseLocalHelpServer(String helpServer) at Microsoft.Crm.Application.Controls.InAppContent.GetHelpPath(String path, String siteMapPath, Boolean& setRestricted, String& initScript) at Microsoft.Crm.Application.Controls.InAppContent.CreateChildControls() at System.Web.UI.Control.EnsureChildControls() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) [HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.] at System.Web.UI.Page.HandleError(Exception e) at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) at System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequest(HttpContext context) at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    It also appears when I click on contact, account and etc.

    only customization page appears but same error appears in solution page.

    p.s: It appears that at the time I was installing a solution, our system admin was also doing maintenance

    Now I just want to export contact, lead and account data
    Monday, April 8, 2013 5:03 AM

All replies

  • Dear Sindu M

    Unfortunately i dont have access to solution page, same error appears there.

    Yesterday I manually deleted that bad solution I was creating from database, but it did not help

    Monday, April 8, 2013 5:33 AM
  • Hi,

    Try to restart the services for sql and crm and do iis reset.Are you sure that you deleted the solution completely or left it reference traces somewhere in database??and it's not advisable to delete the components directly in database!

    Try with the url

    http://support.microsoft.com/kb/947096


    Sindu M

    Monday, April 8, 2013 5:50 AM
  • I saw trace file and there were errors like these:

    The entity with a name = 'new_e1' was not found in the MetadataCache

    The entity with a name = 'new_tribute' was not found in the MetadataCache

    The entity with a name = 'new_markent1' was not found in the MetadataCache

    Monday, April 8, 2013 6:20 AM
  • Hi,

    It seems like that the reference to the above entity got deleted. does you have the backup of what u did in deleting solution components? if so try to restore it!it may help you.


    Sindu M

    Monday, April 8, 2013 6:47 AM
  • no I dont have any back up :(
    Monday, April 8, 2013 6:51 AM
  • hi,

    Explain the things which you did in database!


    Sindu M

    Monday, April 8, 2013 7:01 AM
  • I found the solution id which I created and saw it relations with other tables. First I deleted records from [SolutionComponentBase] where their solution id was equal to the solution I intended to delete and then deleted solution from [SolutionBase]
    Monday, April 8, 2013 7:08 AM
  • Hi,

    Though it's not advisable! u don't have any ways to prefer! just have a backup of your database and do the following! try to delete the records in metadataschema.tables( around 19 tables). depend upon your  solution, Relationships and  attributes are all saved under these tables. check with your solution id and delete the related records in those tables.


    Sindu M


    • Edited by VidhiyaM Monday, April 8, 2013 8:11 AM
    Monday, April 8, 2013 8:05 AM
  • Dear Sindum

    I forget the solution id :( and really don't know what to do, here I copied on of the errors details from trace file:

    Crm Exception: Message: The entity with a name = 'new_e1' was not found in the MetadataCache., ErrorCode: -2147217150
    [2013-04-08 10:37:06.419] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:    9 |Category: Exception |User: 00000000-0000-0000-0000-000000000000 |Level: Error | CrmException..ctor
    at CrmException..ctor(String message, Exception innerException, Int32 errorCode, Boolean isFlowControlException)
    at CrmException..ctor(String message, Int32 errorCode)
    at SiteMap.TryGetEntity(String entityName)
    at SiteMapEntitySubArea.Create(SiteMapGroup parentGroup, XmlNode subareaNode)
    at MasterSiteMapGroup.ProcessSiteMapAreaNode(XmlNode node, IDictionary subAreaTitles)
    at MasterSiteMapGroup..ctor(SiteMapArea parentArea, XmlNode groupNode)
    at MasterSiteMapArea..ctor(SiteMap siteMap, XmlNode areaNode, IOrganizationContext context)
    at MasterSiteMap..ctor(XmlNode xml, DynamicMetadataCache metadataCache, IOrganizationContext context)
    at MasterSiteMap.LoadMasterSiteMapInternal(DynamicMetadataCache metadataCache, Boolean useReferenceXml, Boolean retrieveLatest, IOrganizationContext context)
    at MasterSiteMap.LoadMasterSiteMap(DynamicMetadataCache metadataCache, Boolean retrieveLatest, IOrganizationContext context)
    at CrmMultiOrgCache`2.LookupEntry(TKey key, IOrganizationContext context)
    at SiteMap.GetSiteMapForUser(IUser user, Client client, Boolean isOffline, String forceGroupProfiles)
    at UserSiteMapCache.LookupEntry(IUser user, Client client, Boolean isOffline)
    at NewRecordMenuBuilder.ParseSiteMap()
    at NewRecordMenuBuilderBase.get_CommandDefinitions()
    at RibbonDescription.AddDynamicMenuCommandsAndScripts(RibbonCommandMapping mapping, String entityLogicalName, DynamicMenuInformation dynamicMenuInformation, RibbonTabInformation tabInformation)
    at RibbonDescription.AddCommandsForTab(String tabIdForFetch, String entityLogicalName, RibbonTabInformation tabInformation)
    at RibbonDescription.AddCommandsForTab(RibbonTabInformation tabStruct)
    at RibbonDescription.AddTabs()
    at RibbonData.GetRibbonDescription(Header currentHeader, Boolean suppressTabs)
    at RibbonData.CreateClientControl(Header currentHeader, Boolean suppressTabs)
    at AppHeader.Render(HtmlTextWriter output)
    at AppNavPage.Render(HtmlTextWriter writer)
    at Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    at Page.ProcessRequest()
    at Page.ProcessRequest(HttpContext context)
    at CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    at HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    at ApplicationStepManager.ResumeSteps(Exception error)
    at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

    Monday, April 8, 2013 10:32 AM
  • As far as i know, Without solution id, you can't able to find out the components which was saved in database during solution import! And  with the trace you can able to find out the issues alone. what's the error u saw in your page? 

    does is it like solution with id........ doesn't exist???


    Sindu M


    • Edited by VidhiyaM Monday, April 8, 2013 11:01 AM
    Monday, April 8, 2013 11:01 AM
  • The error I got on IE is the one I mentioned in my first  question what I saw in trace was the one I lasr posted here

    I edited the sitemap and deleted nodes with  'new_e1' , 'new_tribute' ,  'new_markent1' names and no I got this error : 

    [2013-04-08 15:47:29.071] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   19 |Category: Application |User: 00000000-0000-0000-0000-000000000000 |Level: Info | IsvSolutionInitializer.Application_AssemblyResolve
    >Attempted to find assembly Microsoft.Crm.XmlSerializers, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 skipped path not being under ISV folder.
    [2013-04-08 15:47:29.174] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   19 |Category: Application |User: 00000000-0000-0000-0000-000000000000 |Level: Info | IsvSolutionInitializer.Application_AssemblyResolve
    >Attempted to find assembly Microsoft.Crm.XmlSerializers, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 skipped path not being under ISV folder

    Monday, April 8, 2013 11:29 AM
  • Hi,

    do u have a backup of original solution which u have before customization?? The problem is with the solution which got deleted. what u did is deleted the solution which you installed and using that id you delete the record in solution component !Right?

    Normally the attributes, option sets,relation ship for the solution got saved in metadataschema.tables....which you didn't deleted! right?

    If you find out those records and deleted properly then you can able to open the solution page. From there you can solve the other things related to that attributes and entity?

    Now try to find out the solution id??? 

    As far as i know, this is the only solution u got! 


    Sindu M



    • Edited by VidhiyaM Monday, April 8, 2013 11:50 AM
    Monday, April 8, 2013 11:40 AM
  • Now I just need a way to recover my contacts, leads and accounts, cause I installed new crm in other server and I want to transfer these to new crm

    Is there any way?

    Monday, April 8, 2013 12:28 PM
  •  You can't get the data until you recover your database

    There is the two way, to get back your original data. one,you have your database backup other You must have a proper data in template.


    Sindu M



    • Edited by VidhiyaM Tuesday, April 9, 2013 4:26 AM
    Monday, April 8, 2013 12:56 PM
  • SinduM, I dont have any back up :(

    what do you mean data in template? would please explain it ?

    Tuesday, April 9, 2013 6:13 PM
  • Hi, 

    It won't suit your scenario. you might have do that only when your CRM works, which means exporting your data in excel


    Sindu M

    Wednesday, April 10, 2013 4:32 AM
  • Dear SinduM

    I repaired the dynamic crm server with installation DVD and it seems it works fine

    • Proposed as answer by VidhiyaM Thursday, April 11, 2013 6:56 AM
    Wednesday, April 10, 2013 7:19 AM
  • How about the solution which you imported??

    does it still there?


    Sindu M

    Wednesday, April 10, 2013 7:45 AM
  • no it is not there
    Wednesday, April 10, 2013 7:52 AM
  • How about the data which u had?

    The one that related with that solution!!


    Sindu M

    Wednesday, April 10, 2013 7:54 AM
  • Actually I was creating the solution and after that system failed and there was no data associated to that solution. In fact it was not complete 
    Wednesday, April 10, 2013 8:02 AM
  • no need to do restore.

    We had the exact same errors on our servers. dev,qa,production. Even same entities: name _e1, new_tribute, new_markent1. Funny, aha.

    I believe these are garbage entities which came along with one of the free  3rd party CRM tools we installed.

    Anyway, here is my solution.You need to customize your sitemap xml file to remove the missing entities.

    Here is how to customize a sitemap by Microsoft. if you haven't done this before, backup your whole DB and try on your dev first.

    http://msdn.microsoft.com/en-us/library/gg309424.aspx

    1. Create a new solution, i.e Sitemap.
    2. Add only one component-"site map" from existing "Client Extensions"
    3. Export the solution to local pc.
    4. In the customizations.xml file, you will see
    <Group Id="Extensions" ResourceId="Group_Extensions">
              <SubArea Id="new_e1" Entity="new_e1" />
              <SubArea Id="new_tribute" Entity="new_tribute" />
              <SubArea Id="new_markent1" Entity="new_markent1" />
            </Group>

    Remove them. Zip the folder, then import the new solution back and publish it. You can remove the newly created "sitemap"solution any time now.

    After this, you won't see any error regarding to these three entities in your event log.

    If you have more than one organizations in your CRM, you may need to do the same to other organizations.

    Wednesday, April 9, 2014 3:01 PM
  • I repaired the CRM using installation disc an it work properly. Thanks for all of your replies.
    Wednesday, April 9, 2014 5:14 PM