locked
Live Meeting through OCS Edge server RRS feed

  • Question

  •  

    I'm frustrated with a partial failure of my OCS Edge server capability.

    We have successfully installed OCS Standard internally, and an OCS Edge server that works fine for MOC client - to do authentication against our internal domain, chat, presence, video and audio conferencing. Everything internally works really well.

     

    But, we cannot use Live Meeting 2007 (http://office.microsoft.com/en-us/help/HA101733831033.aspx) to establish application sharing sessions. This is one of the main reasons we want to use the Edge server - to allow training and remote presentations.

    In LM2007, we can "Test Connection" and it is successful. We manually configure the server address instead of having _sip. SRV records in DNS.

    When we press "Meet Now" we get "you are now connecting to the meeting" and then the error "Live Meeting cannot connect to the meeting. Wait a few moments then try again. Contact your administrator or support"

    In the MOC 2007 client, during a chat, pressing "Share information with Live Meeting", the remote computer will get an invitation (press Alt-G), but then the connection fails as above.

     

    On the Cisco ASA5500 firewall we have ports 443, 5061, 3478 and 50,000 to 59,999 open to the NAT translation rule for the OCS Edge DMZ address to the public IP address. We have also tried to open all ports, but it does not seem to be a port issue.

    We don't get anything in event logs or any other indication of the cause of the problem. Everything on the Edge server and the OCS server validates correctly.

     

    Does anyone know what is going wrong?

    Monday, July 28, 2008 11:37 AM

All replies

  • A common configuration error that I've seen is the setting on the Web Conferencing properties under the Web Conferencing Edge Server.  Make sure that the Internal FQDN is set to the Edge server's internal interface FQDN.  I've seen a number of customers enter the FQDN by which they think the Live Meeting client should connect to OCS when it's inside the firewall.

     

    Monday, July 28, 2008 12:55 PM
    Moderator
  •  

    Thanks for the advice, it has helped in our investigation, but not resolved the problem.

    I went to my Edge server, right clicked on My Computer, selected Manage, then navigated to MOCS 2007, right clicked and went to Configure Edge Server.

    Then I verified that the FQDN for the Internal interface was set to "server009.domain.com.au" (this is the name of the server on our internal network, and the internal interface NIC on the Edge server is 10.123.0.123)

    I ensured that in the next screen all the external interface IP addresses and the FQDNs were set to "ocs.domain.com.au" (this is the externally public name that is available at 205.234.x.x - which is NATed by our Cisco ASA firewall to the IP address on the NIC of the Edge server at 172.16.201.123)

    I made sure that the FQDN of the next hop server was set to "server005.domain.com.au" and the supported SIP domain was set to "domain.com.au"

    The next few pages of the wizard were about access, which works OK, so I left them and did a restart of all services.

     

    But, this did not help, and we still get the same error with LiveMeeting.

    When we do TCP view of other tools, it appears that the external machine that is running Live Meeting is attempting to establish a connection to itself (to it's private IP assigned to the host, not the external public IP address of the external computer's ADSL link).

    We have noticed that the ASA firewall is reporting "no connection" during the attempt to do a LiveMeeting session, but it is not listed as a Deny entry.

     

    Any other ideas that I could try?


    Tuesday, July 29, 2008 1:25 AM
  • Hi Christian,

    A couple things to try...

    1) you mentioned that all the fqdns on the edge are set to "ocs.domain.com.au" - this probably is the issue. You need 3 different fqdns for the services (e.g. ocs.domain.com.au = Access Edge; livemeeting.domain.com.au = Web Conferencing; av.domain.com.au = AV Edge) and you need 3 different IP addresses for the services. Unless I misunderstood what you were saying, definitely set this to be a diffferent fqdn for each service

     

    2) if you do have 3 different IPs/FQDNs, on the edge server go to a command prompt and run c:>netstat -abn

    and review the output. Check to make sure that you see your edge server listening on port 443 for the IP address you have assigned to the WebConferencing service

     

    3) if you do see your edge listening on 443 using the right IP address, make sure that you can telnet to the edge server from the outside, using the fqdn like "telnet livemeeting.domain.com.au 443" and see if it connects. this will simulate the external livemeeting client connecting to the Web Conferencing Edge.

     

    Regards,

    Matt

     

    Tuesday, July 29, 2008 5:47 PM
  •  

    I finally found the answer to my problem. It disappoints me that no-one suggested this, and that it is not in any of the Microsoft documentation in a form that indicates that this is the problem, and there was no error or event log that pointed to the issue. I found the answer on the licensing website for OCS server;

     

    http://office.microsoft.com/en-us/communicationsserver/FX102405721033.aspx

    http://office.microsoft.com/en-us/communicationsserver/FX102405731033.aspx

     

    You cannot do Live Meeting application sharing unless you have Enterprise edition of OCS as your internal Pool. Even though it works internally on standard edition, and you don't need to have Enterprise edition as your Edge server, you need the internal server to be Enterprise edition.

    The instant we made this change, it worked perfectly (and the above help from others really helped us get into the best position)

    Sunday, November 30, 2008 11:08 PM
  • Christian,
    Although licensing is a serious issue, I doubt that was the cause of your problems. There must have been something in the changes you made to alleviate the cause of the issue.
    If I had to suspect something, it would be the 'External URL for meeting content download' WMI setting. It may not have been set during your original install or something like that. I had a similar issue with a customer where this was the case.

    Glad it works!
    Jim
    Monday, December 1, 2008 4:59 AM
  • Jim is exactly right - Microsoft doesn't have any licensing enforcement with OCS, so the server has no idea which CAL you've licensed.

    Monday, December 1, 2008 5:40 AM
    Moderator