SSRS Configuration Initialization Error RRS feed

  • Question

  • Hi All,

    I am trying to configure SSRS .  I am facing Initialization error ( Greyed out and  not checked).  We moved the CRM Database from one server to another but we didn’t move the report server DB since there was no custom reports.  I created a New report server DB.  It also gives me an error in Database connection tab(Assigning user rights is marked in RED).  I tried to reconfigure from the scratch, still the same issue ( all other component are in Green)



    Point to be noted:

    Another  point to be noted is for SQL server 2005, SP3 is installed. Do I need to install sp3 separately for SSRS also( We have SQL and SSRS are in the same box) Please let me know?



    Saturday, April 17, 2010 6:06 PM


  • Ensure that you've granted rights on the SSRS reports site to the crm groups. - (reporting access / sql access) - and re-run the SQL SSRS Confguration wizard to ensure that SSRS is running ok before attempting  to resolve the connection to CRM.

    Finally - make sure to re-install the SSRS connector on the new server.

    Also - try the following -

    To change the report server with CRM 4.0!  For out-of-the-box reports, they are now stored in the MSCRM database along with the Reportserver database.  So – if you want to change the report server with CRM 4.0:

    1.        Disable the organization in Deployment Manager, that you want to change the report server for

    2.       Right-click disabled org, choose “Edit organization”

    3.       Modify the Report Server URL

    a.       There will be a diagnostic process, that will determine if reports can be moved to the new URL

    b.      If the diags pass, the reports will be published to the new report server

    c.       Note – there is a similar process for moving CRM databases to a new SQL Server

    4.       Re-enable the organization

    (Via http://blogs.inetium.com/blogs/tedh/archive/2008/01/17/how-do-i-move-crm-4-0-reports-to-a-new-sql-report-server.aspx)

    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Sunday, April 18, 2010 3:05 AM