none
problem about 1.5v---802.11b

    Question

  • Here is my PROBLEM:

    when I was running  802.11b, it's ok at first. But after I set sora adapter's IP,My computer was nerely hang, here is my log with dbgview :

    00000000 0.00000000 [STARTUP]---> DriverEntry built on Sep  7 2011 at 17:43:24, MP_NDIS_MAJOR_VERSION=5, MP_NDIS_MINOR_VERSION=1 
    00000001 0.00070485 [STARTUP] -->MPInitialize  
    00000002 0.00070797 [STARTUP] 0x00277e10-byte non-paged memory for adapter context allocated 
    00000003 0.00130449 [STARTUP] --> NICInitializeSdrContext  
    00000004 0.10261370 [STARTUP] PHY Startup, get 1 free radio(s)  
    00000005 0.10269534 [MAC_CS] enable Rx for the first time 
    00000006 0.10269579 [STARTUP] 802.11 MAC startup succ 
    00000007 0.10269930 [STARTUP] <--MPInitialize with 0x00000000 
    00000008 0.10271915 [MAC_CS] channel clean, goto tx  
    00000009 0.10274325 [MAC_CS] channel clean, goto tx  
    00000010 0.10275907 [MAC_CS] channel clean, goto tx  
    00000011 0.10277497 [MAC_CS] channel clean, goto tx  
    00000012 0.10280674 [MAC_CS] channel clean, goto tx  
    00000013 0.10282259 [MAC_CS] channel clean, goto tx  
    00000014 0.10283859 [MAC_CS] channel clean, goto tx  
    00000015 0.10286267 [MAC_CS] channel clean, goto tx  
                                    it's  normal at first

    01578176 26.79661751 [MAC_CS] channel clean, goto tx  
    01578177 26.79663467 [MAC_CS] channel clean, goto tx  
    01578178 26.79663849 [MAC_CS] channel busy, goto rx  
    01578179 26.80334663 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578180 26.81897545 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578181 26.83459854 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578182 26.84246063 [RX][Warning] BB11BRx fail:80050103 
    01578183 26.84247589 [MAC_CS] channel clean, goto tx  
    01578184 26.84249306 [MAC_CS] channel clean, goto tx  
    01578185 26.84250832 [MAC_CS] channel clean, goto tx  
    01578186 26.84252167 [MAC_CS] channel clean, goto tx

                                        it's becoming bad

    01578272 27.63499832 [RX][Warning] BB11BRx fail:80050103 
    01578273 27.63500404 [MAC_CS] channel busy, goto rx  
    01578274 27.64712906 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578275 27.66274261 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578276 27.67836571 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578277 27.69240761 [RX][Warning] BB11BRx fail:80050103 
    01578278 27.69241905 [MAC_CS] channel busy, goto rx  

                                                       then my computer was hang

    01578663 32.63160324 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578664 32.64722824 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578665 32.66285324 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578666 32.67848969 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578667 32.69410324 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578668 32.70972824 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578669 32.72535324 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578670 32.74098206 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578671 32.75660706 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578672 32.77223206 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0 
    01578673 32.78787613 [MAC_Send] no send event comes, pSendQueueManager->nSrcPacket=0

    I don't know why , because 802.11a was running good. HWtest  was normal,too.

    Thursday, September 8, 2011 2:01 AM

Answers

  • hi,

    you may set your rxgain a bit too high. The carrier sensing algorithm implemented in 11b is a little bit simple. So if the gain is too high, there goes to be many false alarm.

    we might update this part in our later release.

    Thanks,

    - Kun

    • Marked as answer by m000n Thursday, September 8, 2011 6:10 AM
    Thursday, September 8, 2011 6:02 AM
    Owner

All replies

  • hi,

    you may set your rxgain a bit too high. The carrier sensing algorithm implemented in 11b is a little bit simple. So if the gain is too high, there goes to be many false alarm.

    we might update this part in our later release.

    Thanks,

    - Kun

    • Marked as answer by m000n Thursday, September 8, 2011 6:10 AM
    Thursday, September 8, 2011 6:02 AM
    Owner
  • hi,

    ok, let me try that again~

    Thanks,

    m000n

    Thursday, September 8, 2011 6:08 AM