none
[UWP][Xbox] Unity game performance drops dramatically with .Net Native RRS feed

  • Question

  • Hi,

    I'm finishing up my game to publish on xbox (creators program) and found out that I have to compile it using .net native otherwise it can't be putted on the store.

    The issue is that with .net native the game is simply a mess, it takes forever to boot, and every time I need to load a scene (unity) it takes at least 10 seconds. But disabling .net native the game runs smoothly without any major fps drops on booting or while loading scenes.

    I was wandering if anyone knows why and how to solve this issue.

    I'm using unity 5.6.3p2

    Regards


    Tuesday, December 5, 2017 4:59 PM

All replies

  • Hi DiogoCardoso

    Based on your words, the problem is not in the scope of UWP forum. UWP forum is where developers discuss writing Universal Windows Apps. I suggest that you might need to optimize your unity code.

    You could ask about this in the Unity Forum.

    Best regards,

    Roy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, December 6, 2017 3:12 AM
  • The issue here doesn't seam to be with Unity but with .net native, that is way I posted in there. The game runs fine without it, so I was wandering if any other DEV went through this. 
    Wednesday, December 6, 2017 6:10 PM