locked
CRM2011 Email Router Fails When Incoming Email Is Set To Use Router RRS feed

  • Question

  • I'm trying to configure the email router for Dynamics CRM 2011 installed on the same server that both Dynamics CRM and Exchange 2010 reside. The email router gives no error messages whatsoever if all the users in CRM have their incoming email set to none, but returns an error message if a users profile is set to use the email router. Tried this using many different credentials, but it just won't work. The error message I'm getting is this:

    "The E-mail Router Configuration Manager was unable to retrieve user and queue information from the Microsoft Dynamics CRM server. This may indicate that the Microsoft Dynamics CRM server is busy. Verify that URL https://dynamics.domainname.org:5443/SpyhoppingFoundation is correct. Additionally, this problem can occur if specified access credentials are insufficient. To try again, click Load Data. (The server was unable to process the request do to an internal error. For more information about the error, either turn on IncludeExceptionDefaultInFaults (either from the ServiceBehaviorAttribute or from the <serviceDebug> configuration bahvaior) on the server in order to send the exception information back to the client, or turn on tracing as per the Microsoft .NET Framework 3.0 SDK documentation and inspect the server trace logs.)

    I have NO idea how to turn on tracing or the other suggestions to get more information on the error. However, the odd thing about all this is that the router works just fine as long as there are no users whose profile is set to use the Router for incoming e-mail.

    What am I missing here?

    Friday, April 29, 2011 12:12 AM