WLW Shows Splash Screen and Immediately Crashes

All replies

  • IshanB,
    The problem seems to be based on issues with reading an XML file; I don't know which file though [...] One of the developers might be able to understand or explain this...

    From the file, there's the extract of this error: <param /> Save Few Bucks <param /> ","" WindowsLiveWriter,1356,None,00184,08-Apr-2009 02:15:18.703,"Exception parsing XML-RPC response: WindowsLive.Writer.CoreServices.XmlRpcClientInvalidResponseException: Invalid response document returned from XmlRpc server ---> System.Xml.XmlException: Root element is missing. at System.Xml.XmlTextReaderImpl.Throw(Exception e) at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo(String res) at System.Xml.XmlTextReaderImpl.ParseDocumentContent() at System.Xml.XmlTextReaderImpl.Read() at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace) at System.Xml.XmlDocument.Load(XmlReader reader) at System.Xml.XmlDocument.LoadXml(String xml) at WindowsLive.Writer.CoreServices.XmlRpcMethodResponse..ctor(String responseText) --- End of inner exception stack trace --- at WindowsLive.Writer.CoreServices.XmlRpcMethodResponse..ctor(String responseText) at WindowsLive.Writer.CoreServices.XmlRpcClient.CallMethod(String methodName, XmlRpcValue[] parameters) ","" WindowsLiveWriter,1356,None,00185,08-Apr-2009 02:15:40.125,"XML-RPC request:

    I did some research on this, if this issue just started happening, it might be a corrupt XML file. Looking through some news forums, it's pointing to an XML file; if an XML file has invalid chars in the beginning of the file, will produce this error, BUT it could be a bad or old XML parser...

    BUT if it was working fine, and then just stopped, I’d say a bad [corrupt ] XML file.

    OR/AND download the latest XML parser from Microsoft.
    I’d set a RESTORE POINT first.

    My guess would be install 'MSXML 4.0 Service Pack 3 (Microsoft XML Core Services)' and download it here...

    Install and reboot.

    Note: I don't know that this will help you, just trying to offer something...

    Hope this helps.

    L. Henry Jr.

    Friday, March 05, 2010 12:26 AM
  • hello L. Henry,
    Thanks a lot for your help. I tried reinstalling the MSXML, but it didn't help.

    However, from the error, I can see name of my very old blog in there. I had uninstalled WLW multiple times, and I was not expecting that it would still have my old settings, but it seems I was never able to do a clean uninstall.

    Could you tell me how can I completely uninstall WLW, so that it does not accesses any old XML file or setting, please. If the problem is with some existing XML file, that might probably fix it.

    I really appreciate your help.

    Friday, March 05, 2010 6:19 AM
  • IshanB,
    I’d make the suggestion you try REVO UNINSTALLER ; it'll un-install the program, folders and registry entries. With any luck, that will get you where you need to be.

    If your interested in your previous posts/drafts; I’d back those up before trying to eradicate the Windows Live Writer program from your system. They're in the documents folder.

    Just trying to help...


    Friday, March 05, 2010 8:40 PM
  • Hello LEHenry: I tried this as well, but no luck. Not sure what is going on.

    Could some developer of WLW help me, please.
    Saturday, March 06, 2010 6:07 PM
  • IshanB, there may be an XML file on your machine left from your old Windows Live Writer install that is causing this crash. Try the following:

    Go to Start > Run  and type "cmd.exe"
    A command line window will come up.
    Type:  cd %appdata%
    Hit Enter.
    Type:  rd /s /q "Windows Live Writer"
    Hit Enter.

    Try opening up Writer again and see if this resolves your issue.
    Windows Live Writer Developer
    Friday, March 12, 2010 9:00 PM
  • @WDuff
    But if he does that, won't he lose all his settings?
    Couldn't you just remove the one file? Assuming it's one file...

    I appreciate it...

    Friday, March 12, 2010 9:15 PM
  • @Will:

    Thanks for the response. I tried this, but this also did not solve the issue. 

    After running this command, i tried running this: "%USERPROFILE%\Local Settings\Application Data\Windows Live Writer\"

    I was expecting that this will not show any application data folders now. But this command showed me application data folder. Then I manually deleted the content of the folder, uninstalled WLW,  and reinstalled. Again same error.

    At this time, Application Folder is completely blank, and I don't even know where to get the latest log file from.

    Please help.

    (Is it possible to run WLW from USB stick? That can be a potential solution for me).

    Wednesday, March 24, 2010 5:57 AM
  • Yes it can...

    Happy blogging!

    Hope this helps.


    Wednesday, March 24, 2010 11:41 AM
  • Hello lehenryjr:

    Thanks again for your help. I tried this, but this also gave me same problem! (I have just one Windows PC, so had to copy the files from that only. I guess the problem got carried over to USB drive as well)



    Thursday, March 25, 2010 6:52 AM