locked
CRM 2013: Ribbon buttons are stale and wont overwrite RRS feed

  • Question

  • We have a managed solution which we have been installing for over 2 years.  It started in 2011 and is now in 2013.

    It is installed on many systems.  This issue is seen in only one of them.

    (I don't believe the following issue is to do with the upgrade)

    There is a custom entity and the form ribbon has 4 custom buttons.  These have been given new icons and rules regarding when to display.

    On the problem system, into which the new version of the managed solution has been installed, the images are old, one new button has not appeared and the display rules are being ignored.

    Although the system has some other solution installed, none of them have the custom entity.

    I have tried the force overwrite option.

    This has been installed on other systems successfully. 

    Any ideas on how to correct the problem?

    Friday, November 29, 2013 4:41 PM

All replies

  • Hi Gordon,

    So you are installing the managed solution over the top of an existing managed solution, but more buttons are added and images are updated?

    If you look at the images directly by browsing to the image webresource do you see the new image?

    Sometimes it takes a couple of solution imports for the new commands to be picked up - so that the button will appear.

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Saturday, November 30, 2013 12:46 PM
    Answerer