locked
Trouble connecting with Toshiba laptop with Vista Business RRS feed

  • Question

  • I have 4 XP machines that have been working great with WHS. However, I have tried and have not been able to get my laptop to connect.

    The laptop is a Portege M400-S5032 - Toshiba Tablet PC with 2 GB of RAM running Vista Business. When I try to run the Connector CD, I receive the following error:

    "An unknown network error has occurred. Please verify that your network connection is active and that your Windows Home Server is powered on. Then restart this Wizard."

    I get this message at the point in the Wizard after it asks me for the password for the Server.

    Prior to installing the latest build of WHS, I have tried the following:
    • The laptop is connected via wireless, so I tried connecting it with a cable.
    • Disabling all security software including firewalls.
    • Changing the server firewall settings to allow exceptions (following instructions found on the forum)
    Yesterday, I installed the latest build of WHS and restored my laptop to Factory defaults using the restore partition. I got the same error message. To make sure the Server was okay, I ran the Connect CD on another machine and it worked fine.

    Suggestions?

    Thanks,

    Craig
    Friday, April 20, 2007 12:34 PM

Answers

All replies

  • I am having the same exact problem after I upgraded to CTP. I have a Vista Ultimate macine and Media Center 2005 machine that have the same problem with both.
    Friday, April 20, 2007 1:30 PM
  •  

    1. Please make sure that the password is correct. There was a bug in one of the builds that for wrong password, the wizard gave an incorrect message.

     

    2. It could be that your router name resolution is not working. Could you try running Discovery.exe from C:\Program Files\Windows Home Server from your laptop and see whether this is connecting?

    Friday, April 20, 2007 1:42 PM
    Moderator
  • I have a Portege M400-1200TE Tablet. I've been wanting to use the connector on it. I guess this would be the good time. I will try it and keep you posted Craig.
    Friday, April 20, 2007 2:20 PM
  • I will try that probably some time later on today and let you know the results. Thanks for the quick response.

    Craig
    Friday, April 20, 2007 2:45 PM
  • For me, the trick seemed to be adding an entry for the Windows Home Server in my hosts file. It wasn't a solution that made logical sense to me because I had other Vista machines that had no problem connecting with the same network config.

    But it worked

    Friday, April 20, 2007 3:04 PM
  • FWIW - I have a M400 with Vista Ultimate installed, and have not had any issues installing the Beta 2 Connector. 

    I've had a few other issues since install, but I chalk those up to the beta and not the M400


    Friday, April 20, 2007 3:34 PM
  • Robert:

    Thanks for the post.

    I am not where I can get to the Server right now but how do I add something to the Host file?

    Thanks,

    Craig
    Friday, April 20, 2007 4:00 PM
  • Craig,

     

    The hosts file is in the directory C:\Windows\System32\drivers\etc. There is example of the format that you need to use to add an entry. Essentially it's just mapping a machine name to an IP address. The discovery process is using broadcasts for name resolution, and sometimes it can be somewhat unreliable.

     

    By the way, the hosts file that you want to modify is on the client machine that you are having trouble with.

     

    hth,

    Robert

    Friday, April 20, 2007 5:12 PM
  • I tried running Discover and it is NOT connecting.

    Other suggestions?
    Friday, April 20, 2007 10:32 PM
  • Robert:

    Thanks for the info but it didn't work for me. I modified the HOSTS file with the IP address of the server followed by about 5 spaces followed by the machine name of the server.

    Did I edit the file correctly?

    Thanks,

    Craig
    Friday, April 20, 2007 10:34 PM
  • Vista Business, 1.5GB, over wifi. It gave the exact same error listed above. I was able to solve my problem by doing two things. One, I updated my hosts file with my WHS's static address and the WHS machine name. At the same time, I realised that my router was set up to assign the static IP and machine name to the client with the same MAC address.
    I figured out that my router was still referring an old machine name to the WHS's IP address.

    I figure that if there you guys are having a problem, delete any record of the old computer from your router. Many DHCP servers hold a lease for hours, prehaps days. They may also assign a dynamic IP to a MAC address, and just keep it there.

    I figure most people wiped a existing computer. This existing computer had a different host name than the new WHS. This seems to be the cause of the problem.

    Can anyone confirm this?
    Saturday, April 21, 2007 12:35 AM
  • I added the server to my hosts file.  Now ntbstat -r reports 8 server objects...
    Saturday, April 21, 2007 4:41 AM
  • Finally figured out how to get the software installed when the connector fails and removes it.  Quit the installer in task manager.  It left the Windows Home Server folder behind this time. Don't know if the registery is in order, as I don't know of a way to document it.  But now when I run talq it generates a report and uploades it.  So off I go to enter the bug report and see if anything useful is in the talq report this time...

    Saturday, April 21, 2007 5:24 AM
  • I have tried all suggestions but it has not worked yet. I have run talq and I going to submit a bug report.

    I am certainly still open to suggestions.

    Thanks to all.

    Craig
    Saturday, April 21, 2007 1:23 PM
  • Check out my other post on connector issues.  I have one solution working.  It needs to be tried by others to insure it's not just happenstance that my machine started working.

     

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1295669&SiteID=50

     

     

    Sunday, April 22, 2007 3:38 AM
  • I'm not sure what combination of things did it but it works!

     

    One of the last things I did was to make sure all the machines had static IPs and were part of the same Workgroup.

     

    Thanks to all for your suggestions,

     

    Craig

    Sunday, April 22, 2007 8:01 PM
  • After a completely successful setup of WHS I changed from a DHCP assigned IP to a static one in order to get remote access working through my router. After doing this I completely lost access to my server through shared folders etc. When I tried a rerun of the connect Cd I got the unknown error others have got. Repeated attempts reproduced exactly the same error, I then put the IP and machine name in my hosts file exactly as suggested and the process went perfectly after that.

     

    Thanks for the advice.

    Tuesday, April 24, 2007 12:21 AM