Where's my HPC PowerShell? RRS feed

  • General discussion

  • Hey Nerdettes and Nerds, did you try to open the PowerShell(or any other command line tool)  in your HPC Pack Start Menu folder only to have it disappear?

    Well I did on my Quad Core Woodcrest client and all I saw was a brief flash as the command Window opened briefly then closed.

    I'm sure it had something to do with running first Beta1, then RC1 and finally RC2 on the same machine. Somewhere something got lost. As I dug into it I found the root cause was pretty general to the command shell. To get the first clue about what I was running into, go to the Start->All Programs->Microsoft HPC Pack->HPC PowerShell and right click it. You will see a multitabbed window that has under the Shortcut tab a field called Target. Mine looked like this:

    %SystemRoot%\System32\WindowsPowerShell\v1.0\powershell.exe -PSConsoleFile "%CCP_HOME%\bin\CcpPsh.psc1" -noexit

    Well this is the command that will run to open the command shell window. All very nice, but in my case the environment varialblr CCP_HOME had gotten lost. I found this out by going to a plain old cmd shell and doing the following:

    C:\Users\frankch.REDMOND>set|grep CCP
    CCP_DATA=C:\Program Files\Microsoft HPC Pack\Data\
    CCP_HOME=C:\Program Files\Microsoft HPC Pack\
    CCP_INC=C:\Program Files\Microsoft HPC Pack 2008 SDK\Include\
    CCP_LIB32=C:\Program Files\Microsoft HPC Pack 2008 SDK\Lib\i386\
    CCP_LIB64=C:\Program Files\Microsoft HPC Pack 2008 SDK\Lib\amd64\
    CCP_SDK=C:\Program Files\Microsoft HPC Pack 2008 SDK\

    Now this is a fixed version. In the broken version the value of CCP_HOME was like this
    D:\Documents and Settings\frankch>set|findstr "CCP"
    CCP_HOME=D:\Program Files\Microsoft Compute Cluster Pack\

    Of course that didn't exist any more after all my installs and uninstalls.

    My fix was a bit heavy handed, but what I did was: Go to Start->Computer right click Properties, then in the left panel left click Advanced System Settings OK the Administrator elevation which brings up the System Properties window then in the Advanced tab I clicked on Environment Variables. Sure enough CCP_HOME was set to the old location, so I clicked on CCP_HOME then on Edit and pointed it to the right location. Closed the cascade of windows and tried it again and got my window. It worked but wasn't pretty enough for me. So I closed it. Went to the shortcut in the HPC Pack submenu and right clicked the HPC PowerShell shortcut and did the following:

    Under 'General" I always check Quick Edit Mode and Insert Mode. I just love the double click to select the right click to paste feature I get with this. Under Font, I always select Lucida COnsole for a fixed size font. This makes editting scripts much easier for me. Under Layout I like to set Screen Buffer Size height to 999. You can never have too much history. I also like to set Window Size Height to 40. And of course under colors I color code the window to blue background with white text. Then I Apply, evevate to Admin and voila, I have a pretty Power Shell and am a happy Frankie.

    Keep in mind you can do the makeover to _any_ command line shortcut with different looks for each one. You should see my bash shell......


    Welcome to the SUA utilities.


    WARNING: One or more events have been logged in the Event Log
             that the system administrator should investigate.

    bash-3.2$ pwd
    bash-3.2$ df
    Filesystem           512-blocks      Used Available Capacity Type  Mounted on
    //HarddiskVolume1     245759992 107269088 138490904    44%   ntfs  /dev/fs/C
    bash-3.2$ ps
       PID TTY     TIME CMD
       325 n00  0:00.00 ps
      1219 n00  0:00.05 bash

    Monday, September 15, 2008 11:37 PM