locked
Problem validating manifest SCROM 1.2 RRS feed

  • General discussion

  • I also tried to see if the course generated by the LCDS works with a SCORM 1.2 compatible LMS.  But it seems that the LCDS Can't generate SCORM 1.2 stadart courses.

    I properly pack into a zip file my course and then when i tried to upload it an error message apears, I also proved to test the course in the "Reload SCROM 1.2 Player" and the following error message apears:

    Problem validating manifest
    (file:/C:/Users/Cesar/reload/reload-scorm-player/server/webapps/reload-scorm-player/course-packages/8/imscp_rootv1p1p2.xsd: 57, 53): src-resolve: Cannot resolve the name 'xml:base' to a(n) 'attribute declaration' component.
    (file:/C:/Users/Cesar/reload/reload-scorm-player/server/webapps/reload-scorm-player/course-packages/8/imscp_rootv1p1p2.xsd: 57, 53): s4s-elt-must-match.1: The content of 'attr.base' must match (annotation?, ((attribute | attributeGroup)*, anyAttribute?)). A problem was found starting at: attribute.
    (file:/C:/Users/Cesar/reload/reload-scorm-player/server/webapps/reload-scorm-player/course-packages/8/imscp_rootv1p1p2.xsd: 243, 38): s4s-elt-invalid-content.1: The content of 'manifestType' is invalid.  Element 'attribute' is invalid, misplaced, or occurs too often.

     

    Sunday, March 29, 2009 4:41 AM

All replies

  • I'm having the same problem with SCORM packaging, and I'm getting the same error message: "Problem validating manifest"; after zipping the course and trying to import it into my LMS (Moodle 1.9).

    Has anyone resolved this problem with packaging LCDS-created content and importing it into Moodle?

    Thanks,
    Pete

    Tuesday, April 28, 2009 2:56 PM
  • Ok, something wrong to help file.
    <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-charset:1; mso-generic-font-family:roman; mso-font-format:other; mso-font-pitch:variable; mso-font-signature:0 0 0 0 0 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0cm; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New Roman","serif"; mso-fareast-font-family:Arial; mso-fareast-theme-font:minor-latin;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; font-size:10.0pt; mso-ansi-font-size:10.0pt; mso-bidi-font-size:10.0pt;} @page Section1 {size:612.0pt 792.0pt; margin:72.0pt 72.0pt 72.0pt 72.0pt; mso-header-margin:36.0pt; mso-footer-margin:36.0pt; mso-paper-source:0;} div.Section1 {page:Section1;} --> Now, I known the reason why.
    you should not zip the folder, you should access inside the folder -> select All files -> zip all.

    Have fun
    Tuesday, May 26, 2009 12:58 AM