locked
Remote Access Displays Connector Setup Page RRS feed

  • Question

  • Hi all

    I am having a little bit of trouble with the WHS remote access.  When I use our  .homeserver.com domain, It simply returns the windows home server connector setup page.  On there are options to install the connector software, or run the WHS toolkit.  This can be accessed outside of the internal network.

    I was just wondering if anyone could point me in the right direction?


    Wednesday, March 3, 2010 9:34 AM

Answers

  • You will have to take a look at your router settings - looking under port forwarding, or on some routers it's in firewall.

    If you goto http://servername/  not http://servername.homserver.com/ from inside your network do you get the connector page then?  You could also try the private IP address of the server i.e. http://192.168.1.100/


    --
    • Marked as answer by andyk123 Friday, March 5, 2010 11:24 AM
    Thursday, March 4, 2010 11:35 AM
  • Hi,
    internal within your home network try:
    http://yourservername
    and
    http://yourservername:55000
    If both end up with the same page, you may have changed something on the server in the IIS settings.
    If this works properly, port forwarding on the router would be the next point:
    incoming port 80 to WHS IP port 80
    incoming port 443 to WHS IP port 443
    incoming port 4125 to WHS IP port 4125

    Thats it, nothing in relation to 55000 or other WHS ports.

    Best greetings from Germany
    Olaf
    • Marked as answer by andyk123 Friday, March 5, 2010 11:24 AM
    Thursday, March 4, 2010 8:42 PM
    Moderator
  • Hi All

    Thanks for your suggestions, which helped me to resolve my issue.

    After looking into the IIS on the home server, I noticed that the home directory local path was set to c:\inetpub\.  After I changed this to c:\inetpub\wwwroot, I got the windows Home Server Remote Access login screen and could login in as normal.

    For any novice users like me having this issue, here are the steps I took

    Login to the servers remote desktop


    1) Start>Programmes>Accessories>Remote Desktop Connection

    2) Type the name of your server, usually SERVER as default. 

    3) Click Connect

    4) Type in your home server password

    You should now be logged into your homeservers desktop

    Access WHS IIS

    5) Start>Programmes>Administrative Tools>Internet Information Services

    6)Click the + sign next to your servers name, to expand the tree on the left hand side of the dialogue box

    7)Click on the Websites folder

    8)In the right hand window, ensure you have two website folders, these should be named Default Website , Windows Home Server Website .

    9)Ensure they are both running.  If they are not, right click and choose start.

    10)Ensure the ports are as follows:

    • Default Website Port 80       SSL Port 443
    • WHS Site          Port 55000  SSL Port 56000
    11) Right click on the default website and choose properties

    12) Choose the home directory tab

    13)Select the radio button, A directory Located on this computer.

    14) In the local path, ensure c:\inetpub\wwwroot is displayed. 

    15) If not, choose browse and in the inetpub folder is displayed, choose wwwroot.

    16) Choose the following buttons: read, log visits and index this resource

    17) Application name: default application

    18) Execute Permisions: scripts only

    19) Application Pool: defaultapppool

    These are the steps I took to get my home server remote access working correctly.  If there are any steps which are not correct, please do let me know, however, it did work for me.

    Thanks again for all your help and guidance.

    Regards
    Andy
    • Marked as answer by andyk123 Friday, March 5, 2010 11:27 AM
    Friday, March 5, 2010 9:02 AM

All replies

  • Hi,

    Are you saying that when you access your servername.homeserver.com address from outside your home network (i.e. internet cafe, work, school) you get the page that gives you the option to install the connector software and toolkit?  If so how did you setup the remote access?  Perhaps take a look at this guide to check you have done that okay:
    http://www.wegotserved.com/2009/06/22/get-started-configure-windows-home-server-remote-access/

    For some reason it appears you have forwarded port 80 to port 55000 on your home server.

    Maybe it is worth going through the remote access setup wizard once again after enabling UPNP on your router and let Windows Home Server take care of the port forwarding.

    Cheers,
    Al
    --
    Wednesday, March 3, 2010 10:22 AM
  • Hi Al

    Thanks for getting back to me, and for providing me with the link.

    I will follow the steps again to see if I can resolve.

    I will keep you informed of how I got on.

    Cheers
    Andy
    Wednesday, March 3, 2010 11:18 AM
  • Hi Al

    I have gone through the setup wizard and I am still having the same issue.  When I visit survername.homeserver from outside the home, it still displays the connector page.

    Is there any way I can check whether I have forwarded port 80 to 55000 on the home server?

    Thanks again.
    Andy
    Thursday, March 4, 2010 11:02 AM
  • You will have to take a look at your router settings - looking under port forwarding, or on some routers it's in firewall.

    If you goto http://servername/  not http://servername.homserver.com/ from inside your network do you get the connector page then?  You could also try the private IP address of the server i.e. http://192.168.1.100/


    --
    • Marked as answer by andyk123 Friday, March 5, 2010 11:24 AM
    Thursday, March 4, 2010 11:35 AM
  • Hi Al

    Yes, I have tried the ip address of the server and I still get the connector page.  The port forwarding seems to be Ok on the router, and I have spoke to BT who set up the port forwarding for me.

    Cheers
    Thursday, March 4, 2010 2:44 PM
  • Hi Al

    Yes, I have tried the ip address of the server and I still get the connector page.  The port forwarding seems to be Ok on the router, and I have spoke to BT who set up the port forwarding for me.

    Cheers
    First, just to make sure we're on the same page, you are trying this from outside of your household, right (i.e. a friend's house, work, Starbucks, etc.)?

    Also, can you please login to your router and copy and paste all of the port forwarding settings here?
    Thursday, March 4, 2010 4:15 PM
    Moderator
  • Hi,

    If you are using the internal address of your home server and you are getting the connector page then I am suspicious of what BT have done.  Can you get them to clear all the port forwards, set UPNP on and then go through the wizard process in the Home Server Console.

    It's probably in your best interests to read up on how to setup port forwarding on your router and do it yourself.

    Cheers,
    Al
    --
    Thursday, March 4, 2010 5:31 PM
  • Hi,
    internal within your home network try:
    http://yourservername
    and
    http://yourservername:55000
    If both end up with the same page, you may have changed something on the server in the IIS settings.
    If this works properly, port forwarding on the router would be the next point:
    incoming port 80 to WHS IP port 80
    incoming port 443 to WHS IP port 443
    incoming port 4125 to WHS IP port 4125

    Thats it, nothing in relation to 55000 or other WHS ports.

    Best greetings from Germany
    Olaf
    • Marked as answer by andyk123 Friday, March 5, 2010 11:24 AM
    Thursday, March 4, 2010 8:42 PM
    Moderator
  • Hi All

    Thanks for your suggestions, which helped me to resolve my issue.

    After looking into the IIS on the home server, I noticed that the home directory local path was set to c:\inetpub\.  After I changed this to c:\inetpub\wwwroot, I got the windows Home Server Remote Access login screen and could login in as normal.

    For any novice users like me having this issue, here are the steps I took

    Login to the servers remote desktop


    1) Start>Programmes>Accessories>Remote Desktop Connection

    2) Type the name of your server, usually SERVER as default. 

    3) Click Connect

    4) Type in your home server password

    You should now be logged into your homeservers desktop

    Access WHS IIS

    5) Start>Programmes>Administrative Tools>Internet Information Services

    6)Click the + sign next to your servers name, to expand the tree on the left hand side of the dialogue box

    7)Click on the Websites folder

    8)In the right hand window, ensure you have two website folders, these should be named Default Website , Windows Home Server Website .

    9)Ensure they are both running.  If they are not, right click and choose start.

    10)Ensure the ports are as follows:

    • Default Website Port 80       SSL Port 443
    • WHS Site          Port 55000  SSL Port 56000
    11) Right click on the default website and choose properties

    12) Choose the home directory tab

    13)Select the radio button, A directory Located on this computer.

    14) In the local path, ensure c:\inetpub\wwwroot is displayed. 

    15) If not, choose browse and in the inetpub folder is displayed, choose wwwroot.

    16) Choose the following buttons: read, log visits and index this resource

    17) Application name: default application

    18) Execute Permisions: scripts only

    19) Application Pool: defaultapppool

    These are the steps I took to get my home server remote access working correctly.  If there are any steps which are not correct, please do let me know, however, it did work for me.

    Thanks again for all your help and guidance.

    Regards
    Andy
    • Marked as answer by andyk123 Friday, March 5, 2010 11:27 AM
    Friday, March 5, 2010 9:02 AM