locked
Error when creating a new CRM organization from HMC (CreateOrganization.xml) RRS feed

  • Question

  • Dears i am facing the following error when run 'CreateOrganization.xml" in the hosted CRM
    kindly help as fast as you can

    C:\Program Files\Microsoft Hosting\Provisioning\Samples\Hosted CRM>provtest /x2
    "C:\Program Files\Microsoft Hosting\Provisioning\Samples\Hosted CRM\CreateOrgani
    zation.xml"
    <response>
      <errorContext description="The request failed with HTTP status 401: Unauthoriz
    ed.
    crmDeploymentServiceUrl='http://linkcrmdep1d:5555/mscrmservices/2007/CrmDeployme
    ntService.asmx'
    WebMethod='Execute'
    RequestType='CreateRequest'
    DeploymentEntity='Organization'
    UniqueName='AlpineSkiHouse'
    FriendlyName='Alpine Ski House'
    SqlServerName='linkcrmsql1d'
    BaseCurrencyName='US Dollar'
    BaseCurrencyCode='USD'
    BaseCurrencySymbol='$'
    State='Enabled'
    SrsUrl='http://Linkcrmsql1d/ReportServer'
     webSvc.Url:'http://linkcrmdep1d:5555/mscrmservices/2007/CrmDeploymentService.as
    mx'
     webSvc.Timeout(in msec):'600000'
     webSvc.UseDefaultCredentials:'True'
     CurrentSecurityPrincipal:'LINKCRM\MPSPrivAcct-69804'"
          code="0x80131600"
          executeSeqNo="96">

        <errorSource namespace="CRM Provider"
            procedure="CreateOrganization"/>

        <errorSource namespace="Managed CRM"
            procedure="CreateOrganization_"/>

        <errorSource namespace="Managed CRM"
            procedure="CreateOrganization"/>

        <errorSource namespace="Hosted CRM"
            procedure="CreateOrganization"/>

      </errorContext>
    </response>


    john yassa
    Sunday, January 3, 2010 12:57 AM

All replies

  • after checking the MPS Traceview i got the following
    kindly help

    Time 01/03/2010 03:03:15.377
    Tag Engine
    Log Level 2
    Process ID 0xf74
    Thread ID 0xf80
    Description CMapsProcessControllerTx::SecuredProcessRequest Failed while executing Process Request
    error 0x80131600
    machine LINKCRMMPS1D

    Time 01/03/2010 03:03:15.393
    Tag Engine
    Log Level 5
    Process ID 0xf74
    Thread ID 0xf80
    Description Leaving CMapsProcessControllerTx::SubmitTrustedRequest HR=80131600
    machine LINKCRMMPS1D

    john yassa
    Sunday, January 3, 2010 1:11 AM
  • Does your user is CRM Deployment Administrator ?
    Check you CRM Log c:\Documents and Settings\<username>\Application Data\Microsoft\MSCRM\Logs

    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Sunday, January 3, 2010 2:37 AM
  • yes the user is in deployment Administrator
    no log has been created
    as the error appears from the MPS side
    john yassa
    Sunday, January 3, 2010 2:48 AM