none
HPC Pack 2012 with SQL express 2012, now scheduler database file oversized, how to reduce to normal status.... Thanks RRS feed

  • Question

  • Log Name:      Windows HPC Server
    Source:        Microsoft-HPC-Scheduler
    Date:          5/8/2020 6:13:42 PM
    Event ID:      21
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      
    Description:
    The scheduler database is full and cannot accept new jobs. Delete old jobs to free up space.
    
    Log Name:      Windows HPC Server
    Source:        Microsoft-HPC-Scheduler
    Date:          5/8/2020 5:12:50 PM
    Event ID:      93
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      
    Description:
    The scheduler failed to clean out old jobs from the database during normal operation.  Please re-start the scheduler service to ensure that the cleanup completes.
    
    HPC Pack 2012 with SQL express 2012, now scheduler database file oversized, how to reduce to normal status.... Thanks


    Friday, May 8, 2020 10:26 AM

All replies

  • Hi,

    Had you tried to restart the HpcScheduler service per the advice in the error message?

    Another thing you should do is to reduce the job record retention period, go to HPC Cluster Manager, in the "Options" menu, click "Job Scheduler Configuration" -> "Job History", and reduce the value of "Days to keep jobs in history".

    Saturday, May 9, 2020 9:03 AM
  • Hi Zhu, Sunbin,

    Thanks for your suggestion, We did that restart the service and reduce Days to keep jobs in history, but it didn't work. Because we couldn't find the reason, we rebuild the system and upgraded to hpc pack 2016 :(, running well so far...


    Best Regards

    Wayne

    Monday, May 11, 2020 6:12 AM