locked
Error preparing the AD forest in OCR 2007 R2 setup RRS feed

  • Question

  • Hi All!

    We are running a small OCS 2007 Standard Edtition system here in our company. We now want to migrate in OCS 2007 R2 SE and installed a new W2K8 x64 server in our datacenter. We already moved the global settings from the system container of the root domain to the configuration server as described in the "Migration from Office Communications Server 2007" document.

    After that we started the setupse.exe and tried to prepare the AD for R2. Unfortunetly, it does not really work. We get a lot of yellow warnings ("check attribute values: wrong") in the logfile at the second AD preparation step, the preparation of the forest. The first step (prepare schema is working correctly). It is possible to ignore the warnings an continue the AD preparation. This works without any more errors.

    But then when we want to install the OCS R2 the installation fails when the setup wants to activate the Standard Server with the error code 0xC3EC796C. I think the error means that the AD is not prepared correctly.

    What is the problem in our AD and how can we fix it?

    Thanks a lot for your help in advance!

    JuWe

    Wednesday, June 3, 2009 9:30 PM

All replies


  • Can you share the log files for R2 Prep Forest step or at least extract the sections with errors?

    Did you carry out R2 Prep Domain as well before you start R2 setupse.exe?

    Are both the AD forest and domain functional level at Windows Server 2003 or above?


    http://www.leedesmond.com
    Wednesday, June 3, 2009 10:39 PM
    Moderator
  • Thanks for your answer. You can find the logfile here: http://www.wes02.de/ad-prep-protocol.mht. Please note that I used the German setup version so the logfile is partly in German language. If I have to translate some words or sentences for you please let me know.

    I do not understand your second question. The R2 Prep Domain Wizard is part of the setup, isn´t it? And it is the place where I get the error/warnings.

    The AD forest and domain are at Windows Server 2008 level.


    Thursday, June 4, 2009 2:13 PM
  • Perhaps you have problems reading the German error log. So I´ve rerun the AD preparation wizard with an English version of the OCS 2007 R2 setup dvd. You can download the English log file here: http://www.wes02.de/english-log.html.

    Thanks a lot for your help in advance!

    JuWe
    Friday, June 5, 2009 7:55 AM

  • For OCS Prepare Environment, Prep Schema, Prep Forest and Prep Domain are 3 separate and distinct steps. You must run them in sequence to properly prepare the environment and allow AD replication to complete before you execute setupee.exe or setupse.exe.

    ( Falls ich Begriffe nicht verstehen kann werde ich nachfragen! )

    Thank you.

    http://www.leedesmond.com
    Friday, June 5, 2009 10:18 AM
    Moderator
  • You are confusing me. The AD preparation wizard is part of setupse.exe (first choice on the welcome screen of the setup labeled "Prepare Active Directory"). How can I run the preparation wizard without setupse.exe. Is there a command line version? What are the exact commands to run?

    Thanks again.

    PS: Entschuldigung, ich wusste nicht, dass Sie deutsch können :-)

    Friday, June 5, 2009 3:13 PM
  • I´ve read the document "OCS 2007 R2 Preparing Active Directory Domain Services" in the meantime and tried to prepare the AD with the lcscmd-command "lcscmd.de /forest /Action:ForestPrep". But I still get an error/the same error log:

    ------------------------------------------------------------------------------------------------------
    Executing "Create Permission Settings of RTCUniversalUserAdmins"
    Executing "Create Permission Settings of RTCUniversalReadOnlyAdmins"
    Executing "Create Permission Settings of RTCUniversalGuestAccessGroup"
    Executing "Create Forest Permissions"
    Executing "Create Permission Settings of RTC Service"
    Executing "Create Permission Settings of ConfigurationContainer"
    Executing "Create Permission Settings of RootDomainSystemContainer"
    Executing "Create Permission Settings of ConfigurationDisplaySpecifiersContainer
    "
    Executing "Check Permission Settings of ConfigurationContainer"
    Executing "Check Permission Settings of SchemaContainer"
    Check the log file "C:\Users\ADMINI~1.WES\AppData\Local\Temp\1\Forest_ForestPrep
    [2009_06_05][20_50_19].html" for details.
    Action succeeded with one or more non-critical error events logged. Please check
     the log file for more detail.

    Execution time = 2016 ms

    D:\Setup\amd64>
    -----------------------------------------------------------------------------------------------------

    I really have no idea what I can do to solve the problem...

    Friday, June 5, 2009 6:59 PM
  • My apologies for the confusion. I meant to say that you can Prepare the AD Environment (Prep Schema / Forest / Domain) from the main setup program after setupse.exe or setupee.exe is started.

    After you Prep Forest, did you check the contents of the log file "C:\Users\ADMINI~1.WES\AppData\Local\Temp\1\Forest_ForestPrep[2009_06_05][20_50_19].html" for details?

    Did you try to start Prep Domain after the Prep Forest step?



    http://www.leedesmond.com
    Friday, June 5, 2009 8:12 PM
    Moderator
  • Yes, I checked the log. It contains exactly the same errors as in http://www.wes02.de/english-log.html.

    I also run the prep domain several times. It completes successfully without any errors (like the schema preparation).

    Do you have an idea?
    Friday, June 5, 2009 8:55 PM

  • I took a quick look at english-log.htm and the overall Execution Result is listed as Success. This means that you should be able to start on the next setup step in R2. Make sure that you click on Prerequisites on each step  to confirm that you are using the account with sufficient privileges (or click Help for more info).

     


    http://www.leedesmond.com
    Monday, June 8, 2009 5:15 PM
    Moderator
  • I´m logged in as "Administrator". When I install the OCS R2, the installation fails when the setup wants to activate the Standard Server with the error code 0xC3EC796C. It means that the AD is not prepared correctly. :-(((
    Tuesday, June 9, 2009 7:51 AM