locked
CRM Email Router: The attachment must be a "forward-as-attachment" e-mail message. RRS feed

  • Question

  • I'm having an issue where for some reason the attachments (via the outlook rule) are coming over as .bin, and not being processed by the email router.  If i manually forward an email as an attachment, it will come over as .msg, and the email router will process accordingly.  Any ideas why the rule would force the attached email to a .bin extension?  This shows up in the log:

     

    Event Type: Error
    Event Source: MSCRMEmail
    Event Category: None
    Event ID: 0
    Date:  6/3/2010
    Time:  7:42:16 AM
    User:  N/A
    Computer: ******
    Description:
    #17174 - An error occurred while validating the e-mail message with subject "FW: Two Celebrations" in mailbox CRM.Email@*****org. Microsoft.Crm.Tools.Email.Providers.EmailException: An error occurred while trying to extract the attachment from the incoming e-mail message.
    The attachment must be a "forward-as-attachment" e-mail message. ---> Microsoft.Crm.Tools.Email.Providers.EmailException: An error status code has been reported: <a:multistatus xmlns:b="urn:uuid:c2f41010-65b3-11d1-a29f-00aa00c14882/" xmlns:d="urn:schemas:httpmail:" xmlns:e="urn:schemas:mailheader:" xmlns:c="xml:" xmlns:a="DAV:"><a:response><a:href>https://webmail.******/Exchange/CRM.Email/Inbox/FW:%20Two%20Celebrations.EML/ATT00001.bin</a:href><a:propstat><a:status>HTTP/1.1 404 Resource Not Found</a:status><a:prop><d:subject /><d:from /><d:to /><d:cc /><d:bcc /><d:datereceived /><d:importance /><d:htmldescription /><e:message-id /></a:prop></a:propstat></a:response></a:multistatus>.
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.ValidateStatus(XmlNode xmlRootNode, XmlNamespaceManager xmlNamespaceManager, String xPathStatus)
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.RetrieveMessage(ServiceLogger serviceLogger)
       at Microsoft.Crm.Tools.Email.Providers.ExchangeEmailMessage.ValidateMessage(Boolean isForwardMailbox)
       --- End of inner exception stack trace ---
       at Microsoft.Crm.Tools.Email.Providers.ExchangeEmailMessage.ValidateMessage(Boolean isForwardMailbox)
       at Microsoft.Crm.Tools.Email.Providers.ExchangePollingMailboxProvider.ValidateMessageInternal(EmailMessage emailMessage)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()\r\nMicrosoft.Crm.Tools.Email.Providers.EmailException: An error status code has been reported: <a:multistatus xmlns:b="urn:uuid:c2f41010-65b3-11d1-a29f-00aa00c14882/" xmlns:d="urn:schemas:httpmail:" xmlns:e="urn:schemas:mailheader:" xmlns:c="xml:" xmlns:a="DAV:"><a:response><a:href>https://webmail*****/Exchange/CRM.Email/Inbox/FW:%20Two%20Celebrations.EML/ATT00001.bin</a:href><a:propstat><a:status>HTTP/1.1 404 Resource Not Found</a:status><a:prop><d:subject /><d:from /><d:to /><d:cc /><d:bcc /><d:datereceived /><d:importance /><d:htmldescription /><e:message-id /></a:prop></a:propstat></a:response></a:multistatus>.
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.ValidateStatus(XmlNode xmlRootNode, XmlNamespaceManager xmlNamespaceManager, String xPathStatus)
       at Microsoft.Crm.Tools.Email.Providers.HttpDavRequest.RetrieveMessage(ServiceLogger serviceLogger)
       at Microsoft.Crm.Tools.Email.Providers.ExchangeEmailMessage.ValidateMessage(Boolean isForwardMailbox)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Thursday, June 10, 2010 1:24 PM

Answers

  • Please check the CRM Outlook Rule and ensure that the checkbox "forward to people or public group as attachment" is selected.

    Regards, Donna

    • Marked as answer by Jim Glass Jr Tuesday, August 24, 2010 4:01 PM
    Tuesday, August 24, 2010 1:30 PM

All replies

  • Which Emailsystem do you use? MS Exchange?, which version?
    Wednesday, August 18, 2010 11:09 AM
  • What version of Exchange do you have. I know that similar issue was on 2003 and MS threat as a bug.

    In your situation I will check also antivirus and check the rule - maybe setup as Server not Client rule.

    KG


    My Dynamics CRM Blog: http://bovoweb.blogspot.com
    Wednesday, August 18, 2010 12:28 PM
  • Please check the CRM Outlook Rule and ensure that the checkbox "forward to people or public group as attachment" is selected.

    Regards, Donna

    • Marked as answer by Jim Glass Jr Tuesday, August 24, 2010 4:01 PM
    Tuesday, August 24, 2010 1:30 PM