locked
Does batching work with snapshot? RRS feed

  • Question

  • I am still seeing the dreaded "maximum message size quota for incoming messages (65536)" when I try to snapshot a table with ~ 20,000 rows , using n-tier and the SqlExpressClientSyncProvider.

    (Everything works fine with a smaller dataset)

    I added batching using the example http://msdn.microsoft.com/en-us/library/bb902828.aspx
    but I stil see this error.
    I am using version 1.0.1208.0 of Microsoft.Synchronization.Data.dll

    Thanks,Peter
    • Moved by Hengzhe Li Friday, April 22, 2011 3:21 AM (From:SyncFx - Microsoft Sync Framework Database Providers [ReadOnly])
    Monday, April 27, 2009 11:33 PM

Answers

  • OK - snapshot sync finally works.

    The solution was to increase WCF properties on server and client :

     

     maxBufferSize="20000000" 
    maxReceivedMessageSize="20000000"

    Thanks,Peter

     

    • Marked as answer by peter clift Wednesday, May 6, 2009 10:43 PM
    • Edited by peter clift Wednesday, May 6, 2009 10:45 PM
    Thursday, April 30, 2009 4:56 PM

All replies

  • Hello,

    I have the same problem. I have to increase the maximum message size to sync my data.
    I am not sure, but i think the batch-mode doesn't reduce the number of messages for a wcf-service, by one synchronisation.
    Is it right?


    best regards

    Boris
    Tuesday, April 28, 2009 6:16 AM
  • Boris,
    Are you saying that batching does not have any effect with snapshot ? Does that mean that we cannot snapshot large datasets ?
    On the client, I set maxReceivedMessageSize="1500000" , but I still get the error. Any ideas ?

     
          <netTcpBinding>
            <binding name="TCPBinding_Configuration" closeTimeout="00:01:00" openTimeout="00:01:00"
                receiveTimeout="00:10:00" sendTimeout="00:01:00" transactionFlow="false"
                transferMode="Buffered" transactionProtocol="OleTransactions"
                hostNameComparisonMode="StrongWildcard" listenBacklog="10"
                maxBufferPoolSize="524288" maxBufferSize="65536" maxConnections="10"
                maxReceivedMessageSize="1500000">
              <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384"
                  maxBytesPerRead="4096" maxNameTableCharCount="16384" />
              <reliableSession ordered="true" inactivityTimeout="00:10:00"
                  enabled="false" />
              <security mode="Transport">
                <transport clientCredentialType="Windows" protectionLevel="EncryptAndSign" />
                <message clientCredentialType="Windows" />
              </security>
            </binding>
          </netTcpBinding>
    Tuesday, April 28, 2009 3:15 PM
  • Hello,

    Sorry I don't know it. I want to test it in my project, but I can't use the snapshot-mode cause of schema problems.
    Have you test if it works with download only? Maybe it works, then the snapshot-mode can be the problem.

    I am not working very long with WCF, but I know that some changes you made in the service are not automatical in the client-config.
    Please look also in the client-config if your changes also there.


    best regards

    Boris
    Wednesday, April 29, 2009 6:34 AM
  • OK - snapshot sync finally works.

    The solution was to increase WCF properties on server and client :

     

     maxBufferSize="20000000" 
    maxReceivedMessageSize="20000000"

    Thanks,Peter

     

    • Marked as answer by peter clift Wednesday, May 6, 2009 10:43 PM
    • Edited by peter clift Wednesday, May 6, 2009 10:45 PM
    Thursday, April 30, 2009 4:56 PM