locked
2 servers one router, now what? RRS feed

  • Question

  •  

    I want to participate in the pp1 beta but didn't want to play with my EX475 so I reactivated my old beta machine using the RTM and successfully set it up.  Now I have it connected to one of my XP latptops and am ready to go, except for remote connect.  I'd like to try both remotely, but my router is set up for the EX475, using ports 80, 443 and 4125.  I've searched the forums and it seems some people have tried changing the server ports, but I didn't find a cook book that would work for me.  If I could define new mappings for 80, 443 and 4125 for the beta server I could map it on the router.  Am I looking for something that isn't possible or is there a way?

    Jerry

    Wednesday, May 28, 2008 12:14 AM

Answers

  • I think it's time to close this out.  First Cybermack, and Ken, you too, thank you!  The instructions helped a lot and got me started.  What was missing, though is thie instructions to open the firewall on the server.  I found that at http://www.myhomeserver.com/, which has a lot of good information, step by step, in case anyone else runs into this.

     

    I followed these instructions a few times and thought I couldn't get it to work.  I even wasted a product key and reinstalled, to no success.  then I tried remote connecting using hppts://servername.homeserver.comStick out tongueort# and realized it worked, enen though the homeserver remote configuration screen said it failed.  This, I hope is cleared up by the PP1 enhnaced details that is billed.  What I got for an error, is that UPnP failed (expected), then the server couldn't open the web services, or something like that.  I think my mistake was believing those errors.  I also realized that I shouldn't have clicked on configure domain name, which messed up my original, as you can't have 2 server names on homserver.com.  The first clue about that is when my security certificates got messed up, and are still messed up (like others I guess from the forum).

     

    Anyway, if I were going to do it again, I'd configure my production home server first.  Then power up the beta machine, change the ports, open the firewall on the server as well as the modem, reboot and then just try to connect to the site via the internet.  I don't know if it is that easy or not, but if anyone else tries this, don't work as hard as I did.

     

    Jerry

    Sunday, June 8, 2008 12:46 PM

All replies

  • Hi!

     

    Have you configured the portforwardings manually or via uPnP?

     

    However, many routers support forwarding port X to port Y, e.g. forward 8080 to port 80 on your beta server, port 4443 to port 443 and so on.

     

    Then you would be able to connect to the remote-access via http://<your-external-ip>:8080  or  https://<your-external-ip>:4443

     

    Regards, Alex

    Wednesday, May 28, 2008 3:27 PM
  • Alex, thanks for your reply.  I have to manually set up my router, as it is a 2Wire.  I did make a quick try by forwarding a new port number to port 443 as a test, but don't think I tried hard enough. I think I successfully set up the router, but when I went to the WHS setup, the router test failed saying the port was used.   I'll try again tonight with your specific encouraging instructions. 

    Wednesday, May 28, 2008 4:40 PM
  • jerry,

     

    Wow what a conundrum you have there. 2wire routers are a bit fussy, I know because I used to work for 2wire and support them. Can you help me out a bit and let me know which model you have? Some of the older 2wire equipment wont do port mapping as alex suggested.

     

    Thanks!

     

    Wednesday, May 28, 2008 6:29 PM
  • Well Cybermack you might just be right about the 2Wire router.  The model is 1701HG Gateway.  When I tried redirecting the ports I identified a new set of external ports and mapped them to the "host port" 80, 443 and 4126.  I even rebooted the WHS.  Going to the WHS setup for the Router configuration details, I see UPnP not supported (no surprise), but it verified that "your web site is available on your home server" and "verified that the Router Access is available on your home server" but failed verifying that your router is accepting web site connections and failed to verify that the router is accepting remote access connections. 

     

    When I went to my Vista machine and tried browsing to https:\\ipaddress:externalport I ended up on my HP Media server. 

     

    I just can't seem to get there from here.  I'm about ready to give up on the beta server remote access.  Any ideas?

     

    Jerry

     

    Wednesday, May 28, 2008 9:19 PM
  • Jerry,

     

    I hate to be the bearer of bad news, but 2wire routers do not support Upnp. When I worked there I got the old " Its a security risk bs". Also your 1701HG, can support port mapping unfortunantly 2wire doesn't make the firmware availble to customers/public to upgrade that feature. Based on the age of your router I am assuming you purchased it through ebay or a ISP. That means its going to have at least a 2 year old firmware on it. Don't get me wrong that paticular model Router/dsl modem is one of the best that 2wire has ever developed. They are pretty much damn near bulletproof, but they don't have a great feature set.

     

    Also you can check the firmware version by veiwing the system summery by typing in 192.168.1.254 in the address bar of a browser and click the link that says "system summery". I am not sure which on you will have, there were about 10 different ones for that model, but the most current is 4.25.19. You could also try contacting their support the phone number is on their webpage www.2wire.com/support. They can issue upgrades to modems remotely via their backend management systems for all 2wire modems. But beware, a failed firmware upgrade could render your modem/router useless.

     

    My suggestion would be to upgrade your router to something more current, or you may have to abondon all hope for a successful port mapping as alex described.

     

    Best Regards

     

    Cybermack

    Thursday, May 29, 2008 1:52 AM
  • Cybermark, I really appreciate your input.  Thanks!

     

    I got the router via my ISP.  They had a very good rebate at the time, and I've been through the support route before and got noware, just the security risk story as you described.  my current version is 3.17.5 and the red letters next to it say it's up to date.  I'm not sure about a new firmware, just thinking about replacing the whole thing, so I'll wait on that part.

     

    I recognized the shortcomings of the router route and was hoping there was a way of just porting straight through and redefining them on the server.  I've played with settings before but would need guidenace on how to reconfigure the WHS ports to match the new numbers. 

     

    Like you say, the other route is to bag the remote on the beta server for the test and be happy my HP is running well.

     

    Again, your advice is very much appreciated and I'm sure other readers with 2Wire appreciate it too.

     

    Jerry

     

    Thursday, May 29, 2008 9:40 PM
  • Jerry,

     

    Late last night an Idea hit me, why not set one server to be hosted on port 80 and the other server over 443. You could essentially have your production machine hosted via HTTP, and the test server hosted on HTTPS. Now I don't have an idea for 4125, but at least you could test out the remote UI.

     

    Also you welcome for the info on the 2wire modem! I am glad I could provide you with some straight anwsers.

     

    Cybermack

    Friday, May 30, 2008 5:47 PM
  • Good suggestion, but someone else may have to help us with this idea. I understand that the http traffic starts at port 80, but when you go to log in it switches to the https on port 443.  If this is the case, you would only be able to get into whichever server is on 443 and the server starting on 80 would end up on the other server when it tries to logon.

     

    Like I said, we may need some other help here.  The only way for sure that I think we can fight this is a new router or moving the WHS ports on one of the servers.

     

    Thanks again, keep trying!

    Jerry

    Friday, May 30, 2008 5:51 PM
  • It's possible to change the HTTP/HTTPS ports for the web application (80 and 443). It's not possible to change the port for the Remote Desktop proxy (4125), because it's wired into the web app.

    Friday, May 30, 2008 9:09 PM
    Moderator
  • Ken, thanks!  Are there instructions anywhere, or can you point me to the right config file or service?

     

    Saturday, May 31, 2008 12:18 AM
  •  

    The Service your looking for is IIS. It can be found in your computers admistration panel.

     

    Here are the instructions for changing the ports that IIS listens to.

     

    Microsoft Internet Information Services versions 4.0 to 6.0

    1. Open Internet Service Manager or Internet Information Services (IIS) Manager.
    2. If necessary, expand the Web server that you want, and then expand Web Sites.
    3. Right-click the Web site that you want to change.
    4. Click Properties.
    5. Click the Web Site tab.
    6. Change the TCP Port Number in the TCP Port edit box (or click Advanced for multiple Port settings).
    7. Click OK to save the changes.

     

    or you can use this link

     

    http://support.microsoft.com/kb/149605

    Saturday, May 31, 2008 7:47 PM
  • I think it's time to close this out.  First Cybermack, and Ken, you too, thank you!  The instructions helped a lot and got me started.  What was missing, though is thie instructions to open the firewall on the server.  I found that at http://www.myhomeserver.com/, which has a lot of good information, step by step, in case anyone else runs into this.

     

    I followed these instructions a few times and thought I couldn't get it to work.  I even wasted a product key and reinstalled, to no success.  then I tried remote connecting using hppts://servername.homeserver.comStick out tongueort# and realized it worked, enen though the homeserver remote configuration screen said it failed.  This, I hope is cleared up by the PP1 enhnaced details that is billed.  What I got for an error, is that UPnP failed (expected), then the server couldn't open the web services, or something like that.  I think my mistake was believing those errors.  I also realized that I shouldn't have clicked on configure domain name, which messed up my original, as you can't have 2 server names on homserver.com.  The first clue about that is when my security certificates got messed up, and are still messed up (like others I guess from the forum).

     

    Anyway, if I were going to do it again, I'd configure my production home server first.  Then power up the beta machine, change the ports, open the firewall on the server as well as the modem, reboot and then just try to connect to the site via the internet.  I don't know if it is that easy or not, but if anyone else tries this, don't work as hard as I did.

     

    Jerry

    Sunday, June 8, 2008 12:46 PM