locked
CRM 2011 issues with Rollup 10 (UR10) RRS feed

  • Question

  • Hi,

    I have been reading about others having problems connecting to CRM 2011 (from code, plugin registration tool etc.) and tried to implement the suggested solutions, but it haven't fixed my problem.

    I would really like to know if it is official that UR10 introduces problems that is being worked on of if it working as it was supposed to.

    For me personally the problem is connection to CRM 2011 from code, including SDK 5.0.12 Plugin Registration Tool and ExportRibbonXml which are both developed by MS and packed in the latest SDK.

    If i try to use ExportRibbonXml (when I try to add a new connection) it asks me for the the server name (like it did in previous versions as well) and once I have provided that it asks me for something new "Is this organization provisioned in Microsoft Office 365 (y/n)".

    Regardless of what my answer is to this question an error follows:

    The application terminated with an error.
    Metadata contains a reference that cannot be resolved: 'https://disco.<organizationName>.crm4.dynamics.com/XRMServices/2011/Discovery.svc?wsdl'.
    The remote name could not be resolved: 'disco.<organizationName>.crm4.dynamics.com'
    Press <Enter> to exit.

    I have tried different ways of providing the server name and I have tried to delete the LiveDeviceID.xml file, but nothing changes.

    As for the Plugin Registration Tool, I have tried to replace any referenced SDK assemblies with assemblies from the new SDK => exception, authentication fault.
    I have also tried to build the new Plugin Regitration Tool (packed with SDK 5.0.12) and the result is the same, it cannot login to CRM, so as of right now I cannot register/update any plugins on CRM 2011 with UR10 or connect from any other application or service for that matter.

    I'm thinking, since this is MS's own tools, does this mean that UR10 is broken or that the SDK tools are broken or what does it mean?

    If it is not broken, then how do I fix this so that I can once again connect to CRM 2011 from code?
    A lot of our products depend on being able to connect to CRM, so if MS starts to roll UR10 in on all CRM Online servers, we're screwed without a solution.

    Any help would be much appreciated, thanks.

    /Aidal

    Friday, September 14, 2012 1:10 PM

All replies

  • Aidal,

    The url that it's trying to resolve is definitely wrong.  For the discovery service, it should look like this (no org name):

    https://disco.crm4.dynamics.com/XRMServices/2011/Discovery.svc

    Hope that can help you track down the source of the problem.

    -Pat


    • Edited by Tengato Friday, September 14, 2012 9:50 PM post error?
    Friday, September 14, 2012 9:48 PM
  • Thanks for your reply Pat, but it really doesn't help me much though sorry ;)

    The URL is generated by MS's code not mine and I see posts and mails popping up everywhere at the moment about UR10 problems, even people urging customers and partners not to install UR10 for this very reason.

    Can anyone shed some light on the matter?

    What is with UR10, why does it break pre-UR10 code and what can be done about it if anything at all?

    Is the fix going to come from MS or do we have to dome something (not that I know what) to resolve the issue?

    /Aidal


    • Edited by Aidal Tuesday, September 18, 2012 7:26 AM
    Monday, September 17, 2012 6:59 AM