unable to uninstall customer portal RRS feed

  • Question

  • Hi, I installed the customer portal (from adxstudio)and it was working fine (under Win 2003/IIS6). I ran the website copy for XRM partner portal and I was able to login with partner login credentials. However, I could not create accounts (as the channel access was missing).

    So I tried to un-install the customer portal (so that I can install the XRM Partner portal). However, the system doesn't let me un-install the XRM customer portal.

    I get the following Error message. Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: An unexpected error occurred.Detail: <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts"> <ErrorCode>-2147220970</ErrorCode> <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" /> <Message>An unexpected error occurred.</Message> <Timestamp>2011-09-21T19:11:45.204733Z</Timestamp> <InnerFault i:nil="true" /> <TraceText i:nil="true" /> </OrganizationServiceFault>

    Thursday, September 22, 2011 10:37 AM

All replies

  • Anyone come across the above issue? 
    Thursday, September 22, 2011 10:38 AM
  • Hello,

    Correct me if I am wrong, I just wanted to clarify - the Customer Portal that you installed was the one from adxstudio and not the one that is downloaded from the marketplace? When you refresh the solutions subgrid after failed uninstall, the customer portal solution is still there? Can you also try to install the XRM Partner Portal on top of the Customer Portal? That should work, as both of them should be able to co-exist.



    Tuesday, October 18, 2011 8:09 PM
  • Hi, I am able to un-install the partner portal but still having problem with customer portal. I am unable to uninstall. After 20 mins, the system hangs with no error message.  I tried several times. I also disabled/removed the SDK plug-ins and workflows. but still no result. 
    Tuesday, October 18, 2011 9:58 PM
  • Yes, i installed the one from Adx studio - the customer portal version. I didn't install other adx components just the customer portal. 
    Tuesday, October 18, 2011 9:59 PM
  • Can you point me to the location from where you downloaded the solution? I'll see if I can also reproduce the issue. Please do send me mail at mariajoa at microsoft, so I can do a follow-up whenever necessary. Thank you.
    Tuesday, October 18, 2011 11:25 PM
  • The issue maybe related to server performance or existing dependencies upon deletion. There might also be a problem with your server. For this issue, a ticket has already been filed with support. 
    • Proposed as answer by Maria Joaquin Thursday, November 10, 2011 10:58 PM
    Thursday, November 10, 2011 10:57 PM
  • I'm encountering the exact same problem during uninstall.  I have a PSS open but we haven't found anything concrete yet.  Did you manage to get it to uninstall?

    For me I tried uninstalling it after publishing the changes and waiting 30 minutes.  I didn't use it at all between the import and the removal.

    Wednesday, November 23, 2011 1:32 PM
  • We are having a similar issue -  have made it through a couple of errors (deactivating workflows and the like) and are to the following error that may be related to an Advanced Find but am unclear how to narrow down from here….

    System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: 1 is not a valid status code for state code SavedQueryState.Inactive on savedquery.Detail:

    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">


      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />

      <Message>1 is not a valid status code for state code SavedQueryState.Inactive on savedquery.</Message>


      <InnerFault i:nil="true" />

      <TraceText i:nil="true" />



    Tuesday, January 10, 2012 8:45 PM
  • Please refer to the following thread and see if it helps. Thanks.




    Prashanth GanapathyRaj


    Monday, January 23, 2012 12:29 AM