Child Records not Showing up in Sub-Grid for Parent Record RRS feed

  • Question

  • I am working with a fairly new implementation of Dynamics CRM. Finally got all of our data imported and am now working on refining forms etc.

    I have a custom entity called Qualifying with a N:1 relationship with Account Entity. After the Account information was imported, I imported each accounts qualifying records if they had any. When I go to the custom entity I can see all the qualifying records there with the Account field populated. If I navigate to Accounts, then choose an account and go to Qualifying there are no Associated records. I have to click on Add Existing Qualifying record, then search for the record for that account.

    Why are these not already associated with the Account?

    And more importantly, is there a way for me to associate the Qualifying records with the appropriate Account record without going into every Account, navigating to the Qualifying records and manually picking the record? Which really isn't an option since there are roughly 20,000 qualifying records or more.


    Monday, March 31, 2014 8:37 PM

All replies

  • Wonder if there are multiple relationships between these entities causing this behavior., can you pls check?

    If my response helps you in finding your answer then please click 'Mark as Answer' and 'Vote as Helpful'

    Monday, March 31, 2014 10:47 PM
  • There is another lookup field for the Account Entity, but shouldn't it attach to the main AcccountId field that was created with the new entity? When I export the Qualifying records and select "Make this data available for for re-import..." the main field  (the first one highlighted in dark blue) is the correct Account in which the record should be related.

    If the multiple relationships are causing the behavior is there anyway I can attach the records to the correct account without manually going into every account record?

    I apologize if I am not explaining this very well, I appreciate your patience and help.

    Thank you.


    Tuesday, April 1, 2014 10:54 AM