locked
Lots of problems with conflicts RRS feed

  • Question

  • Hello,

    I really love live mesh - and I know this has been talked about before... but today I've just had huge problems with conflicts.

    I use two computers and turned one off for vacation over the holidays. When I got back... live mesh found conflicts with everything. I ran into this sort of thing when I first installed live mesh... but dealt with it without much trouble - just lots and lots of clicking through them one at a time. The disastrous thing this time was that it began by asking me about folders... It would say folder X matches - each with 0 bytes...  so I would pick one, and end up with a bunch of empty folders. This seemed to confuse live mesh as much as it did me...

    Then, I noticed that live mesh put two copies of all the live mesh folders on one of my computers... this was definitely weird. So I would go to my computer -> live mesh folders... and it would say folder X twice. I tried deleting folder X from that computer, and the icons indicated that one copy was still active and the other was a shortcut to add it again. If I clicked the one that looked to be still active, I got an error that it couldn't find the folder... if I tried replacing using the one that was a marker to replace, I got the error saying you can't create two live mesh folders in the same place. I ultimately just completely removed that computer from my mesh, uninstalled the software, and reinstalled - things see to be getting back to normal now.

    Anyway... the whole thing was definitely a mess... and it made me really think again on how critical it is to get a better conflict resolution system. The current one is really kind of a disaster. When I first installed live mesh, I spent probably 10 hours clicking through conflicts... mostly because I was migrating over from Folder Share. This is important, I think, because many of your users will probably be in a similar boat... there really needs to be a better way to handle that stuff.

    With that said - thanks again for Live Mesh... after all this hassle... I'm still using it. It's a great program - it just has a few frustrating elements.

    Mike
    Tuesday, January 13, 2009 9:02 AM

Answers

  • Hi Mike,

    Thank you very much for the kind words despite the confusion and hassle Live Mesh put you through.  I find the empty folders particularly concerning.  It doesn't sound like you lost any of your data (thankfully!), but something was definitely not right.  If you wouldn't mind, I'd really like to have our developers look into this: could you submit a bug report via Connect (and attach your logs, if this incident isn't too far in the past)?  Instructions are in an Announcement at the top of the forums.  If you could then post the Connect Feedback ID here, I'll follow up internally and make sure this gets looked at right away.  Please let me know if you have any questions.

    Thanks,

    Ben.
    Tuesday, January 13, 2009 4:00 PM

All replies

  • Hi Mike,

    Thank you very much for the kind words despite the confusion and hassle Live Mesh put you through.  I find the empty folders particularly concerning.  It doesn't sound like you lost any of your data (thankfully!), but something was definitely not right.  If you wouldn't mind, I'd really like to have our developers look into this: could you submit a bug report via Connect (and attach your logs, if this incident isn't too far in the past)?  Instructions are in an Announcement at the top of the forums.  If you could then post the Connect Feedback ID here, I'll follow up internally and make sure this gets looked at right away.  Please let me know if you have any questions.

    Thanks,

    Ben.
    Tuesday, January 13, 2009 4:00 PM
  • Hello,

    Thanks for your prompt reply - sorry I was delayed in getting back to you myself.

    I have a log of the whole thing (I think)... sorry for my ignorance here, but how do I submit it?

    Also, I noticed that the new version is still showing me folders as conflicting... is there anything I can do about that?

    Thanks,

    Mike
    Thursday, January 15, 2009 6:52 PM
  • dkmj17 said:

    Hello,

    Thanks for your prompt reply - sorry I was delayed in getting back to you myself.

    I have a log of the whole thing (I think)... sorry for my ignorance here, but how do I submit it?

    Also, I noticed that the new version is still showing me folders as conflicting... is there anything I can do about that?

    Thanks,

    Mike



    Hi Mike,

    You can submit a bug on our Connect site (https://connect.microsoft.com/livemesh) - though please note that you'll need to log into Connect to do so.  You'll be able to attach your logs to the bug, and you'll be given your Connect Feedback ID when you're done (which you can then post here so that I can track it and follow up with our developers).

    As for the conflicts: aside from starting over (i.e., removing all folders and devices from your mesh and starting over), I'm afraid the only thing to do is to manually resolve any conflicts you're still seeing.  We are, however, continuing to work on improving conflict handling and resolution.

    Please let me know if you have any trouble submitting your bug.

    Thanks,

    Ben.
    Thursday, January 15, 2009 7:13 PM
  • Hello,

    Thank you again for your interest. I submitted a report on connect... The ID is 399728. I am uploading the cab file of logs now... I'm not sure it'll be any help... but who knows.

    Thanks again for your help and live mesh... I really do love the program.

    Mike
    Thursday, January 15, 2009 11:55 PM
  • dkmj17 said:

    Hello,

    Thank you again for your interest. I submitted a report on connect... The ID is 399728. I am uploading the cab file of logs now... I'm not sure it'll be any help... but who knows.

    Thanks again for your help and live mesh... I really do love the program.

    Mike



    Hi Mike,

    Thanks for posting your Connect Feedback ID here.  I see the bug internally now, and I'll continue to track it and let you know as soon as I learn anything.

    Ben.
    Friday, January 16, 2009 5:07 PM
  • I appear to have run into a similar problem.  I posted in detail in another thread before finding this one here.  Here's the link to the other thread:
    http://social.microsoft.com/Forums/en/LiveMesh/thread/62c4b5cd-9ec6-4064-956e-d617bc3168f4

    I am having difficulty gathering logs, as I mention in the thread.  So, let me know if you need more logs to help resolve this issue and I'll try harder to get the logs for you.  Also, let me know if you think my issue might be different and would like me to file a separate bug.

    I also like Live Mesh and see a lot of potential in it, however, I think the automatic and manual conflict resolution needs to improve greatly before I think it's ready for prime-time.  See some thoughts/suggestions in my other thread for more about that.

    PS.  I can't find the bug filed in this thread to rate or comment on it, I tried a couple of search queries, but neither 'sync' nor 'conflict' appear to be in the title, and you can't search by bug ID, so I'm at a loss.  I suppose I could look internally if I knew which PS db it was ;)

    Tex Riddell, DirectX Graphics
    Tuesday, February 17, 2009 4:19 AM
  • Quite a few bugs submitted a while ago are not accessible to everyone, since it should be just as easy as clicking on:

    https://connect.microsoft.com/LiveMesh/feedback/ViewFeedback.aspx?FeedbackID=399728

    This can be a bit annoying - but Ben / others from the Live Mesh team have opened them up when they were reported.
    • Edited by nachmore Tuesday, February 17, 2009 4:38 AM note
    Tuesday, February 17, 2009 4:25 AM
  • Ahh, that would explain that...
    Tex Riddell, DirectX Graphics
    Tuesday, February 17, 2009 4:36 AM