locked
Error 0x800705b4 when installing SATA drivers RRS feed

  • Question

  • Hi

     

    I'm having real problems trying to to install RC1 with this SATALink 3114 card, my setup :-

     

    Leadtek Winfast K7NCR18G Pro nForce 2 M/B

    768Mb DDR 333 Ram

    SataLink 3114 OEM 4 port PCI controller card

    Maxtor 320Gb SATA Drive

    Samsung IDE DVD-ROM

    Lite-On CDRW

    (disconnected 40Gb IDE drive with Win XP on it)

     

    I keep getting stuck at the part of the install where you search for the driver for the card, I've flashed the bios of the 3114 with both b5314.bin and b5403.bin and I'm using driver version 1.3.10.0.  When I search for the drivers (have tried from a floppy and CD) I get the following error :-

     

    Unable to Load

    E:\3114_x86_13100_logo\SI3114.INF (Error 0x800705b4)

     

    I've loaded this driver in XP (plugging the IDE drive back in with XP on it) with the card and hard disk and everything works fine, anyone got any suggestions?

     

    Thanks

    Friday, June 22, 2007 7:30 AM

All replies

  • First thought...  Are you sure that driver is Server 2003 compatible?  While most XP drivers work on S2003, not all will; and some require "hacking" the .inf file so S2003 will load it.
    Friday, June 22, 2007 2:08 PM
  •  

    The driver does say it supports Win2k3,  taken from the TxtSetup.oem :-

     

    ; This file installs the SiI 3114 non-RAID serial ATA driver as part
    ; of text mode setup on Windows NT, Windows 2000, Windows XP,
    ; Windows Server 2003, and Windows Vista.
    ;
    ; Copyright (C) 2003-2006 by Silicon Image, Inc.
    ; All rights reserved

     

    and from the si3114.inf file :-

     

    ; This INF file installs the Silicon Image Serial ATA non-Raid driver
    ; for the SiI 3114 controller on systems running Windows 98/ME,
    ; Windows NT 4.0, Windows 2000/XP, Windows Server 2003,
    ; and Windows Vista.
    ;
    ; Copyright (C) 2003-2006 by Silicon Image, Inc.
    ; All rights reserved

     

    Looking through the inf file I don't see any specific sections for Win2k3 server, just these sections

    [DriverFiles_9X]  [DriverFiles_NT_2K] and [DriverFiles_XP]

     

    Does the file need 'hacking' and if so does anyone know what needs to be changed?

     

    Thanks

    Friday, June 22, 2007 2:27 PM
  • Hi,

     That error usually refers to a 'time out', so I would think it's timed out while searching for the driver.

    An option that others have used and is recommended by the WHS Team, is to put the drivers on a USB stick, which appears to be successful.

     

    HTH

     

    Colin

    Friday, June 22, 2007 5:20 PM
  •  

    I burnt the drivers to CD and tried from there and from floppy, but no luck.

     

    Have just installed xp media center on the machine and it picked up the drivers from the floppy disk (f6  prompt) and installed without problems.

     

    I just can't get the home server install to load the driver, any other ideas?

     

     

    Friday, June 22, 2007 8:36 PM
  • If you are using a floppy, try putting the drivers and assosciated files in the root folder (A:\) of the floppy disk. Leave the floppy drive connected until Setup is completely finished.

     

    Or, did you try a USB flash drive as previously suggested?

    Friday, June 22, 2007 8:56 PM
  • I have the same issue. Drivers are on floppy however, WHS does not install.

     

    However, my HW is as follows:

     

    TYAN 2885 (opteron) with Si3114 SATA.

     

    Jeff

    Wednesday, July 4, 2007 10:33 PM
  • I am having a very similar problem except I have a VIA based card. When WHS asks for additional drivers I point it to the drivers I have on floppy. It loads the drivers then gives the popup saying "No hard drive capable blah blah blah".  But if I again tell it I want to load additional drivers, when the window pops up that shows all connected drives, the SATA drive then shows up. The drive is a 160gb WD so I know it's big enough. What gives?
    Friday, July 6, 2007 5:09 PM