locked
HomeServer can be accessed by IP adress but NOT by name ; thus WHS console doesn't work ... RRS feed

  • Question

  •  I have a Fujitsu Homeserver and 2 Pcs : 1 XP and 1 Vista.

    Everything was working fine till I decided to give a fixed adress for the HServer . After having assigned a fixed IP adress to my WHS, the Vista machine took note of the change but I got stuck with the XP machine: the WHS console does not work while everything else (ie daily backups, shared files etc...) is OK.
    It appears that if on the XP PC, I ping the WHS by its new adress 192.168.1.201 it works while if I try to ping it with its name it fails ; this must be the reason why the WHS console cant be started from the XP machine . It looks as if the table matching IP adresses and names did not update on the XP machine during the process .

    Can someone help me to fix it ?
    Thanks
    FG
    Wednesday, September 24, 2008 12:25 PM

Answers

  • UPnP is only important, if you want to use the Remote Access features. Since the router usually should not have UPnP configuration enabled by default (which would make no sense in context of security), WHS cannot update the settings for the Port Forwarding automatically. Therefore the message. Maybe you can temporary enable UPnP configuration on the router and let WHS do the reconfiguration or reconfigure the router yourself manually.

    Now we have to figure out, which kind of name resolution fails - DNS or NetBIOS.
    Try the following from a cmd line:
    nslookup server
    Is the result the expected? Which DNS server responds? (Should be the router, but sometimes the router does not care about DNS changes or even ignores local machines.)
    If the router responds and states, that the host is not found, open c:\windows\system32\drivers\etc\hosts in Notepad and add a line for your WHS.

    Since short names are usually resolved via NetBIOS broadcast in home network, you should also check, if in the TCP/IP properties of your LAN connection after clicking Advanced and opening WINS tab NetBIOS over TCP/IP is enabled. If not, do so and reboot.
    If this still does not work, what does following command return:
    nbtstat -A IPAddress of your server

    Did you already try to run discovery.exe from the Windows Home Server folder in Program Files om the client?

    Best greetings from Germany
    Olaf
    Friday, September 26, 2008 7:27 AM
    Moderator
  • Olaf Engelke said:

    UPnP is only important, if you want to use the Remote Access features. Since the router usually should not have UPnP configuration enabled by default (which would make no sense in context of security), WHS cannot update the settings for the Port Forwarding automatically. Therefore the message. Maybe you can temporary enable UPnP configuration on the router and let WHS do the reconfiguration or reconfigure the router yourself manually.


    Actually I think discovery of homeserver from client also uses UPnP. Unconfigure  / Reconfigure UPnP is a good idea, probably this will fix the problem.

    If it doesn't I would try and reboot your router or disable / enable UPnP on your router, then on client run ipconfig /renew

    If this also doesn't help:

    Normal name resolution also would first look in hosts file, then check DNS servers, then NetBIOS. Perhaps you (FG) can check if there any entries for your homeserver in the hosts file. You will find this file in C:\WINDOWS\system32\drivers\etc, open with text editor. If there are any entries there poiting to your WHS either correct  or replace them.

    If there are no entries for your WHS you could also add the following line to the hosts file:

    192.168.1.201 yourservename # myhomeserver

    This will very likely fix things, however you still don't know the source of your problem

    • Marked as answer by FGMareil Saturday, September 27, 2008 7:12 AM
    Friday, September 26, 2008 8:08 AM
    Moderator

All replies

  • Please try: 

    On the client machine do Start, Run, type ipconfig / flushdns and Hit Enter.

    If this doesn't fix it's most likely ill-configured TCP/IP settings or firewall issue on the client.

    Best use DHCP for TCP/IP and also automatic DNS server address If you must use fixed IP address please make sure you use correct DNS server setting. In most homenetworks with router that will be same as router gateway address, often 192.168.1.1.

    Firewall allow netbios ports UDP 137, 138 and TCP  139, 445 on local subnet (windows firewall allow file and printer sharing on local subnet)
    Wednesday, September 24, 2008 12:52 PM
    Moderator
  • Thanks . Unfortunately it doesn't work : after flushing the DNS if i type ping servername I se the command ping 192.168.1.57 appearing and failing ; it looks as if somehow the XP machine is stuck with the old IP adress (192.168.1.57) and unable to refresh it to 192.168.1.201.
    I have checked the TCI/IP settings of XP and Vista machines : they look identical (but of course more details for vista).

    I have also tried netbios ; the only differences worth noting are that :
    * nbtstat -s shows no connection for the Vista machine whereas it shows 1 netbios connection with the WHS name appearing for the XP machine
    *  nbtstat -c shows nothing for the XP machine but shows the WHS twice (00 & 20 status) on the Vista machine

    FG
    Wednesday, September 24, 2008 4:23 PM
  •  In one log I found the  fwg message which is a good summary of the problem :

    serverIp doesn't match ip from UPnP protocol

    I have no idea how to fix it .......

    FG
    Thursday, September 25, 2008 3:05 PM
  • FGMareil said:

     In one log I found the  fwg message which is a good summary of the problem :

    serverIp doesn't match ip from UPnP protocol

    I have no idea how to fix it .......


    FG



    Did you ever set up the uPnP for the Remote Access website through the Console?  If so, did you unconfigure it when you changed to a static IP?
    Friday, September 26, 2008 2:20 AM
    Moderator
  • Thanks for assisting .
    The answers are :
    1- yes I did set up uPnP through the console
    2- No I didn't unconfigure it when I put a static adress to the server ; are you suggesting I should have ? why ?


    FG
    Friday, September 26, 2008 6:03 AM
  • UPnP is only important, if you want to use the Remote Access features. Since the router usually should not have UPnP configuration enabled by default (which would make no sense in context of security), WHS cannot update the settings for the Port Forwarding automatically. Therefore the message. Maybe you can temporary enable UPnP configuration on the router and let WHS do the reconfiguration or reconfigure the router yourself manually.

    Now we have to figure out, which kind of name resolution fails - DNS or NetBIOS.
    Try the following from a cmd line:
    nslookup server
    Is the result the expected? Which DNS server responds? (Should be the router, but sometimes the router does not care about DNS changes or even ignores local machines.)
    If the router responds and states, that the host is not found, open c:\windows\system32\drivers\etc\hosts in Notepad and add a line for your WHS.

    Since short names are usually resolved via NetBIOS broadcast in home network, you should also check, if in the TCP/IP properties of your LAN connection after clicking Advanced and opening WINS tab NetBIOS over TCP/IP is enabled. If not, do so and reboot.
    If this still does not work, what does following command return:
    nbtstat -A IPAddress of your server

    Did you already try to run discovery.exe from the Windows Home Server folder in Program Files om the client?

    Best greetings from Germany
    Olaf
    Friday, September 26, 2008 7:27 AM
    Moderator
  • Olaf Engelke said:

    UPnP is only important, if you want to use the Remote Access features. Since the router usually should not have UPnP configuration enabled by default (which would make no sense in context of security), WHS cannot update the settings for the Port Forwarding automatically. Therefore the message. Maybe you can temporary enable UPnP configuration on the router and let WHS do the reconfiguration or reconfigure the router yourself manually.


    Actually I think discovery of homeserver from client also uses UPnP. Unconfigure  / Reconfigure UPnP is a good idea, probably this will fix the problem.

    If it doesn't I would try and reboot your router or disable / enable UPnP on your router, then on client run ipconfig /renew

    If this also doesn't help:

    Normal name resolution also would first look in hosts file, then check DNS servers, then NetBIOS. Perhaps you (FG) can check if there any entries for your homeserver in the hosts file. You will find this file in C:\WINDOWS\system32\drivers\etc, open with text editor. If there are any entries there poiting to your WHS either correct  or replace them.

    If there are no entries for your WHS you could also add the following line to the hosts file:

    192.168.1.201 yourservename # myhomeserver

    This will very likely fix things, however you still don't know the source of your problem

    • Marked as answer by FGMareil Saturday, September 27, 2008 7:12 AM
    Friday, September 26, 2008 8:08 AM
    Moderator
  • Thanks to both Olaf and Brubber.

    To cut a long story short :
    1- I had used  the toolkit which provided useful tip for fixing the problem
    2- to answer Olaf the router responded that the host was not found . I checked the hosts file and corrected the old (wrong) IP adress, rebooted and it worked !!!!!!
    3- to answer rubber, I think the source of the problem is the wild way in which I set up the static IP adress of my WHS

    Once again many thanks to you guys for spending time and assisting !

    a special "Danke schön" (as you guys say a few miles from here) to Olaf
    FG
    Saturday, September 27, 2008 7:11 AM
  • Bitte sehr :-)
    Saturday, September 27, 2008 7:14 AM
    Moderator
  • Graag gedaan!

                           

                          
    Saturday, September 27, 2008 1:15 PM
    Moderator