locked
Error during install with some mixed hardware. RRS feed

  • Question

  • I have just downloaded and burned the Windows Home Server RC and prepared a system on which to run it. The motherboard in this system has a notoriously hard to support controller chipset - I have some bad memories of trying to get various Linux distributions to play nicely with the IDE controller (IT8212F) on this board.

    I am able to get past the initial setup steps and past the volumes being formatted. Just after this is done the following error pops up:

    "The specified setup script file (c:\install\winnt.sif) is inaccessible or invalid. Contact your system administrator."

    It looks like a Windows unattended setup file couldn't be found. Obviously I am quick to blame some of the funky hardware in my machine which I will try to list as best I can. Before I spend all the time to test various configurations of this hardware I would like to hear if anyone has experienced the above failure.

    Motherboard spec page:
    http://www.gigabyte.com.tw/Products/Motherboard/Products_Overview.aspx?ProductID=1756

    System specifications:
    CPU: AMD Athlon XP "Barton" 2500+
    RAM: 1GB dual-channel
    Video: AGP Nvidia TNT2 32MB
    NIC: Disabled onboard NIC in the BIOS and installed a PCI Compaq NC3121 ethernet card
    Motherboard:

    Gigabyte GA-7N400 Pro2 Rev. 1.0
    Nonstandard IDE (fake-RAID) chipset: ITE8212F "GigaRAID"
    SATA chipset: Silicon Image 3112 / 3512
    Drives:
    1 80GB SATA attached to above SATA controller
    1 40GB IDE attached to "GigaRAID" controller, controller configured for ATA (non-RAID) mode
    1 80GB IDE attached to primary IDE controller's second channel (Master)
    1 12x Sony CDRW drive attached to Primary IDE channel (Slave)
    1 4x DVD (ro) drive attached to Primary IDE channel (Master)

    In order for Home Server setup to identify the drives attached to the IT8212F and the SATA controller, I had to load drivers from install packages on Gigabyte's site.

    ITE GigaRAID IT8212F for Windows 2000,Windows XP
    Silicon Image 3112 / 3512 SATA Driver for Windows 2000,Windows XP,Windows Server 2003

    I did not receive any warnings from the installer while loading either driver so I expected to not have issues. From what I've been reading on this forum, the first thing I will try is to remove the unnecessary CDRW drive and restart setup. Failing that, I'll remove the drive on the IT8212F chipset and not attempt to load the driver that only claims to work with up to XP.

    Anybody have any obvious solution to my problem? I did a search for this particular error but came up empty handed. I apologize if this exact issue has been addressed before. Thanks in advance.

    EDIT:
    I also saved the log file from the installer.  Here is the very end detailing the failure. 

    [6/28/2007 3:11:49 AM  544] Copying file D:\WHS\umwhsarch.exe.
    [6/28/2007 3:11:49 AM  544] Success!
    [6/28/2007 3:11:49 AM  544] Install step is set to 4
    [6/28/2007 3:11:49 AM  544] Running Windows setup
    [6/28/2007 3:11:49 AM  544] Creating unattended setup configuration file in c:\install\winnt.sif
    [TRACE] CopyFilesRecursively : Exited (0x80070002)
    [TRACE] Looking for template F:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF
    [TRACE] Checked file C:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF, error 3
    [TRACE] Checked file D:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF, error 3
    [TRACE] Checked file E:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF, error 21
    [6/28/2007 3:11:49 AM  544] Found file F:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF
    [TRACE] Looking for template F:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF
    [TRACE] Checked file C:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF, error 3
    [TRACE] Checked file D:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF, error 3
    [TRACE] Checked file E:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF, error 21
    [6/28/2007 3:11:49 AM  544] Found file F:\7n400_IDE\ITE_RAID\DRIVERS\WIN2K_XP\ITERAID.INF
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file E:\qs.ini, error 21
    [TRACE] Checked file F:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 2
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [6/28/2007 3:11:50 AM  544] Spawning process [D:\SVR_2003\i386\winnt32.exe /copysource:lang /makelocalsource /syspart:c /tempdrive:c /unattend:c:\install\winnt.sif]
    [6/28/2007 3:51:23 AM  33c] MessageBox: Windows Home Server Setup is in progress. No additional user input is required at this time. Setup is locked to avoid accidental input that could cause setup to fail. Would you like to interrupt setup?
    [6/28/2007 3:51:25 AM  544] ERROR: Process failed (with return code 1)
    [6/28/2007 3:51:25 AM  544] Process returned the following message:

    [TRACE] ExecCmd : Exited (0x800703eb)
    [TRACE] RunWindowsSetup : Exited (0x800703eb)
    [6/28/2007 3:51:25 AM  544] Running Windows setup failed. Error 0x800703eb.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file E:\qs.ini, error 21
    [TRACE] Checked file F:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 2
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [6/28/2007 3:51:25 AM  544] MessageBox: Running Windows setup failed: Cannot complete this function.

     (error code 0x800703eb).
    [6/28/2007 3:51:25 AM  544] Windows Home Server setup failed. The error code is 0x800703eb. Please correct the problem and reboot to restart the setup program.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file D:\qs.ini, error 2
    [TRACE] Checked file E:\qs.ini, error 21
    [TRACE] Checked file F:\qs.ini, error 2
    [TRACE] Checked file X:\qs.ini, error 2
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [6/28/2007 3:51:25 AM  544] MessageBox: Windows Home Server installation failed. Do you want to view the installation log file?
    [6/28/2007 3:51:26 AM  544] Spawning process [notepad.exe "X:\ProgramData\Microsoft\Windows Home Server\logs\q_setup.log"]

    Thursday, June 28, 2007 3:49 AM

All replies

  • Now that I've looked through my log my problem seems pretty obvious.  Anybody know of a good driver for the IT8212F chip that works with Home Server? 
    Thursday, June 28, 2007 3:59 AM
  • I had similar problem, if possible, and have another graphic video card beside the "AGP tnt card" like some cheap pci and a like to try.

    My best.


    Thursday, June 28, 2007 8:06 AM
  • I managed to get past my first error by eliminating all drives hooked up to the IT8212F controller.  Now I get almost all the way through setup.  I do not get an error message popup other than the standard message that setup failed.  Here is the end of my latest log file:

    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\$OEM$
    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\windows\system32\pidgen.dll
    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\install\winntbbu.dll
    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\install\q-1024x768_24bit.bmp
    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\install\qs.ini
    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\install\winnt.sif
    [6/28/2007 5:31:16 AM  9bc] Fixing up path C:\install\dcpromo.ini
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file I:\qs.ini, error 2
    [TRACE] Checked file J:\qs.ini, error 21
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file I:\qs.ini, error 2
    [TRACE] Checked file J:\qs.ini, error 21
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [6/28/2007 5:31:16 AM  9bc] Install step is set to 5
    [6/28/2007 5:31:16 AM  9bc] Continuing to configure storage
    [TRACE] Step_SetWindowsSourceCD : Exited (0x80070003)
    [6/28/2007 5:31:16 AM  9bc] Continuing to configure storage failed. Error 0x80070003.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file I:\qs.ini, error 2
    [TRACE] Checked file J:\qs.ini, error 21
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [6/28/2007 5:31:16 AM  9bc] MessageBox: Continuing to configure storage failed: The system cannot find the path specified.

     (error code 0x80070003).
    [6/28/2007 12:06:43 PM  9bc] Windows Home Server setup failed. The error code is 0x80070003. Please correct the problem and reboot to restart the setup program.
    [TRACE] Looking for template _:\qs.ini
    [TRACE] Checked file C:\qs.ini, error 2
    [TRACE] Checked file I:\qs.ini, error 2
    [TRACE] Checked file J:\qs.ini, error 21
    [TRACE] Template _:\qs.ini NOT FOUND!
    [TRACE] FindOnMedia : Exited (0x80070002)
    [TRACE] FindSetupFile : Exited (0x80070002)
    [6/28/2007 12:06:43 PM  9bc] MessageBox: Windows Home Server installation failed. Do you want to view the installation log file?
    [6/28/2007 12:06:45 PM  9bc] Spawning process [notepad.exe "C:\Documents and Settings\All Users\Application Data\Microsoft\Windows Home Server\logs\q_setup.log"]

    Thursday, June 28, 2007 12:26 PM
  • Put the install CD/DVD back in the drive and reboot.

     

    Thursday, November 1, 2007 2:58 AM