none
Bare metal restore to new hard drive - failure RRS feed

  • Question

  • For the record...

    I wanted to install a new hard drive on my laptop, a 500GB Seagate hybrid drive, a Momentus XT SATA, to replace a Fujitsu 320GB SATA drive. I've been running WHS v1 since the public beta but have never had to do a bare metal restore in anger; have done a couple of successful 'practices' on existing machines so I knew it worked. In this case I expected to insert the new drive and do a bare metal restore to it. Three partitions on one drive, C:\ D:\ and a Recovery Partition (wanted to restore only C and D). I formatted the new drive first but left it one partition. (BTW: did a full chkdsk on the server before I started).

    Tried it first using the most recent Client Restore CD (from Technet) but couldn't get past the Realtek NIC issue (laptop was connected to my wired Ethernet network). Spent about 2-3 hours trying different drivers but couldn't get one to work. Instead, turned to Drashna Jael're's X:\Edition WHS Client Restore 1.3 and it seemed to be working.

    Except that after 30-40 mins of restoration I got "Unable to refresh RestoreWizard from your server, Your server may be an older version of Windows Home Server than this CD or your server may be damaged, we will attempt a restore with an older version."
     
    The only option here was "OK". When I clicked it, the restore process started again and restored the D:\DATA drive. At one point an option became available for restoring the C:\SYSTEM drive and the Recovery partition but both were greyed out and I could find no way of getting it to change its mind. When I inspected the hard drive later I find that a C:\ partition had been created but nothing on it - first time I did it, it was in RAW format (which I converted to NTFS but wouldn't fix the problem). Second time was NTFS but blank.

    I then tried a bare metal restore of the new drive using an IDE/ATA adapter connected to my desktop. Thought everything was going fine 20-30 mins into the restore until it threw an error. By this time, I was losing patience and didn't note the exact words but was to the effect that the restore 'does not recognise the IDE/ATA adapter' (odd: don't know whether it was referring to the adapter itself or something about the new drive) and wouldn't continue.

    AT that point I gave up and did a clean install on the new drive - which, to be honest, I'm happier with. But I was disappointed. My WHS has generally been fantastic - backups and media serving.

    My take-away is that the bare metal restore function really on works on a machine that's identical to that backed up; i.e. system corruption on an existing machine, not cloning a new drive. Try to change key components like a drive, and the chances of success are limited.

    Would that be a fair enough conclusion?

    PS. Very happy with the new hybrid drive. Speed of the SSD where required but with the larger storage capacity.

    Monday, May 9, 2011 9:39 PM

All replies

  • Bare metal restore of machine to multiple volumes usually requires, that the volumes already exist and are at least the same size as the old one.

    Loosing connections can point to problems with the network card driver (the drivers are not optimized for Windows PE) or with the DHCP lease time (if this is to short in the router, it may drop the connection during restore).

    If possible, you could attach the disk to a second client PC as secondary drive (directly via SATA or using an USB to SATA converter cable) and use clientrestorewizard.exe to restore the volumes within the running OS.

    Best greetings from Germany
    Olaf

    Tuesday, May 10, 2011 2:09 PM
    Moderator
  • First issue is almost certainly due to raw partition. In addition Momentus XT is suffering from a number of issues including random spin downs, check here and here. This could well be the cause of restore no longer recognising hdd in the middle of restore.

    For now I would say you conclusion is not fair, there's numerous examples of people succesfully restoring to a new (different) drive.


    Henk Panneman - http://www.homeserverweb.nl
    Tuesday, May 10, 2011 2:40 PM
    Moderator
  • Thanks Olaf and brubber. Judging by the posts I've read from both of you over some time, compared with you two, I'm just an enthusiastic amateur and bow to your expertise (BTW: I should have mentioned I was trying to restore Windows 7 Ultimate, 32-bit, and that my WHS is a Dec 2009 self-build, up-to-date, regularly maintained and functioning fully including a family website, without glitches, other than this).

    Brubber, thanks for the links about the Momentus XT. I haven't hit problems yet but then it's only been installed since the weekend - cross fingers! If the drive has weaknesses in the firmware (mine has the most recent), that could be a possible source of issues in the action I was attempting. Your reference to RAW: the drive was formatted NTFS before I started the restore - on the first failed attempt (from the Client Restore CD), the restore somehow converted it to RAW. Second attempt, it recreated the NTFS partition but left it blank. Third and fourth attempts using the IDE/ATA adapter, didn't work at all (as explained in my OP) - Ken Warren posted on another thread somewhere that's an alternative.

    Olaf, my attempted restore did recreate the partitions - it just failed in fully restoring the files to C:\ (I've seen conflicting advice on forums here and elsewhere as to whether it's necessary to pre-partition. I chose not to, maybe unwisely).

    I'm still slightly sceptical. I hope to have sufficient time this coming weekend to test restoring to a clean standard desktop drive; I'm going to try both Olag's suggestion of connecting directly via e-sata to my desktop and also using the IDE/ATA connector I tried previously.

    If my test is successful I'll post back.

    Thanks again

    Wednesday, May 11, 2011 10:43 AM