locked
Subscription to OneCare from Australia not working RRS feed

  • Question

  • I have been running the 90 day trial version of OneCare and would now like to buy it but every time I try to I get directed to a US only billing page and there is no option to change the country. My details on my Windows live account say that I live in Australia but I still can't access the correct billing page. Can someone help?
    Thanks
    Bec
    Monday, March 10, 2008 12:29 AM

Answers

  • I have tried all these suggestions, includingtrying to reach support which also didn't work, I followed all the instructions and it didn't work. Then I realised why. I don't use internet explorer, I use Firefox. So I open up exactly the same pages in IE and it works just fine. Looks like Microsoft trying to block out the competition again....
    Monday, March 10, 2008 11:47 PM

All replies

  • Have you checked that your Regional and Language Options in Control Panel are both set to Australia for Language and Location rather than the United States? I recall that OneCare is picky about this, though I believe you can change them back after you complete the registration process.

     

    OneCareBear

    Monday, March 10, 2008 5:37 AM
    Moderator
  • I checked this and it was already set to Australia for both country and language. When I go to the website, click 'get it now', it tells me it will be $99.95 (AUD) then when I click subscribe now, it says $49.95 plus taxes and is now in US dollars. From here it directs me to the US billing page. Hopefully that extra info helps
    Thanks
    Bec
    Monday, March 10, 2008 7:02 AM
  • Check your profile for the LiveID you are activating with - http://account.live.com and http://billing.microsoft.com and make sure that your address/location is identified correctly.

    Delete your cookies and temporary Internet files in IE and close all instances of IE. Open OneCare and try to activate once again.

    If this still fails to get you through the process for Australia, please contact support.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Monday, March 10, 2008 4:04 PM
    Moderator
  • I have tried all these suggestions, includingtrying to reach support which also didn't work, I followed all the instructions and it didn't work. Then I realised why. I don't use internet explorer, I use Firefox. So I open up exactly the same pages in IE and it works just fine. Looks like Microsoft trying to block out the competition again....
    Monday, March 10, 2008 11:47 PM
  • I wouldn't call it blocking out the competition, it is just that the process is optimized for IE. When problems do occur with the process, including accessing support, the best thing to try is to temporarily set your browser default to IE, give it a shot and once resolved, go back to your browser of choice. Yes, it should work better in all browsers...

    -steve

     

    Tuesday, March 11, 2008 1:31 AM
    Moderator