locked
Can't access data after SMB copy RRS feed

  • Question

  • I've had problems since day 1 getting automatic backups working on one of my PC's.  I tried pretty much everything and decided that it was time to do a format / clean reinstall (it's about time, lots of junk from others are on it).

    I used Robocopy to copy everything from the PC to my WHS using SMB.  Something like:

    robocopy c:\  \\Server\Public\01012009 /S /R:1 /W:1

    8 hours later the 64GB copy was done.

    When I went to take a look at the files copied over the Public directory shows as being EMPTY.  However when I look at it through the WHS Console it says it is taking up 63.93 GB, I just can see or access any of it.

    I tried the following with no luck
        looking at it via both a Guest account and a user acccount
        reboooting the WHS
        viewing the data via the WHS console Shared Folders tab | right click on Public | open

    1.  Ideal problem to solve - Getting access to the data on the drive.
    2.  If #1 isn't going to happen - How do I delete the data I copied yesterday?
    Friday, January 2, 2009 4:36 PM

Answers

  • Hi,
    Essentially, the difference between the D: files/folders and the others, are that the D: ones can be pointers (tombstones) pointing to the actual location of the data. This data can be moved by WHS to another physical location, particularly if you have multiple drives and duplication enabled.

    Just been checking about the 'hidden' files, and it's a RoboCopy problem. I see it's reported a few times and appears to appear sometimes when RoboCopy creates the destination folders: it ends up as a hidden folder and also a system folder, so cannot be unhidden. You could also try updating your version of RoboCopy, this document appears to have the latest version.

    Also, note that the 'Public' folder is a WHS required one, so really should remain. Just a thought, did you also go through ALL the options:
    1. Check "Display the contents of system folders"
    2. Select "Show hidden files and folders"
    3. UNcheck "Hide extensions for known file types"
    4. UNcheck "Hide protected operating system files". When prompted to click 'Yes' or 'No' to display the files you will have to select 'Yes'.
    5. Hit Apply.

    Colin



    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by wallys2 Friday, January 2, 2009 7:45 PM
    Friday, January 2, 2009 7:36 PM
    Moderator

All replies

  • Hi,

    Have you tried an RDP into your server, and then checking the Public folder on each of your drives? Apart from the folders seen on your D: drive, any other drives you may have, which will also have copies of your Shared Folders can be seen through C:\fs\(x)/DE\shares.

    Colin
    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Friday, January 2, 2009 6:23 PM
    Moderator
  • I had not tried that - didn't know I could...

    I RDP'd in and am seeing the same thing.  The folder in D:\shares\Public and D:\DE\shares\Public don't show any files in them.  Additionally, the status bar says 0 objects.  However, if I right-click on it and go to Properties, it finds the files because it includes them in the size.

    Some more info that may help:
        I only have one HD installed at the moment.
        The only data in the Public folder is this backup data so in theory I could blow away the folder if doing that would take the 70GB with it...
        I turned on 'view hidden files' and they didn't show up that way.
        They aren't visable via the cmd prompt.

    On a side note, what's the difference between what is in the root and in DE ?

    Thanks
    Friday, January 2, 2009 7:02 PM
  • Here is a new development...

    I found one of the files that got moved.  It was at D:\DE\shares\Public\Image01012009\....  (and also the equivalent not DE folder)
    which is where I put it.

    I can get there via the CMD prompt and see all the files if I go to that specific dir.

    What is the difference between the DE and non-DE folder?

    I could try to rename them or just delete them and start over with smaller chunks.  Any ideas or suggestions?
    Friday, January 2, 2009 7:15 PM
  • Hi,
    DE is, where the real data is, and may be located on d:\ or on c:\fs\<volumemountpoint for other disks>. This can be the shared files tmeself or this can be duplicated files.
    D:\shares is, where the tombstones are built, which are pointing to the files which you can see, if accessing them through the shares.
    Best greetings from Germany
    Olaf
    Friday, January 2, 2009 7:34 PM
    Moderator
  • Hi,
    Essentially, the difference between the D: files/folders and the others, are that the D: ones can be pointers (tombstones) pointing to the actual location of the data. This data can be moved by WHS to another physical location, particularly if you have multiple drives and duplication enabled.

    Just been checking about the 'hidden' files, and it's a RoboCopy problem. I see it's reported a few times and appears to appear sometimes when RoboCopy creates the destination folders: it ends up as a hidden folder and also a system folder, so cannot be unhidden. You could also try updating your version of RoboCopy, this document appears to have the latest version.

    Also, note that the 'Public' folder is a WHS required one, so really should remain. Just a thought, did you also go through ALL the options:
    1. Check "Display the contents of system folders"
    2. Select "Show hidden files and folders"
    3. UNcheck "Hide extensions for known file types"
    4. UNcheck "Hide protected operating system files". When prompted to click 'Yes' or 'No' to display the files you will have to select 'Yes'.
    5. Hit Apply.

    Colin



    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    • Marked as answer by wallys2 Friday, January 2, 2009 7:45 PM
    Friday, January 2, 2009 7:36 PM
    Moderator
  • That was it.  I had to tell it to show the protected OS files.

    Thanks very much for your help!
    Friday, January 2, 2009 7:45 PM